Skip to main content
Latest news: [[ newestAnnouncement.title ]] Learn more
InVision Support Home Page
Sign in
InVision ambassador ambassador
Tommy Silcher
Tommy Silcher Updated

Craft Player not working

When trying to view a prototype using the Craft player in Sketch I see an empty view with the title "button" and cannot change this behavior. I have an artboard selected and then click on the "Player" icon.

I have the latest version of both Sketch (Version 75 (129697)) and CraftManager (1.0.114) installed. I have tried restarting Sketch as well as Craft and reload the file. No go. Any idea on how to solve this?

This post is associated with a known feature request: [[ problemTicketSubject ]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.

2

comments

Sort by

Raynor B
InVision ambassador Raynor B , ambassador

Hi Tommy,

We're sorry to hear that you're running into some trouble with Craft, but thanks for reaching out to our Community.

I’ll be opening a ticket on your behalf with our Support team so they can dig into this further with you internally. Please keep an eye out for an email from one of our Support agents soon.

We'll look forward to assisting you via the ticket. 

Best,
Raynor

0
Jim
InVision ambassador Jim , ambassador


Hey Raynor B you have to fix this it has been this way for 2 weeks and I'm pulling out my hair trying to deliver a prototype.  Not only dopes the preview not work but there are issues with sketch components having undeletable interaction links associated with them (see purple vs blue arrows in the screenshot).  In order to fix this I have to detach all these elements from their symbol which is really goddamn annoying.

You guys decided to give up on invision studio and now your plugin doesn't even work....  What exactly is the purpose of InVision as a company???? Freehand? posting articles on twitter?

You should at least acknowledge this is a huge bug and say there is a roadmap to deal with it but instead we get radio silence.

1
Raynor B
InVision ambassador Raynor B , ambassador

Hi Jim,

I'm sorry to hear that you're encountering some issues with Craft. I can certainly understand how frustrating it is to encounter these bugs, so thanks for taking the time to reach out about these.

I'll be happy to pass these on to our Support team for assistance, so to that end, could you please confirm which versions of Craft, Sketch, and macOS are you running so I can include these details? 

Regarding the issue with the purple hotspots, this seems to be affecting Sketch 77 in particular. In similar instances, reverting to Sketch 76.1 resolved the issue. If you're using Sketch 77 or later, you might consider trying this. I realize that it's not ideal, but wanted to offer it as a possibly workaround for the interim. 

Looking forward to your reply!

Best,
Raynor

If anyone else is experiencing these issues, please submit a support request.

0

join the conversation

To comment, sign up or sign in.