Skip to main content
Latest news: [[ newestAnnouncement.title ]] Learn more
InVision Support Home Page
Sign in
InVision ambassador ambassador
Gino Molinaro
Gino Molinaro Updated

Craft Sign-In Issue

After 5 minutes or a short period of not using Craft, it signs me out - requiring a sign in with Invision every time I go to use Craft again. Please fix this.

This post is associated with a known feature request: [[ problemTicketSubject ]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.

6

comments

Sort by

Korene
InVision ambassador Korene , ambassador

I also have the same issue and it's getting worse with every time.  

4
Camille M
InVision ambassador Camille M , ambassador

Hi Gino and Korene,

So sorry to hear that you’re both running into this issue of being repeatedly signed out of Craft!

I’m opening a ticket on your behalf, Gino, with our Support team so they can troubleshoot with you internally. Please keep an eye out for an email from one of our Support agents soon.

Korene, I see that you already have a Support Ticket open with our team, and they've sent over some troubleshooting points.

I apologize for any frustration and disruption that this issue is causing you!

Thanks for hanging in there,

Camille

If anyone else is experiencing this issue, please submit a support request to report the issue you’re encountering.

0
TSU
InVision ambassador TSU , ambassador

Hi,

I have the same problem since mid-november. And I'm not the only one in my team to have it.

Can you please let me know if you find a solution?

 

Thank you.

3
jonmarc
InVision ambassador jonmarc , ambassador

Same here, I too am having the same problem that Craft will log me out. Sometimes whenever I make an update to a page and load it to Invision through Craft, it will not show that update either.

3
Camille M
InVision ambassador Camille M , ambassador

Hi TSU and Jon,

Thanks for sharing those details! This does sound like a bug our tearm are currently lookint into.

I’m opening a ticket on your behalf, Jon, with our Support team so they can troubleshoot with you internally. Please keep an eye out for an email from one of our Support agents soon.

TSU, I see that you already have a Support Ticket open with our team, and they've sent over some troubleshooting points.

Cheers,

Camille

0
Mor Daniel
InVision ambassador Mor Daniel , ambassador

Hi, my team has the same bug, when is it going to be fixed?

2
Gino Molinaro
InVision ambassador Gino Molinaro , ambassador

For me there is no solution with someone that is currently using the Brave browser. I've heard from Invision support that clearing the cache and cookies might work as the only other step.

0
Darryl Edwards
InVision ambassador Darryl Edwards , ambassador

I can confirm that this issue is still very persistent on the chrome browser.
Sometimes login sessions can last as little as 10 minutes - this breaks up workflow as I'm constantly having to re-sign in each time I want to upload a new change.

I tried clearing all cache and cookies, plus made sure craft is up to date. The issue is still there.

@... is there a temporary fix for this so that log in sessions will at least last for my working day?

Is there an ETA on when this will be fixed?

0
Camille M
InVision ambassador Camille M , ambassador

Hi Darryl,

Thanks for following up! I see that you had already opened a ticket regarding this issue and a member of our Support team was working with you on this. 

If you have any additional questions, please feel reply to that ticket or let us know here.

Regards,

Camille

0
Darryl Edwards
InVision ambassador Darryl Edwards , ambassador

Temporary solution suggested by Invision support:

  1. Open your default/main browser that Craft opens when trying to authenticate
  2. Log out of all/any InVision sessions in your default/main browser
  3. Close/Quit your browser
  4. Select the Craft Manager "C" in the upper macOS menu bar
  5. Select the settings wheel, and select Sign Out
  6. Close/Quit Craft
  7. Proceed to Finder > Applications > Utilities > Activity Monitor
  8. Locate any 'Craft' processes
  9. Quit all/any 'Craft' processes in Activity Monitor
  10. Return to Finder > Applications 
  11. Open Craft Manager
  12. Select the Craft Manager "C"
  13. Select the settings wheel, and select to Sign In
  14. When your default/main browser opens, copy the URL in the address bar
  15. Open another/different browser (i.e; if using Chrome, open Safari)
  16. Paste the copied URL into the different browsers address bar and proceed to the webpage
  17. Attempt to authenticate via the other/different browser using "Know your team domain?"
0
Michael S
InVision ambassador Michael S , ambassador

Hi Darryl,

Thanks for sharing this here! Hopefully others find this helpful if they run into this issue as well. Since you have a ticket open with us, rest assured we will be sure to send any updates to you via email. If you have any follow up questions on the issue, feel free to reply to that email as well. Let us know if there is anything else we can do here to help for now!

Thanks
Michael

0
Chris Gonzales
InVision ambassador Chris Gonzales , ambassador Edited

Other Craft users at my company have also encountered this issue. Has there been any update on this?

0
Raynor B
InVision ambassador Raynor B , InVision Employee , ambassador

Hi Chris,

Thanks for getting in touch via our Community. 

Reports of similar issues — being signed out frequently in Craft — have been resolved by clearing the cache and cookies from the default browser. Instructions for this are here: How do I clear my browser's cache and cookies?

I would recommend have your colleagues try this and seeing if this resolves the issue for them.

If not, please let us know (or have them reach out themselves), and confirm the following:

  • Could you provide screenshots or a recording of the issue occurring, particularly any error messages?
  • Which versions of Craft and Sketch are they running? 

Thanks, Chris!

Best,
Raynor

0
Darryl Edwards
InVision ambassador Darryl Edwards , ambassador

Chris Gonzales our team had the same issue, I can confirm these steps work:

  1. Open your default/main browser that Craft opens when trying to authenticate
  2. Log out of all/any InVision sessions in your default/main browser
  3. Close/Quit your browser
  4. Select the Craft Manager "C" in the upper macOS menu bar
  5. Select the settings wheel, and select Sign Out
  6. Close/Quit Craft
  7. Proceed to Finder > Applications > Utilities > Activity Monitor
  8. Locate any 'Craft' processes
  9. Quit all/any 'Craft' processes in Activity Monitor
  10. Return to Finder > Applications 
  11. Open Craft Manager
  12. Select the Craft Manager "C"
  13. Select the settings wheel, and select to Sign In
  14. When your default/main browser opens, copy the URL in the address bar
  15. Open another/different browser (i.e; if using Chrome, open Safari)
  16. Paste the copied URL into the different browsers address bar and proceed to the webpage
  17. Attempt to authenticate via the other/different browser using "Know your team domain?"

I have performed the above steps 5+ times and it fixes the issue every time, however, it would be really nice if InVision fixed the issue rather than having us fix the issue for ourselves. At this point, it's been 4 months since this issue was first reported...

0

join the conversation

To comment, sign up or sign in.