Sorry, the InVision Help Center does not support Internet Explorer. Please download Microsoft Edge or another modern browser.


InVision ambassador ambassador
Jon Armstrong

Hotspot goes to mid-screen instead of top of screen

Sketch: Version 67.2 (100443)

Craft: 1.0.98

Mobile browser: Safari iOS (iOS 13.5.1)

I have a prototype that when viewed on desktop, all the hotspots function as intended. However, when opening the public share link (the one we are trying to use to test on device, without requiring users to install the InVision iOS app), one of the hotspots from the homepage transitions to the correct screen, but then jumps down the screen by a set amount. It doesn't matter what we do in terms of hotspot creation. If we use Craft inside of Sketch to select the object and define the transition in Sketch or we use the desktop browser to define the hotspot and transition, the behavior is the same. And this behavior will destroy any user testing results we try to get. I haven't seen this behavior before unless "Maintain scroll position after transition" is checked. It is not checked for this hotspot. We've checked it, uploaded. Unchecked it, uploaded. All to no avail. Thanks in advance for any help.

This post is associated with a known feature request: [[problemTicketSubject]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.

comments

sort by


Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Hi Jon,

Thanks for reaching out here in Community! Sorry to hear that you're running into some issues with one of your hotspots when attempting to view on your mobile browser. To get a better idea of what might be causing this, can you please provide some additional information?:

  1. Your mobile device details 
  2. A screencast or screenshot(s) displaying the issues you've described
  3. A screenshot of your hotspot settings
  4. Is this happening with just the one hotspot you've mentioned or many?
  5. Is this happening across multiple prototypes?
  6. Have you attempted to view this prototype in the InVision iOS mobile app? If so, does this same issue occur?
  7. Have you tried viewing the prototype in an incognito/private window? If so, does the issue occur

Look forward to hearing from you,

Shaina

0

Jon Armstrong
InVision ambassador Jon Armstrong , ambassador
Comment actions Permalink

Thank you for getting back to me so quickly! I've filed a support ticket (705372) and have responded there. For the sake of any others that may follow:

Your mobile device details:

iPhone XS Max running iOS 13.5.1 (updated today to 13.6)

Browser details: Safari for iOS version 13.1

Hotspot settings (it doesn't matter if I use Craft inside of Sketch or use the online prototype Build editor, it still doesn't respect these settings):

It only happens with this hotspot, despite have two other similar hotspots where the landing screen is much taller than the starting screen.

It is happening for just this prototype.

It does not occur when I view the prototype in the Invision iOS app.

Incognito (on desktop, it does not occur; on mobile it doesn't matter if it's incognito mode or not, the issue happens.

Thanks again for reaching out. If I get a solution from the formal support ticket, I'll update here.

 

0

join the conversation

to comment, sign up or sign in.