Sorry, the InVision Help Center does not support Internet Explorer. Please download Microsoft Edge or another modern browser.

InVision ambassador ambassador
Elliott Edited

Motion Animation with Overridden Components

Hey, I'm working on a profile swipe left/right prototype. While the swiping worked great using just rectangles, once I created my profile component and tried to swipe between those, I got strange animation transitions using Motion.

Basically, I have 4 profile components stacked on top of one another and as one is swiped away, the next should fade in and grow to the size of the original. I appears that maybe Motion is getting confused about which profile component to animate even though I have named each profile uniquely (profile.0, profile.1, etc).

The widths of the profile components are animated wrong. On the first frame of the animation in the Timeline, they jump to odd widths, then animate to other widths, then jump to the correct widths on the last frame of the timeline. 

I tried deleting my second artwork and recreating it from a copy of the first storyboard, but still have the same problem.

Any idea on a work around for this? After spending nearly a week getting the profile components completed I can't animate between the components. While my tests with XD have worked fine, I'd rather not recreate my work in Adobe (and have to abandon InVision).

This post is associated with a known feature request: [[problemTicketSubject]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.


sort by

Michael S
InVision ambassador Michael S, InVision Employee , ambassador
Comment actions Permalink

Hi Elliott!

Thanks for getting in touch about this, and I'm sorry to hear about the trouble! When you have a chance, would you mind saving your Studio file, quit the Studio application and re-open it to see if you get different results?

If this doesn't seem to help, please provide the following information for us.

  1. Can you please send a screenshot of the About This Mac overview? (click the Apple icon > About This Mac)
    - If you're using a Windows machine, we need to see both the “Device specifications” and the “Windows specifications” sections on the “About” page. To grab that info, click the Start (Windows icon) button, and then click Settings > System > About.
  2. What version of Studio are you using?
  3. Would you be able to record a screencast showing what’s going wrong?

We look forward to hearing back from you and helping to get this resolved!




InVision ambassador Elliott , ambassador Edited
Comment actions Permalink

Sure. Restarting doesn't do anything.


Here is the unlisted screencast:


MacOS and Studio are latest versions:



Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador
Comment actions Permalink

Thanks for trying Michael's suggestion above and for providing these details, Elliott. At this point, I would like for our Support team to take a look directly at your file to see if they can spot the source of this issue.

I will open a ticket on your behalf with our Support team including all of the details that you've provided here. Please keep an eye out for an email from one of our Support agents soon.

Thanks for reporting this,



join the conversation

to comment, sign up or sign in.