Sorry, the InVision Help Center does not support Internet Explorer. Please download Microsoft Edge or another modern browser.


InVision ambassador ambassador
Roshni Ghedia

Craft plugin not syncing with sketch

My craft plugin keeps throwing up the same error when I try syncing my artboards from sketch to Invision - that the file is not readable and it does not sync. It creates a project in Invision, but with no artboards in it. I've tried reinstalling the plugin but no luck - any ideas? Thank you.

 

 

This post is associated with a known feature request: [[problemTicketSubject]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.

comments

sort by


Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Hi Roshni,

Thanks for reaching out, and our apologies for this trouble with Craft.

So we can take a closer look into this, could you please provide the following details:

  1. Do you see the same error if using a different WiFi or data connection? If using a VPN or proxy, does it help if you temporarily turn it off? I'd like to exclude the possibility of this trouble being related to a whitelisting issue.
  2. Could you send a screenshot showing the error message you're receiving?
  3. Are you encountering this issue when syncing all Sketch files, or only with a specific file?
  4. What version of Sketch are you using?
  5. What version of Craft Manager are you running?
  6. Would you be able to send the CraftManager log files? The log files are located in ~/Library/Application Support/CraftManager/logs​. You can either paste this path into Spotlight or use Finder (Go > Go To Folder…). Simply compress the folder's contents and attach the resulting zip file to your reply.

This information will help us to further investigate the issue. I look forward to your response!

Best,

Shaina

0

Roshni Ghedia
InVision ambassador Roshni Ghedia , ambassador
Comment actions Permalink

Hi Shaina,

Thanks for your quick response.

  1. Do you see the same error if using a different WiFi or data connection? If using a VPN or proxy, does it help if you temporarily turn it off? I'd like to exclude the possibility of this trouble being related to a whitelisting issue. - Yes the same problem happens regardless of my connection, I've tried hotspot and wifi and not going through a VPN.

 

  1. Could you send a screenshot showing the error message you're receiving? - Sure, please see below. It does not allow me to select all artboards on the page (that option is simply not clickable) and it also says 'filenotreadable' at the bottom.

 

 

  1. Are you encountering this issue when syncing all Sketch files, or only with a specific file? - I cannot sync any files - so both
  2. What version of Sketch are you using? Version 66.1 (97080)
  3. What version of Craft Manager are you running? v1.0.96 (193)
  4. Would you be able to send the CraftManager log files? The log files are located in ~/Library/Application Support/CraftManager/logs​. You can either paste this path into Spotlight or use Finder (Go > Go To Folder…). Simply compress the folder's contents and attach the resulting zip file to your reply. I have them, but this support chat won't allow me to upload them due to the upload limit of 2MB - is there an email address I can forward them to? Many thanks
1

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Thanks for providing those details, Roshni! Based on the error, I believe the issue is due to some permission problems with Craft and MacOS Catalina. To fix this could you please try the following troubleshooting steps:

  1. Click on the Apple menu  in your Mac's menu bar and select System Preferences.
  2. Select the Security & Privacy section.
  3. Click the Privacy tab and select Full Disk Access.
  4. Click the lock in the bottom left corner and enter your password to make changes.
  5. Click the checkbox next to the CraftManager app to grant access, then click the lock icon to save the change.

After this please restart both Sketch and Craft Manager and try to sync again. Let me know how this goes for you!

Look forward to hearing back,

Shaina

2

Roshni Ghedia
InVision ambassador Roshni Ghedia , ambassador
Comment actions Permalink

That's really helpful, thank you - it worked!

0

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Glad to hear that worked for you, Roshni! Please don't hesitate to reach out any time we can help.

Have a great day,

Shaina

0

jeyson lopez
InVision ambassador jeyson lopez , ambassador
Comment actions Permalink

Is there a way to get craft to work without giving the app full disk access? that seems a bit excessive 

0

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Hi Jeyson,

You shouldn’t need to provide full disk access unless you would like to pull Sketch files from anywhere on your Mac.You are able to allow access to certain folders, and Craft should still cooperate properly. The caveat is, Craft needs access to Downloads and Documents in order to access the Sketch file so we can sync it.

Technically, it will work properly if you provide just Downloads folder access, but you might run into troubles if you start using it more regularly. The messaging to allow "full disk access" might happen if you try to pull in a Sketch file from a specific folder.

Please let me know if that helps clear things up or if you have any outstanding questions.

Thanks,
Shaina
 
0

join the conversation

to comment, sign up or sign in.