Skip to main content
InVision Support Home Page
InVision ambassador ambassador
Lucas
Lucas Updated

Something went wrong when I publish prototype

Hi,

I very often have the same message which prevents me from publishing prototype : "Something went wrong - Please try again. If the problem persists, try signing out and in again." 

I try to save a new file, delete elements, it always starts again ... how to avoid the problem?

PLEASE HELP ! 

other than that i love inVision studio.

Best ++

Lucas L. 
https://bigcheese.fr/

This post is associated with a known feature request: [[ problemTicketSubject ]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.

1

comments

Sort by

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Hi Akos,

Thanks for reaching out on this thread. I understand how frustrating it is to wait for a fix to an issue. The Engineering team is aware of the issues reported in this thread and they're actively researching a solution. This is an issue that I have been in contact with the Studio Product Managers about on a weekly basis. We understand that this is a huge blocker for many users and we're so sorry for the impact that this is having on everyone encountering these publishing errors.

I can assure you that each of the users who have reported this issue are receiving support. However, several of these cases mentioned in this Community thread are linked up to different known issues that our teams are investigating.

To determine exactly which known issue you're encountering, can you please provide some additional information as requested from others above?:

  1. A screenshot of your "About this Mac" overview or other OS details.
  2. The version of Studio that you're using.
  3. A screenshot showing the error message that you're encountering.
  4. Is this happening with all prototypes or just one in particular?
  5. Are you able to publish successfully if you connect to an alternate network (no VPN, firewalls, proxies, etc.), if available?

One workaround that I can recommend in the interim is to sign out and sign back into your account in Studio, try copying each artboard necessary to a new file, give the file a new a new name and attempt to re-publish the prototype. While I can't guarantee this will work, we have seen success with this from some of the users.

Again, I'm terribly sorry for any inconvenience that this has caused but please let us know if there is anything that we can do to help you further in the meantime.

Best,

Shaina

-1
Akos Toth
InVision ambassador Akos Toth , ambassador

Hello Shaina,

It is just getting so long and we are running same circles again and again:

1.
I have already sent you
2.
Same thingnas above

3. Same

4.
So far all 4 prototypes a have designed

5.

I have changed to my mobile network as well. Same problem.
6.
Of course I have tried to quit, sign out and in again, retsart and all those things as usual when having problems. Did not helped.

7.
An d finally. When you have 10- 20 artboards does not semms reasonable to copy all and start building interactions again. But I have tired it just copying only two artboards. Not helped unfortunately. :(

I was thinking to go old method to show to client all the artboards as pdf files, but unfortunately I get svg file which is not carries the typefaces and inserted pictures. Any idea how could be exported all artboards as a look?

Thanks: Ákos

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Thanks for providing all of those details, Akos. I know that it can be a bit time consuming to put all of that together, but we really appreciate having all of the information pertaining each individual's specific issue. Additionally, thanks for testing out the workaround. We definitely know this is not ideal and our team continues to work towards a solution.

At this point, I will open a ticket on your behalf with our Support team including all of the information that you've provided. They will be able to troubleshoot more internally to determine exactly which known issue you're encountering. Please keep an eye out for an email from one of our Support agents. 

Thanks for hanging in there,

Shaina

-1
Nelson Secco Filho
InVision ambassador Nelson Secco Filho , ambassador

Good afternoon guys from the invision studio team, I need help. My invision has stopped publishing and unfortunately many people are having this problem. I just created a project from scratch with all the screens and interactions in invision studio.

To my surprise when I went to publish this message appeared.

 

Eu trabalhava com o Adobe Xd e como a empresa já tinha seus projetos no Invision optei em manter dentro do ecossitema já existente, mas se o Invision Studio não for seguro e confiável o como podemos seguir?

Conto com o suporte de vocês.

Estou trabalhando com o Invision no windows 10 e minha versao do Invision Studio é a 1.28.1


I also tested it on my personal account and the error is the same.
I did the test on windows and 2 macbooks that I have at home.

I really liked the software but if it is not reliable how to work professionally with it?

I count on all your support.

 

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

I'm so sorry to see that you're also running into this issue, Nelson! We appreciate you taking the time to report this, and definitely want to officially log it with our Support and Engineering teams.

That being said, I'm going to open a ticket on your behalf with our Support team. Please look out for an email from one of our Support agents soon who may have some follow up questions.

Thanks for hanging in there,

Shaina

0
Tom
InVision ambassador Tom , ambassador

Seems like theres been no resolution on this issue, and i'm having the same trouble. Made sure I'm running the latest version of studio, logged out, logged back in, tried recreating the protoype in a new file with a new name, same issue.

 

0
Timothy Dziewit
InVision ambassador Timothy Dziewit , ambassador

Hi,

Been having the same issues as everyone else for about 2 months now.
Done all of the suggestions to try to evolve, including copying and pasting into a new document... with now luck.

 

Thanks in advance for the help.

0
Sorin C Cucu
InVision ambassador Sorin C Cucu , ambassador

Timothy Dziewit Tom

Really sorry for you gents. My recommandation is to try to make the source files lighter. 

Try this test:

1, Save another copy so u are sure u don't lose anything.
2. Now, start deleting artboards 1 by 1 and with each try to publish.

3. At some point you'll not receive the error anymore. That's the max of elements your source can hold. What comes above it will get u the error.

4. U either keep the deleted artboards or u restore them and try to flatten elements inside. 

5. In my case - I've grouped together and flattened much of the elements which had no interactive side. How?
(Select them inside Invision and paste them into Sketch - it will paste them as flatten and .jpg - delete them from Invision - and paste the new .jpg instead.)

I know it sound complicated but try this test. It will make u understand how this work.

For Invision Support:
This problem is 6months old now. When do you plan to solve it?

Regards,
Sorin

0
Nik Finan
InVision ambassador Nik Finan , ambassador

Hi

I am also getting the same issue uploading a prototype from Invision Studio, Do you have an expected fix date? - the console output while trying to upload was:

shared_bundle.js:29 [bugsnag] Usage error. notify() expected error/opts parameters, got unsupported object
Me @ shared_bundle.js:29
e @ shared_bundle.js:29
notify @ shared_bundle.js:29
y @ preview.js:1
(anonymous) @ preview.js:1
emit @ events.js:194

Machine and versions info is:

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Sorry to hear that you're also running into these issues, Nik. It looks like you're running an outdated version of Studio. Can you please trying updating to the latest version of Studio 1.28.1 and let us know if you continue to run into issues?

If you continue running into this issue, can you also please provide a screenshot of the error message(s) you're encountering?

Thanks in advance,

Shaina

0
Nick Runco
InVision ambassador Nick Runco , ambassador

Hi all -

I had this issue as well, and none of the previous recommendations helped (sign out, pasting artboards into new doc, etc.). I slowly narrowed down the issue to fewer and fewer artboards and was able to isolate the error to some textboxes that contained specific fonts. Once I replaced those fonts, the "Something went wrong" issue went away, everything could publish. That font also was not rendering correctly anyway.

Font files are notorious for screwing up layout files, so it's not a surprise! This might also explain why @Sorin recommended flattening files. I'm sure this isn't everyone's issue, but it helped me, so maybe it will help someone else, or help the InVision team debug this thing. So, check your fonts! Or run a test where you replace all your fonts with something like Helvetica. (I know, I know. It's just a test.)

Hope this helps!

Nick

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Thank so much for popping in here to share what helped you with this issue, Nick. I'm sure it will help others running into this issue!

If you haven't already reported this with our Support team, please let me know. The more reports we have of issues like this helps our team as they work to find a solution.

Thanks again for your help here!

Shaina

0
Seulki Lee
InVision ambassador Seulki Lee , ambassador

I also have same problem. Is there no answer to solve this problem?

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Hi Seulki,

We have seen several users encounter this issue due to different causes. I get a better idea of what might be causing this for you, can you please provide the following information?:

  1. The version of Studio that you're using
  2. A screenshot of your "About this Mac" overview
  3. Have you attempted any of the suggestions provided by other users above?

Look forward to hearing back,

Shaina

0
Atwell Design
InVision ambassador Atwell Design , ambassador Edited

Wow--disheartening to see this still not resolved. We've signed in again and again--same failure each time--on files I previously published a month ago with no problem!!! We had a client delay and now we can no longer publish prototypes on the same project of the same complexity that worked in May. Very upsetting. Really makes my design firm look bad. We're having to go in front of a client today with static pdf files because these won't publish to InVision. Big big fail. 

By the way, one of the files that won't publish has 2 artboards, each with a static jpeg in them and one animation/transition. I mean.... really?

0
Tom
InVision ambassador Tom , ambassador

Same here. had this issue a while back discovered it was the fonts at the time, but luckily it was a new client so i was able to shift fonts no problem and got it working again.  got a new client with established look and design, built the entire prototype and went to publish, and BAM, 'oops something went wrong.' opened up a brand new project to test each font individually with the simple words, 'test' each failed. tried it with just arial, failed to publish even that.  this system doesn't seem to work at all anymore and on tight deadlines like many of us have (my project was due today and i have to hand in exported flat jpgs), it makes us look terrible and like we dont know what we're doing. and every time we come to this message board to bring up issues we get the same 'post screen shots' followed by nothing for months, and no resolution. I think we've officially gave up on invision as a team, and its a shame- it had a lot of potential.

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador Edited

We completely understand how frustrating this issue has been for each of you and the other users that have reported this. We're terribly sorry for this and understand how it can cause a major disruption to your workflow!

I can assure you that this issue continues to be raised with our Studio team. The Studio Engineering, Product, and Design teams have been hard at work building a brand new release of Studio to address issues like this one. We’re evolving Studio for the long term focusing on improving performance, usability, and how you collaborate within your teams. The investments we are making today will also enable us to respond to your needs more quickly in the future.

We’re committed to keeping everyone informed on what’s next, as we track closer to a shareable date. In the meantime, we want to pull back the curtain a bit. I'm really sorry to hear that the wait has caused some teams to move on from InVision. It bums us out and hope we can earn you back for usage on future projects!

As for the more immediate future, I want to make sure that we formally report this with our team. That being said, I will be opening a ticket on your behalf with our Support team so that they can test internally and see if we can offer a solution in the meantime.

Tom• Are you and your team still encountering these issues? I looked back into your ticket history and it looks like you were able to find a solution with the fonts in your design. If you're still having issues, we absolutely want to make sure to help! Let me know and I will get you back in touch with our Support team if needed.

Thanks all for your patience,

Shaina

0
Kevin The
InVision ambassador Kevin The , ambassador

Hi everyone,

 

I am experiencing the same exact issue here with my Invision Studio file. 

My case :

I'm trying to build a prototype with around 10-20ish pages, and when I'm publishing the prototype from my Studio to Invision web account, it generates well up to the point where "Uploading assets ... " then it just crashed down and closed my Invision software altogether. Then the "Invision Studio quit unexpectedly" message appears.

What i've done :

Following advices from this tried, here's a list of what i've done - none resulting in me having my project successfully uploaded to my Invision account.

1. Sign out and sign in again. Not working.

2. Create a duplicate Studio file. Not working.

3. Reducing assets in my file (removed unused and large asset/images). Still not working.

4. Remove all the linked artboards in my prototype. Still not working.

5. Asking my co-worker to use his Mac with the exact same file, uploaded to my own account. Still not working.

Weirdly I tested with a blank prototype with linking artboards and its working - so my hypothesis is that the bug might be in the file. For your reference - the .Studio file that we use, I converted it from a .Sketch file.

The Problem

For the records, our company had paid Invision web account, and we need this project to be published for clients for see by end of this week. On previous project this works just fine (and our previous project has larger number of screens as well - around 50-60 screens).

However the problem here is our Front-End team might need this Invision Studio prototype on web so that they can inspect it on the prototype with "Inspect" feature. This is our usual working flow for handing over assets, and primarily why we choose Invision + Studio, because it integrates everything in just one platform. When this bug happens, its very disappointing and slowing down our working process. 

Please do look into this case as soon as possible, and waiting for your reply. Thanks!

 

Attached is the screenshot of my About Mac and Studio version info.

0
Camille M
InVision ambassador Camille M , InVision Employee , ambassador

Hi Kevin,

So sorry to hear that you’re running into this issue! Thanks for providing the details you have here in Community for our team to use for further troubleshooting.

It does sound like your issue may be related to this file in particular, so I’m opening a ticket on your behalf with our Support team so they can get a copy of the file from you to troubleshoot with you internally. Please keep an eye out for an email from one of our Support agents soon.

I apologize for any frustration and disruption that this issue is causing you!

Thanks for hanging in there,
Camille

0

join the conversation

To comment, sign up or sign in.