Sorry, the InVision Help Center does not support Internet Explorer. Please download Microsoft Edge or another modern browser.


InVision ambassador ambassador
Felipe de Castro

Link to DSM is not present in nested components

When I'm inspecting a prototype that uses components from a DSM library I can see a link to the DSM page of that component and that's fabulous! The problem is that I can't see this link in nested components, which is really frustrating.

In other words, if a component owns another component inside, then I can only see the DSM link for the father one and none for the child.

Am I doing something wrong?

This post is associated with a known feature request: [[problemTicketSubject]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.

comments

sort by

official comment

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

UPDATE

I wanted to pop in here to let you all know that the issue where DSM Data in Inspect was not appearing for Symbols which are nested inside another symbol/component is now resolved in Sketch 67.1

Nested symbols that used to display as folders in Inspect are now showing as symbols. DSM Data is also now appearing in Inspect in the right panel and the symbols show as purple in the layers panel on the left. You will need to update to Sketch 67 and re-sync your affected files for the changes to show 😄​ . 

Thank you for your patience while we repaired this issue, and please reach out if you run into any hiccups! 


Laura Cunha
InVision ambassador Laura Cunha, InVision Employee , ambassador
Comment actions Permalink

Hi Felipe,

Thank you for taking the time to share your thoughts here in Community!

From my own testing, it does seem that the expected behaviour is that only the specific parent component displays DSM information in Inspect. In any case, I'll go ahead and open a support ticket on your behalf, so that our team can have a closer look into this. Please keep an eye out for an email from our team!

Best,
Laura

0

Christian Murra
InVision ambassador Christian Murra , ambassador
Comment actions Permalink

Hello Laura,

we are experiencing the same problem and are quite sure it already worked. 

We rely on using our library that way to communicate with our development and other people.

Is there any information "if" and "when" this feature will be usable again?

 

Thanks,

Christian

0

Mike Siegle
InVision ambassador Mike Siegle, InVision Employee , ambassador
Comment actions Permalink

Hey Christian, 

It's Mike from InVision Support here. I'm really sorry to hear you're having these troubles as well. 

After reviewing this thread and checking our processes, DSM does indeed work this way with nested components. Sadly, we won't be able to tell you when or if this will be added, but we'd be more than happy to take a look into this with you to see if you're experiencing the same issues as Felipe or not.

If you are having these issues, we can certainly add your vote to this request and possibly find a solution that works for your team until we've developed this ability.  

Again, I'm really sorry for the trouble this has caused your team. Please let us know if there's anything we can do to help! 

Best, 

Mike

0

Christian Murra
InVision ambassador Christian Murra , ambassador
Comment actions Permalink

Hi Mike,

it's not a function that is new. It has already worked about 6 or 7 month ago.

Because of that we build our libraries accordingly. 

We have projects where it is still possible to use as described but as soon as I upload a newer version (even without changes made) the nested symbols are reverted to basic components.

So something has changed how invision or craft handles the uploads and displays them in inspect-mode.

 

Regards,

Christian

 

0

Mike Siegle
InVision ambassador Mike Siegle, InVision Employee , ambassador
Comment actions Permalink

Hey Christian, 

Thanks so much for the update and my apologies for any misunderstanding here. 

To ensure we're all on the same page, I'd like to get a visual of your symbols and how they are setup. 

With that being said, can you please provide the following details: 

  1. Can you send a screenshot showing your master symbol and the nested layers you're having these troubles with? 
  2. If possible, can you send us a before and after screenshots of the master and nested symbols mentioned above?

Once we have these details, we should have a better idea why this is taking place. 

Again, sorry this is happening to you and if there's anything we can do to help, please let us know. 

Looking forward to hearing back!

All the best, 

Mike

0

Christian Murra
InVision ambassador Christian Murra , ambassador
Comment actions Permalink

Hopefully this describes the problem:

These are Screenshots from the same Project, coming from the same Sketch-File.

– The left is taken from an upload from 9 month ago. Here you can see that the "Building Block" and the Control nested within it point to different locations in the DSM describing their own properties. A behaviour which we needed and used.

– On the right you can see an upload from yesterday and the nested symbol is reverted to basic objects without any connection to the used control-symbol nor any link to the DSM.

This happens in other projects too but we saw it too late and since there is no rollback to older versions of an upload we are stuck with it. The parent element has now a sketch symbol, which is nice but not really helpful in this case. 😉 Something has happened with how Invision handles the upload since this Sketch-Icon appeared or with the upload via Craft. 

We really hope that you are able to identify the problem.

Thank you,

Christian

 

0

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Hi Christian,

Thanks for taking the time to provide those screenshots and additional information. Before passing this along to our Support team to do some testing with your file, can you please provide the following information as well?:

  1. A screenshot of your "About this Mac" overview
  2. The version of Sketch that you're using
  3. The version of DSM that you're using
  4. The version of Craft Manager that you're running

Have a noticed a difference in what appears when you click the arrow for the dropdown items under "Item 1" for example? There's a known issue at the moment where nested symbols are appearing as folders instead of symbols. This is what Felipe reported above. If that's the case, I'll get a ticket opened on your behalf so we can confirm this is the same issue you're encountering. 

Thanks in advance,

Shaina

0

Christian Murra
InVision ambassador Christian Murra , ambassador
Comment actions Permalink

Hello Shaina,

1.) I'm using a 2019 15" Macbook Pro with macOS 10.15.3. 

2.) Sketch 64

3.)  ? Where can I look that up?

4.) 1.0.95

 

As described the "Item" is reverted to basic elements within a folder and not a symbol anymore.

 

0

Laura Cunha
InVision ambassador Laura Cunha, InVision Employee , ambassador
Comment actions Permalink

Hi Christian,

Thank you for confirming! We'll go ahead and open at support ticket on your behalf, so that our team can have a closer look. Please keep an eye out for an email from us!

Cheers,
Laura

0

Vincent
InVision ambassador Vincent , ambassador
Comment actions Permalink

Hi InVision team, 

 

We have the same problem !

Can we know when it will be fixe ? 

 

Thanks by advance, 

Vincent

0

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Hi Vincent,

Sorry to hear that you're also running into this issue! We definitely want to get this reported with out Support team. In order to get an accurate report of your experience, can you please provide the following details?:

  1. A screenshot of your "About this Mac" overview.
  2. The version of Sketch that you're using.
  3. The version of DSM that you're using.
  4. The version of Craft Manager that you're running.
  5. Any screencasts or screenshots displaying the issues that you're running into.

The issue that Christian reported above has been logged as a known issue with our Support and Engineering teams. I understand how frustrating it is to wait for a fix to an issue. The Engineering team is aware of the issue but we prioritize issues based on the scope and impact of the issue. For that reason, we are unable to provide an ETA for a fix on this issue.

Look forward to hearing back from you with the details requested above,

Shaina

0

join the conversation

to comment, sign up or sign in.