Skip to main content
Latest news: [[ newestAnnouncement.title ]] Learn more
InVision Support Home Page
Sign in
InVision ambassador ambassador
Mike Ortega
Mike Ortega Updated

Craft keeps logging me out every time I up a project to inVision via Sketch

Getting to the point of ridiculous. Craft keeps logging me out every time i up a project to inVision via Sketch, literally, I can upload artboards, and within 15 seconds try and upload another batch, and it autologs me off before I can even do it.

I've deleted the plugin, installed the latest version of the plugin several times. v1.0.92

I'm also on the latest version of Sketch. v63.1(92452)

This has been going on for at least a week now. It's awful.

This post is associated with a known feature request: [[ problemTicketSubject ]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.

6

comments

Sort by

official comment

Camille M
InVision ambassador Camille M , ambassador

Hi all,

I hope this note finds everyone well. I wanted to follow up regarding the issue you were experiencing where Craft was signing our users during syncing.

We're happy to announce that our Engineers were able to get that issue fixed and you should not expect to encounter it any longer. When you have a moment, please try syncing your prototype to find that your sync functions as normal.

If you're still having trouble, please do let us know. Otherwise, thanks for your patience while we worked to fix this issue.

All the best,

Camille

If anyone is still experiencing issues with Craft signing them out, please submit a support request to report the issue you’re encountering.

Jeremy Bauer
InVision ambassador Jeremy Bauer , ambassador

Hi Mike,

Thank you for reaching out here in Community! I'm so sorry you're having this Craft logout trouble. Could you answer a few questions to help us look into this?

  1. What version of macOS are you using?
  2. When Craft logs you out, are you shown any error message?
  3. If possible, can you share a screenshot or screencast of this logout issue and any error message you may be receiving?
  4. If you switch to another network, do you have the same logout issue afterwards?
  5. Are you using a proxy, VPN, firewall, or other network security service?

Looking forward to investigating this further, Mike!

Best,
Jeremy

-1
Mike Ortega
InVision ambassador Mike Ortega , ambassador Edited

Thanks Jeremy - This literally just started last week. No config changes at all.

In the file that I am working with, I have a single page with 6 sets of flows with multiple artboards in each flow. I also have a symbols page.

If i hurry, and go as fast as I can, I can get 2 sets of artboards to upload before it signs me out, only 1 set if i go slow. I see no real error message, it just says either "Something went wrong!" in red letters at the bottom of the craft modal and spins for a second or two then signs me out; or just blanks and goes back to the "You're signed out" screen when i hit the sync button on the tool panel.


I have saved it as a screen recording with the error replicated, but due to the nature of my work, I can't post the video here. I can email it directly to you if needed.

Same problem with whatever network I join.

Issue is with VPN and without VPN.

Thanks!

0
Camille M
InVision ambassador Camille M , ambassador

Hi Mike,

Thanks for providing the details you have here in Community for our team to use for further troubleshooting.

I’m opening a ticket on your behalf with our Support team so they can troubleshoot with you internally. Please keep an eye out for an email from one of our Support agents soon.

I apologize for any frustration and disruption that this issue is causing you!

Thanks for hanging in there,
Camille

0
Thi_Le symantec com
InVision ambassador Thi_Le symantec com , ambassador

I'm having the same problem and it's been going for over a week now. 

2
Michael S
InVision ambassador Michael S , ambassador

Hello,

Thanks for letting us know. Would you mind also providing the following additional information so that we can take a look into this for you?

  1. What version of macOS are you using?
  2. If possible, can you share a screenshot or screencast of this logout issue and any error message you may be receiving?
  3. If you switch to another network, do you have the same logout issue afterwards?
  4. Are you using a proxy, VPN, firewall, or other network security service?

We look forward to helping to get this resolved for you!

Thanks
Michael

0
Thi_Le symantec com
InVision ambassador Thi_Le symantec com , ambassador

Hi thank you for assisting me with the problem. Here are the answer to your questions:

  1. What version of macOS are you using? macOS Mojave Version 10.14.6
  2. If possible, can you share a screenshot or screencast of this logout issue and any error message you may be receiving?

  1. If you switch to another network, do you have the same logout issue afterwards? Yes I still have the same issue.
  2. Are you using a proxy, VPN, firewall, or other network security service? No, I don't
0
Rashad
InVision ambassador Rashad , InVision Employee , ambassador

Hi there,

Thanks so much for taking the time to provide that information. I’m opening a Support ticket on your behalf at this time so our Support team can troubleshoot this with you. Please stay tuned for a response from one of our Support team members.

As Michael previously mentioned, we are looking forward to getting you up and running as quickly as possible.

Cheers,

Rashad

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador Edited

UPDATE

We're very happy to announce that our Engineers were able to get that issue reported by Mike above fixed in the latest public Craft Manager update and you should not expect to encounter it any longer. Since you had installed the test-build, you'll want to revert back to the main Craft Manager build for this update to take effect. Here's how to install the latest public Craft Manager version:

First, please quit Craft Manager completely:

  1. Click the "C" icon in your mac toolbar

  2. Click the gear icon, then Sign out

  3. Click the gear icon again, then Quit


Next, install the public Craft Manager version:

  1. Download this CraftManager.zip file 

  2. Go to your Downloads folder, and double-click CraftManager.zip to extract CraftManager

  3. Move CraftManager to your Applications folder. If asked to replace the current version, click Replace.

  4. Go to your Applications folder, and double-click CraftManager to open the app

  5. Click the "C" icon in your mac toolbar, and sign in to your company account as you normally would.

Please note: this update only resolves the issue's we've been experiencing with users being signed out after attempting to sync their artboards. If you were previously encountering syncing errors, you may continue to see those errors with some files, however, you should no longer be automatically signed out when attempting to sync. 

Thank you for your patience while our team worked on sorting this out. We want to make sure this is working as intended now, so please don't hesitate to reach out if you have any questions or lingering issues with this. We're here to help!

-1
Lydia S.
InVision ambassador Lydia S. , ambassador Edited

Same problem is happening to me but I can't upload; I get a sync error if I do. A ticket was opened today.

I tried downloading and installing the version above (UPDATE March 20) that Craft claims fixes the issue. It didn't work for me.

EDIT: tried the deep uninstall and reinstall and that didn't work either. 

1
Jason Ralls
InVision ambassador Jason Ralls , ambassador

I'm having the same issue. Also tried downloading and reinstalling Craft, with no luck.

3
Chris Holm
InVision ambassador Chris Holm , ambassador

I'm also having this issue. 

0
brian berg onapsis com
InVision ambassador brian berg onapsis com , ambassador

I have the same issue. 

1
Alejandra Estrada
InVision ambassador Alejandra Estrada , ambassador

I'm having the same issue since yesterday, I tried with the version uploaded here and nothing, still the same...

0
Chris Holm
InVision ambassador Chris Holm , ambassador

What solve this issue for me was clearing my cached browser data.

0
Camille M
InVision ambassador Camille M , ambassador Edited

Hi all,

 Our Engineering team are investigating an issue with Craft signing users out. Although they believe the issue is fixed, some users will need to clear their browser's cookies and log into Craft again. Could you try following the steps below to clear your InVision cookies then sign out and back into Craft:

https://support.invisionapp.com/hc/en-us/articles/207797203-How-do-I-clear-my-browser-s-cache-and-cookies-

Please let us know if these steps don't resolve the issue for you, and we'd be happy to investigate further.

Cheers,

Camille

0
Stacy Carpenter
InVision ambassador Stacy Carpenter , ambassador

I am having this exact same problem and it is verging on ridiculous. What do I need to do to fix?

0
Camille M
InVision ambassador Camille M , ambassador

Hi Stacy,

Thanks for letting us know you're affected by this issue! Can you let us know if you were able to try the steps provided above to clear your cookies, and if those steps let you get back up and running with Craft? 

https://support.invisionapp.com/hc/en-us/articles/207797203-How-do-I-clear-my-browser-s-cache-and-cookies-

Please let us know if these steps don't resolve the issue for you, and we'd be happy to investigate further.

Cheers,

Camille

0
Jennifer Keller
InVision ambassador Jennifer Keller , ambassador Edited

I am having the same problem. Interesting point though, I am on a Mac using Sketch, InVision, and Abstract. I just converted from contractor to FTE in my company. For security purposes, I needed to have a new profile set up on my Mac for FTE. I started having this problem in the old profile and am still having it in the new one.

  1. What version of macOS are you using? 10.15.1
  2. When Craft logs you out, are you shown any error message? Yes
  3. If possible, can you share a screenshot or screencast of this logout issue and any error message you may be receiving? Will provide later.
  4. If you switch to another network, do you have the same logout issue afterwards? Have not tried this yet
  5. Are you using a proxy, VPN, firewall, or other network security service? VPN

When I did the search to clear my cookies there was nothing for InVision that I could clear.

0
Raynor B
InVision ambassador Raynor B , InVision Employee , ambassador

Hi Jennifer,

Sorry to hear that you're running into this as well! Thanks for providing the details you have here in Community for our team to use for further troubleshooting.

I’m opening a ticket on your behalf with our Support team so they can troubleshoot with you internally. Please keep an eye out for an email from one of our Support agents soon.

Thanks, Jennifer!

Regards,
Raynor

0
Kevin Chiang
InVision ambassador Kevin Chiang , ambassador

Same! This issue is infuriating.

  • Craft 1.0.103
  • Mac OS 
  1. What version of macOS are you using? 10.15.7
  2. When Craft logs you out, are you shown any error message? Yes
  3. If possible, can you share a screenshot or screencast of this logout issue and any error message you may be receiving? N/A, just says I'm signed out.
  4. If you switch to another network, do you have the same logout issue afterwards? Have not tried this yet
  5. Are you using a proxy, VPN, firewall, or other network security service? No
0
Camille M
InVision ambassador Camille M , ambassador Edited

Hi Kevin,

Thanks for taking the time to share those details with us!

I'll go ahead and open a ticket for you now for our Support team to investigate further.

Best,

Camille

If anyone else is experiencing this issue, please submit a support request to report the issue you’re encountering.

 

0
Eric Loehrmann
InVision ambassador Eric Loehrmann , ambassador

Do you have a timetable as to when you will fix this issue?  Been going on for a year plus.  Really annoying to have to clear cache/cookies every week.

1
Rena
InVision ambassador Rena , ambassador

can you please fix it? 

Every week I have to spend some time to clear my cache/cookies (sometimes this way didn't even work for me). It's really annoying, why we even have to do this at all?? Can't you please just fix this cache problem? thank you very much. 

0
Raynor B
InVision ambassador Raynor B , InVision Employee , ambassador

Hi Eric and Rena,

Thanks for providing updates on this!

Eric, I can see that your already have an open ticket with our support team regarding this, so if you have any details to add to this, I encourage you to reply to your ticket so that our Support team can assist you directly. 

Rena, I’ll be opening a ticket on your behalf with our Support team so they can dig into this further with you internally. Please keep an eye out for an email from one of our Support agents soon.

We'll look forward to assisting you via the ticket. 

Best,
Raynor

0
Catie
InVision ambassador Catie , ambassador

This continues to be a consistent problem for everyone on our team. It's a disruption in our workflow and is really a drag on our efficiency. It has been this way for over a year, but in the past couple of months, it's gotten really bad again. It happens every single time I try to update an artboard from Sketch on an InVision project. 

0
Carlos Angeles
InVision ambassador Carlos Angeles , ambassador

Oh wow, this issue has been going on for over a year??

Is there any ETA on a fix for this Raynor B. It's getting a bit ridiculous. It logs me out 5 min after syncing some art boards. I have to login over and over again just to sync a few screens.

0
Kevin Chiang
InVision ambassador Kevin Chiang , ambassador

😂 My solution was to push my entire team to Figma

1
Camille M
InVision ambassador Camille M , ambassador

Hi Carlos,

Thanks for reaching out, and I'm sorry for the trouble!

I’m opening a ticket on your behalf with our Support team so they can troubleshoot with you internally. Please keep an eye out for an email from one of our Support agents soon.

I apologize for any frustration and disruption that this issue is causing you!

Thanks for hanging in there,
Camille

0

join the conversation

To comment, sign up or sign in.