Sorry, the InVision Help Center does not support Internet Explorer. Please download Microsoft Edge or another modern browser.


InVision ambassador ambassador
Michael Connelly Michael Connelly

Libraries with renamed or deleted components are not updating in any Studio files using the library.

Help! I have built two shared libraries full with components for wire-framing and current style guides. 

When I rename a component in these libraries, any Studio file using the library does not get updated with the new name. 

When I delete a component in these libraries, any Studio file using the library - the component does not get removed from the list.  Note these are components that are not used in the file.  

1) Why is this cascade not working?

2) Is there a way to "refresh" the library to pull in new names/changes.

I hope there is a fix, because I am already seeing issues with old names or removed components clogging up my lists.

Thanks!

PS: I'm using Studio Windows Version 1.22.1

0

comments

sort by


Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Hi Michael,

So sorry to hear that you're running into issues with your components not syncing properly with your shared library when renaming and deleting. In order for our Support team to do some further troubleshooting, we will need some additional information:

  1. A screenshot of your "About this Mac" overview.
  2. screenshot or screencast showing what is happening with your library.
  3. If you used a brought a Sketch file into Studio to work with, the version of Sketch that you have installed. 
  4. The version of Studio that your project was originally created in.

Look forward to hearing back,

Shaina

0

Michael Connelly
InVision ambassador Michael Connelly , ambassador
Comment actions Permalink

Hello!  

Here's a screen flow.

 

Added 2 new components in the shared library.

 

Created new Studio File. Added the two components.

Went back to Shared Library.  Changed the Name of one, and deleted the other.

GO back to Studio File -  Notice that something was updated.

Accept Changes.   

  • The "rename me" test component is not renamed in the "Add new components" list.  It preserved the old name.
  • The "delete me" component is still in the list. 

I even closed everything out and launched again. Still not updated.

Thanks for your help in figuring this out!

 

 

 

0

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Thanks for taking the extra time to provide that detailed process through your screenshots that you've provided. This appears as if it may be related a known issue that our team's investigating.

To be sure, I will open another ticket for you so that our Support team can test this. Please keep an eye out for an email from one of our Support agents soon.

Thanks for hanging in there,

Shaina

1

Michael Connelly
InVision ambassador Michael Connelly , ambassador
Comment actions Permalink

Thanks @ShainaTorgerson :-)

0

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Of course, Michael! Thanks for being so diligent about reporting these types of issues and working with our Support agents.

We really appreciate your willingness to help make our products even better!

0

join the conversation

to comment, sign up or sign in.