Sorry, the InVision Help Center does not support Internet Explorer. Please download Microsoft Edge or another modern browser.


InVision ambassador ambassador
Andreas Boos

Artboard is not placed correctly

Hi there,

somehow some of my artboards are not placed correctly anymore, there is a white border on the right side and the bottom. I don't know how this was happening and don't find any mistakes in my design.

Can someone help here?

 

This post is associated with a known feature request: [[problemTicketSubject]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.

comments

sort by


Kayden Knauss
InVision ambassador Kayden Knauss , ambassador
Comment actions Permalink

Hey Andreas,

Sorry to hear your artboards aren't placed properly and you're seeing a white border.

You mention that the artboards within your design software are appearing correctly, would you mind updating and replacing the screens to see if this fixes it?

Here's how to replace your screens:

  1. Go to the screen you want to replace.
  2. Drag and drop the updated image into the browser. The screen will be replaced. If you want to replace multiple screens, try doing so from the prototype home page. Click the upload screens and drag and drop all of the images to replace them.

Here's a help article that includes a video as well.

Please let me know if this doesn't fix the white borders and we can further troubleshoot for you.

Best,
Kayden

0

BRIAN THOMAS FUGATE
InVision ambassador BRIAN THOMAS FUGATE , ambassador
Comment actions Permalink

I have the same issue. It is incredibly problematic. User testing is a bust.  

1

Michael S
InVision ambassador Michael S, InVision Employee , ambassador
Comment actions Permalink

Hi Brian,

Thanks for letting us know, and I'm sorry to hear that you're running into this issue as well. Have you tried updating your screens as mentioned above?

The most common cause for this will be if your artboard size is a little smaller than the device you're deigning for. Would you mind double checking your artboard dimensions and ensure those match up?

If so, please let us know and we'd be happy to take a deeper look into what might be going on!

Thanks,
Michael

0

Eric Gustafson
InVision ambassador Eric Gustafson , ambassador
Comment actions Permalink

i'm having the same issue as well and replacing the screen from an exported version doesn't fix it. minor but incredibly annoying

0

BRIAN THOMAS FUGATE
InVision ambassador BRIAN THOMAS FUGATE , ambassador
Comment actions Permalink

Nothing has solved the problem. Artboards are the correct size. I literally have to make another artboard of the same size and then copy and paste the content from the problematic board into it. This will resolve the issue on some occasions. Obviously not an acceptable workflow. Incredibly annoying indeed. 

0

Jeremy Bauer
InVision ambassador Jeremy Bauer, InVision Employee , ambassador
Comment actions Permalink

Hi Eric and Brian,

Thank you for letting us know that you're both also having this issue with a white border appearing in your prototypes! I'm very sorry to hear you're having this trouble.

I think this may be related to a known issue we're looking into at the moment. In order to confirm this, could each of you share the following info?

  1. If you synced your prototype from Sketch with Craft, what version of Sketch are you using?
  2. What version of Craft are you using? On macOS, you can find this by clicking the Craft icon in the macOS menu bar, clicking the gear icon in the top right of the Craft window, and selecting About.
  3. Can you share a screenshot or screencast showing this border in your prototype?
  4. What browser and operating system are you using when viewing your prototype? You can get these details all at once, if you’d like, by going to http://www.whatsmybrowser.org/, clicking Copy, and pasting the link it gives you here.

Looking forward to digging into this issue with both of you!

Best,
Jeremy

0

Tom Hopcroft
InVision ambassador Tom Hopcroft , ambassador
Comment actions Permalink

Hello,

I have the same issue now - was there ever a solution to this?

Thanks!

0

Eric Gustafson
InVision ambassador Eric Gustafson , ambassador
Comment actions Permalink

Tom Hopcroft

 

it still randomly happens to me. i haven't figured out a rhyme or reason.. the only fix i've found is to add a few extra pixels to the artboard that it's being weird about. really sloppy workaround because then all your designs and layers might be off by a few pixels, but it seems to fix it in Invision. for eg:

instead of size being 375w x 812h, do 376w x 813h or something like that.

also messes up any export things a bit too..

0

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Hi Tom,

Since we were unable to collect any information for troubleshooting from the other users to reported this issue above, we were never able to confirm if those reports were linked to a known issue. To get a better idea of what might be causing this issue for you, can you please provide the information requested above?:

  1. If you synced your prototype from Sketch with Craft, what version of Sketch are you using?
  2. What version of Craft are you using? On macOS, you can find this by clicking the Craft icon in the macOS menu bar, clicking the gear icon in the top right of the Craft window, and selecting About.
  3. Can you share a screenshot or screencast showing this border in your prototype?
  4. What browser and operating system are you using when viewing your prototype? You can get these details all at once, if you’d like, by going to http://www.whatsmybrowser.org/, clicking Copy, and pasting the link it gives you here.

Best,

Shaina

0

Tom Hopcroft
InVision ambassador Tom Hopcroft , ambassador
Comment actions Permalink

Thanks for getting back to me!

 

- Sketch version 66.1

- Craft version 1.0.98

- You can see the border here, on the right and bottom (I already checked all artboards, some have the issue and some do not, even though they all are the same sizes and dimensions)

- Im using Chrome 84

- Operating system
OS X 10.14.6
0

Andreas Boos
InVision ambassador Andreas Boos , ambassador Edited
Comment actions Permalink

Hey there,

i needed to put the artboards to another Position in Sketch, that solved the problem for me back then...

1

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Thanks for providing those requested details, Tom! It looks like you're on a slightly outdated version of Sketch. Can you please try updating to the latest version of Sketch and let us know if the issues persist?

Can you try the following?:

  1. Unless specifically needed downsize this screen and ensure all screens are the same width.
  2. Go to sync the screens again. Before doing so in the Craft Sync window click preferences and change the density setting from 2x to 1x. Now sync the screens.

Let me know if either of these things help!

Best,

Shaina

0

join the conversation

to comment, sign up or sign in.