Sorry, the InVision Help Center does not support Internet Explorer. Please download Microsoft Edge or another modern browser.


InVision ambassador ambassador
Kyle Kyle

How to hide Overlays from public view of my presentation?

Howdy,

I have a project i'm working on in invisionCloud that is using a couple overlays. https://invis.io/9SSR5MJYREW

When viewing the shared link of the prototype and the user clicks through to the end, the overlays are also shown to the user, which I don't want them to see. I just want them to see the artboards, and have the overlays work on those artboards, but not show them my overlays as if they were an actual page of the prototype.

Here's a screen of a page in the prototype that they see, but I don't want them to. http://prntscr.com/o8371q

0

comments

sort by

official comment
Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Hi Glyn,

Thanks for your feedback regarding the issues that Kyle initially reported. After working with our Support team, it was found that this is a known limitation where if a fixed header overlaps a hotspot, the hotspot will fail to trigger. Also, the hotspot hinting will incorrectly display only the bit that overlaps the fixed header. Our Product and Engineering teams have evaluated based on factors including severity, impact, scale, and frequency. Given the cost required to address this bug, we have decided to allocate our resources to addressing other issues with a greater impact on our customers, and don't intend to fix this issue at this time.

This decision is never easy to make and we understand it may be frustrating to hear that we don't intend to fix the issue at this time, but we focus our resources where they'll do the most good for the most customers and we believe it’s important to be transparent with our customers when we’ve determined a particular bug won’t be fixed.

In the meantime, users will need to make sure their hotspot is created completely within the fixed header or outside of the fixed header. We will continue to track this issue and monitor the prevalence and severity of the bug, and we will revisit that decision if the circumstances change. That being said, I'm happy to share your feedback in our next product meeting.

​​Please do let us know if you have any questions at all about this. Otherwise, we want to thank you again for taking the time to chime in about this issue.
​​
Best,

Shaina

If anyone else is having issues with this, please contact our Support team directly here to share your feedback.


Owen Hughes
InVision ambassador Owen Hughes , ambassador
Comment actions Permalink

Hi Kyle!

Im assuming you mean the blue hotspots?

Luckily there is a way of hiding these!

These are the steps to follow to hide these: 

  1.  Click 'Share' on the bottom right of the screen. This will reveal a pop up.
  2. In the bottom right of this pop up there is a text link that says 'Link Settings'. Click this. 
  3. You will see 3 options with toggles to the right of them. Under these toggles you will see 'More Options' which will reveal 4 more options.
  4. One of the options/toggles is 'Prevent hotspot hinting' activating this toggle will hide the hotspots from people accessing the prototype via public share links.

Hope it works! Let me know if you need any further assistance. 

 

Thanks

Owen

 

0

Kyle
InVision ambassador Kyle , ambassador
Comment actions Permalink

Hey Owen,

Thanks for your response. Unfortunately that was not the issue I am having issues with.

To make it more clear, I've created a screencast describing my issue: https://drive.google.com/file/d/1J3vbUXCHtugHZV463fgklTvoFZ4gR4Pi/view

Thanks!

0

Owen Hughes
InVision ambassador Owen Hughes , ambassador
Comment actions Permalink

Ah my apologies for misunderstanding Kyle!

Let me ask a fellow ambassador to see if they can help with this!

0

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Hi Kyle,

I would like our Support team to take a closer look at the file in question, as well as the issue mentioned in your other post. As mentioned, I will be opening a ticket on your behalf with our Support team including all of the details you have in each post.

Please let me know if there's anything else I can do in the meantime. Look forward to getting you some answers soon.

Best,

Shaina

0

David Shavrick
InVision ambassador David Shavrick , ambassador
Comment actions Permalink

I have the same question.

I don't want the artwork used for the hotspot to appear in the sequence of screens viewed by my client.  Any plans of adding the ability to hide a screen from view but still have it function as the source for a hotspot? Seems like a must have requirement. 

Thanks

D

0

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Hi David,
​​
Sorry to hear that you're also running into this issue. In order for our team to take a closer look at this for you, can you please provide some additional information?:

  1. Your browser details. You can get these details by going to http://www.whatsmybrowser.org/, clicking “Copy”, and pasting the link it gives you here.
  2. A screenshot of your "About this Mac" overview, or other OS details.
  3. What version of Sketch/Photoshop are you using?
  4. What version of the Craft plugins are you using?
  5. If you're able to do so publicly, can you please provide a share link to your project?

Look forward to hearing from you,

Shaina

0

Glyn
InVision ambassador Glyn , ambassador
Comment actions Permalink

It's a shame there's no answer to this.  Kyle just wants the artboards that are used to create his menu overlays etc. not to be shown to his client as if they were additional pages.   I'd like this too - it's usually unnecessary and confusing for the client to see the overlay element again presented as a page.

0

Richard
InVision ambassador Richard , ambassador
Comment actions Permalink

Hi, I've had the same issue with InVision for a while now and have figured out a solution. (although it might not be perfect for all instances)...

For the screens on your project that are overlays (the screens you don't want clients to see as an individual screen), you must set automatic redirects of 1ms.

How to do that:

- On your overlay screen in Build mode, click the icon at the top with the stopwatch icon

- Set the 'Automatically redirect to...' screen to your homepage 

- Set the 'After:' duration input to 1ms

- Click Save

- Repeat for all overlays screens (lightboxes etc)

 

this automatically redirects clients or visitors to the homepage when they try view one of the overlay screens

1

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Thank you very much for chiming in to provide your solution for this, Richard! If there's anything we can help out with in the meantime, please don't hesitate to follow up.

Have a wonderful day,

Shaina

0

join the conversation

to comment, sign up or sign in.