Sorry, the InVision Help Center does not support Internet Explorer. Please download Microsoft Edge or another modern browser.


InVision ambassador ambassador
Lachlan Sunderland

iOS app not respecting automatic redirect delays

Hi there, just found another infuriating and weird issue -_-

I'm putting together a prototype for usability testing and need to use automatic redirects with timed delays to mimic interactions. This works very well in the browse. Unfortunately we need to use the iOS app for it's handy 'user' test feature (also, come on inVision, usability test not user test) and it's completely ignoring all of the delays I've set.

For example i've applied 1500ms delay on an app splash screen before loading the first real screen. When viewed in the inVision app this splash screen only flashed for a fraction of a section before navigating to the next screen.

Anyone know if this a known issue? Are there any work arounds?

Cheers,

Lachlan

This post is associated with a known feature request: [[problemTicketSubject]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.

comments

sort by

official comment

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador
Comment actions Permalink

Thanks for following up, Patrick. Glad to hear that this is now working for you with the newest release of version 2.8.8 of the InVision iOS app.

For anybody else that may be encountering this issue, please try updating to the latest version of the app. Our Engineering team has shipped a fix which means you should no longer encounter the issue. 

We thank you for your patience as we worked to resolve this. If you are still encountering issues, please do just reach out right here, where we would be more than happy to assist.


Beth Vanderkolk
InVision ambassador Beth Vanderkolk , ambassador
Comment actions Permalink

Hey Lachlan,

Thanks for touching base here. I'm so sorry you're having trouble with the iOS app not respecting automatic redirect delays! I'm going to open a Support ticket on your behalf so they can dig in to this for you. Keep your eyes peeled for an email, please. Thanks for hanging in there.

Beth

0

Tommy Wakeham
InVision ambassador Tommy Wakeham , ambassador
Comment actions Permalink

Same for the android app

0

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador
Comment actions Permalink

Hi Tommy,

Sorry to hear that you're also experiencing this issue in the Android app. Before having our Support team take a look at this for you, can you please provide your mobile operating system details and the version of the InVision Android app that you're running please?

Look forward to hearing back,

Shaina

0

Tommy Wakeham
InVision ambassador Tommy Wakeham , ambassador
Comment actions Permalink

sure, im on a Pixel 2 running android 9 and invision 2.6.8

0

Beth Vanderkolk
InVision ambassador Beth Vanderkolk , ambassador
Comment actions Permalink

Hey Tommy,

Thanks for those deets. I just opened a ticket with Support on your behalf so they can dig in to what's going on. Keep your eyes peeled for an email! Have a great weekend!

Beth

0

simanta pathak
InVision ambassador simanta pathak , ambassador
Comment actions Permalink

same problem here.. automatic redirect not working on the iphone app, but works on a browser.. i needed it tomorrow and now its this.. invision you really failed me, it was my first real test using invision.. oh well.. 

0

Beth Vanderkolk
InVision ambassador Beth Vanderkolk , ambassador
Comment actions Permalink

Oh no! Simanta, I'm so sorry about that. It looks like you already have a Support ticket open with Brittini, so I'll let her continue to troubleshoot for you. Looks like she's waiting to hear back from you. Hope you had a nice weekend and again I'm so sorry for the trouble you experienced.

Beth

 

0

Charles Walter
InVision ambassador Charles Walter , ambassador
Comment actions Permalink

Having the same issue here. 

InVision app: 2.7.4 (499)

iOS: iPadOS 13 Beta

0

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador
Comment actions Permalink

Hi Charles,

Thanks for reaching out here and for providing those details. It looks like your InVision mobile app for iOS is a bit outdated. The newest version is 2.8.3.  Can you please go ahead and update that to the lates to see if this issue continues once updated?

If this persists can you please provide the following information?:

  1. A share link to the prototype in question (if you're able to share publicly)
  2. A screenshot of the settings for the timed redirect
  3. Is this something that appears isolated to one particular prototype, or have you seen this same issue with other prototypes as well?
  4. Are you chaining multiple timed redirects? (where one screens redirects, then that destination screens also has a timed redirect setup)

I look forward to hearing back.

Best,

Shaina

0

Patrick Haney
InVision ambassador Patrick Haney , ambassador Edited
Comment actions Permalink

I'm also having this issue with the InVision iOS app, and it's extremely frustrating. iOS 13 support was added 2 weeks ago, but this bug has been a problem for almost 2 months now with no resolution. It doesn't matter what I set my Automatic Redirect time to (I've tried 3000ms, 30000ms, etc.), the prototype will jump to the next screen in what seems like the default of 800ms.

Considering I just spent the entire day designing and building a prototype to user test tomorrow on my iPhone, this is a real punch to the face. I now have to spend time this evening figuring out how to reflow some of my prototype. Please fix this bug!

PS. I'm running iOS 12.4.1 with the latest InVision app on an iPhone Xs.

0

Patrick Haney
InVision ambassador Patrick Haney , ambassador
Comment actions Permalink

Update: I spent quite a bit of time adjusting values for Automatic Redirect last Friday, and the conclusion I came to is that if you enter a time (in milliseconds) and choose a transition, you then have to select the screen you want to redirect to after that, regardless of whether or not you've already selected one (and even if you're just reselecting the same one). From what I can tell, that last step will properly save the values to the prototype screen and then the iOS app will wait the correct amount of time before redirecting screens.

I can't say this is what fixed it for sure, or that it will work for everyone, but it worked for me and I was able to get my 36 screen prototype working in time for user testing over the weekend.

0

Caitlin Cambron
InVision ambassador Caitlin Cambron , ambassador
Comment actions Permalink

Hi Patrick,

I'm glad the you found a solution to the issue you were having with automatic redirects. I'm going to let our Community Moderator know that you found a work around. Thank you for posting that update!

Best,

Caitlin

0

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador
Comment actions Permalink

Hi Patrick, 

Thanks for taking the time to reach out here in Community reporting your issue, and for following up with a workaround! I'm glad to hear that you're able to achieve what you're looking to do for the time being, but I know that what you've discovered is far from ideal.

That being said, I would like to share your findings with our Support and Engineering teams. Before passing this information over to them, can you please provide the following information?:

  1. The version number for the InVision iOS app that you're running
  2. A share link to the prototype in question (if you're able to share publicly)
  3. A screenshot of the settings for the timed redirect
  4. Is this something that appears isolated to one particular prototype, or have you seen this same issue with other prototypes as well?
  5. Are you chaining multiple timed redirects? (where one screens redirects, then that destination screens also has a timed redirect setup)

I look forward to hearing back. If you are unable to share this information publicly, I'm happy to open a ticket on your behalf requesting the same information to share with our Support team internally.

Best,

Shaina

0

Patrick Haney
InVision ambassador Patrick Haney , ambassador
Comment actions Permalink
  1. I'm running InVision 2.8.7 (622) on iOS 12.4.1 on an iPhone Xs
  2. I can't share the prototype, it's private and has to stay that way. If necessary, I can create a public version with nondescript screens to share.
  3. Here's a Dropbox link to a screenshot: https://www.dropbox.com/s/elurqx6q4dpmpco/invision-auto-redirect-settings.png?dl=0
  4. I've seen it with 2 different prototypes, both in the same account
  5. I'm seeing this for both a single timed redirect, and also chained redirects (I use both in my prototype).
0

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador
Comment actions Permalink

Thanks for following up with those details, Patrick! I will open a ticket on your behalf including all of the details you have here to share with our Support team.

Please look for an email from one of our Support agents soon. Feel free to add any other comments to your ticket that you feel might be useful.

Thanks again,

Shaina

0

Patrick Haney
InVision ambassador Patrick Haney , ambassador
Comment actions Permalink

Update: This issue has been resolved from what I can see in the latest iOS release (2.8.8) and is mentioned in the app update notes. The InVision team opened a support ticket and we worked through the problem, and their engineering team seems to have resolved it. Thanks everyone!

0

Caitlin Cambron
InVision ambassador Caitlin Cambron , ambassador
Comment actions Permalink

Hi Patrick!

We're glad to hear the latest update has solved this issue for you!

Caitlin

0

Hawra Husain
InVision ambassador Hawra Husain , ambassador Edited
Comment actions Permalink

PLEASE HELP. I'm facing the same problem with inVision 2.10.3 (650) running on ios 13.5.1

0

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador
Comment actions Permalink

Hi Hawra,

Sorry to hear you're running into some of these issues as well. Thanks for taking the time to provide the details you already have above. In order to determine what's causing these issues for you, can you please provide some additional information?:

  1. A share link to the prototype in question (if you're able to share publicly)
  2. A screenshot of the settings for the timed redirect
  3. A screencast or screenshot showing exactly what's going wrong
  4. Is this something that appears isolated to one particular prototype, or have you seen this same issue with other prototypes as well?
  5. Are you chaining multiple timed redirects? (where one screens redirects, then that destination screens also has a timed redirect setup)

Look forward to hearing from you,

Shaina

Shaina

0

join the conversation

to comment, sign up or sign in.