Sorry, the InVision Help Center does not support Internet Explorer. Please download Microsoft Edge or another modern browser.


InVision ambassador ambassador
Andy Al-Rubaye Andy Al-Rubaye

Can no longer login, Duo Security returning out-of-date OS version

Hi,

Long time Invision + Craft user here. Currently I have no way to sync files to my company's Invision due to Duo Security not allowing me to authenticate because whatever Chromium Web Renderer the Craft Plugin is using to Auth keeps returning an out of date User Agent info. I have taken this up with IT and they basically told me I am SOL as this is a problem with the Craft Plugin rendering engine and not on their end.

I have tried every trick in the books including deleting the files, removing the plugin and I must have reinstalled Craft Manager about 10x at this point to no avail. 

Steps I am taking:

1. Open Craft Manager:

2. Sign in using my Company Domain:

3. Upon entering my username and password, which activates Duo and usually I get a push notification on my phone to accept the Auth. Instead I get this:

4. When I look at the "See what is allowed" link, this is what I get (I have also tried connecting via VPN in an attempt to avoid this Duo Auth screen but it keeps showing up regardless):

 

Mind you, my Mac is up to date with Mojave 10.14.4, not what is being displayed in the Craft Manager. Here's a screenshot of my OS About. 

 

At this point I have completely given up using Craft and having to export individual PNGs and upload them the old way. What sucks even more is the fact that Invision has disabled the ability of dragging a Sketch file directly into Invision. So now I am pigeon-holed into this terrible process and I am not really sure what to do.

Writing here as a last ditch effort to see if there's anything that can be done about this. If anyone has any idea how to resolve this or get around it I would greatly appreciate it.

0

comments

sort by


Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Hi Andy,

So sorry to see that you're running into these issues with signing into Craft! We definitely want to help you get to the bottom of what might be causing this. 

Thanks for providing all of the details and screenshots above. In order to troubleshoot a bit more, I'd like to gather some more information to help us test this issue:

  1. What version of Sketch do you have installed? Sketch > About & Registration… 
  2. What version of Craft Manager do you have running (for example 1.0.63)? Checking Craft Versions

Once we have these details, we will be able to dig deeper into this investigation. 

In the meantime, you can try signing in with your native credentials. I know this may not be the most ideal situation but it is an option since the InVision app shows both Enterprise and personal projects when signed in with native credentials.

Look forward to hearing from you,

Shaina

0

Andy Al-Rubaye
InVision ambassador Andy Al-Rubaye , ambassador
Comment actions Permalink

Thank you for the response Shaina. 

Here are the versions you requested for Sketch and Craft Manager:

 

I also tried logging in with my Native Credentials. The only thing I can access are my own personal projects. Enterprise projects lead to the same Duo loop and throws the same errors I indicated above.

Greatly appreciate your help with this.

0

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Thank you so much for providing those details, Andy! At this point, I would like to have our Support team investigate why you are unable to sign in using DUO.

Once they have had a chance to review your case, they will be in touch. So keep your eyes open for an email from them soon!

Thanks for your patience,

Shaina 

0

join the conversation

to comment, sign up or sign in.