Skip to main content
Latest news: [[ newestAnnouncement.title ]] Learn more
InVision Support Home Page
Sign in
InVision ambassador ambassador
CRi Solutions
CRi Solutions Updated

Removing Orphaned Craft Hotspots

I used the Craft plugin to setup many hotspots on static design elements. Recently I setup a symbol to replace the static design elements. I deleted the static elements across several artboards, replacing them with the new symbol. I expected the Craft hotspots to automatically delete when I removed the static design elements. Counterintuitively, the hotspots remained and were orphaned. These orphaned hotspots appear purple, rather than blue. I cannot select them in order to remove them. Copying and pasting the artboards to a new canvas, uninstalling and reinstalling the plugin also fails to remove these orphaned hotspots. Please help!

This post is associated with a known feature request: [[ problemTicketSubject ]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.



Sort by

official comment

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador


I wanted to provide you an update on the issue that has been reported in this thread where Craft prototype links created in Sketch 66 and below changed the color from blue to purple when the file is opened in Sketch 67. Our engineering team has just released a fix for this issue in CraftManager V1.0.98 (C icon > Settings > Preference) & Craft Sync 2.3.163. Please update your CraftManager and Craft Sync to the latest version and check if the issue is resolved. 

Thanks very much for your patience while we worked to resolve the bug! Feel free to let us know if there's anything else that we can assist with or if you're continuing to run into issues.

CRi Solutions
InVision ambassador CRi Solutions , ambassador Edited

After some digging around, experimentation, and consulting with a fellow designer I found a solution. The video linked below demonstrates the fix that worked for me. Hope it helps others. Cheers! 

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

So glad you were able to work together to find a solution! Thanks so much for sharing with the rest of the Community :)

Megan Cook
InVision ambassador Megan Cook , ambassador

I am having this same problem. The solution with the dropbox link goes to a 404 page. Can you please send a new link or write a post with the solution?

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Hi Megan,

If you have updated to the latest version of Craft Manager, you can quickly bulk delete hotspots created with Craft Prototype by following the step by step instructions here. If you continue to have issues after using these steps, or are encountering a completely separate issue, please let me know.

Hope this helps,


Phillip Morley
InVision ambassador Phillip Morley , ambassador

Hi Shaina,

Unfortunately the video you have suggested does not resolve this issue. I have the purple arrow problem, I have highlighted the layer and tried to remove manually and by the menu too and neither work.

The only way round this seems to be deleting the artboard itself, but i dont want to do this as there a many protoype arrows coming off of that particular artboard

All the best


Beth Vanderkolk
InVision ambassador Beth Vanderkolk , ambassador

Hey Phil,

Sorry for the frustration here. Are you able to post a video of what's happening when you try to follow the instructions? Also, let me know which version of Craft you're using.


Marcus Pedersen
InVision ambassador Marcus Pedersen , ambassador Edited

I have the exact problem.




How it started:

1. I have a sketch document (Let's call it Work Document") with several  Artboards and one of the artboards has a group called window. Within this window there was several symbols that were used as hotspots so that I could link to other artboards.

2. I then decide to turn the window group into a symbol, since I have all my symbols on a separate Sketch document ("library") I use the plugin "move selected symbols to library" and move them over. I then see that on the Work Document the hotspots are still there. I go to Craft>Prototype>Delete Hotspots but nothing happens, the links are purple and so I'm guessing I have to do this in the symbol document. So I open the library document and check, but no there are no hotspots here. I select the artboard just in case and try to delete any hotspots but nothing happens.

3. So now I'm stuck with hotspots that can't be removed.


Solution: I opened the library document, selected all symbols layers with an artboard and clicked delete Hotspots in the craft plugin settings. The I selected all symbol artboards just in case and did the same.

Since I also used Abstract together with Sketch, I commited the changes on the library document then I merged it as well.

I opened the work document and updated the library changes here. The hotspots were still visible but I just moved the symbol in the Work Document. I dragged it away from it's original placement, dropped it and then dragged it back and suddenly the hotspots disappeared. The thing is, I tried this earlier however then I used cmd+z to return it to it's original placement. So the solution might just be to move the symbol because it might just be a visual bug of some kind.




Caitlin Cambron
InVision ambassador Caitlin Cambron , ambassador

Hi Marcus!

Thanks for your detailed explanation of the issue you were encountering, and double thanks for posting this workaround in Community! 

Have a great one,


Arati Dube
InVision ambassador Arati Dube , ambassador

Hi Guys, I have a simple solution to this problem, Even I faced the same issue of seeing Purple links when I turned those hotspots into symbols.

So The Reason why they seem purple is the interaction is applied to whole symbol. let's say for example in mobile application I link 'search icon on the top to different search screen' and then I turn this icon into symbol then throughout the application where I'll use this Search icon it'll be automatically linked to the search screen where I linked it before and this interaction will look purple (call it symbols interaction)  

So the Simple Solution to this is go on symbols page, find this search icon you will see small blue color craft interaction icon (see attached image) there, select that and you'll be able to remove it from there.


Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Thanks so much for taking the time to add your solution here in Community, Arati! I'm sure it will help many users also running into this.

If there's anything we can do to help out, please don't hesitate to reach out again in Community.

Have a great day!


Lydia S.
InVision ambassador Lydia S. , ambassador Edited

I recently updated Sketch (yesterday, v67.1) and this issue appeared suddenly. Using Craft to remove the orphan hot spots is not working at all. I can get rid of the orphan links if I delete the originating component (or art-board entirely), but as soon as I add a library component back on the screen, the orphan link returns.
Note: If I view the component in the library, there is no link.
Is this a bug related to the update? 

James McLain
InVision ambassador James McLain , ambassador

Man it's a nice holiday 3-day weekend, everybody has left the office. I'm staying late about to finish this prototype and lo and behold orphan hot-spots. Staying even later to figure out this garbage is beyond frustrating. 


Arati your solution didn't work. No blue dot exists on the symbols page. 

Sebastien K
InVision ambassador Sebastien K , ambassador

I just back to the 66.1 sketch version and all the orphan link disappeared. Good luck everyone ! 

Ricardo Moreira
InVision ambassador Ricardo Moreira , ambassador

I am having the same problem. After updating Sketch to version 67.1 several orphan links (purple) appeared, if I go to symbols page nothing is there to delete. Probably a bug.

Ankita Gupta
InVision ambassador Ankita Gupta , ambassador

Agreed, I downgraded to 66.1 version. All purple links are gone

Laura Cunha
InVision ambassador Laura Cunha , InVision Employee , ambassador

Lydia S., James McLain, Sebastien K, Ricardo Moreira and Ankita Gupta — I am very sorry to hear that you've been running into this issue, and thank you for taking the time to flag it.

I’ll be opening a ticket on your behalf with our Support team, so they can troubleshoot with you. Please keep an eye out for an email from one of our Support agents shortly.

I'm sorry about any frustration and disruption that this has caused you.

Thanks for hanging in there!

Michael McGillivray
InVision ambassador Michael McGillivray , ambassador

I have the same issue with the latest update.

There's so many bloody purple links thee's no way to delete them (see image). Please fix this mess of a bug ASAP!ASAP!

Chris Phillips
InVision ambassador Chris Phillips , ambassador

Just to chime in here.

Not a solution for this problem which I also have at the moment. But could we also have the option to remove all the links (orphan or not) at a individual Artboard level rather than clearing them for the entire page which could have LOTS of Artboards, like the example that Michael McGillivray provided.

Even consider adding it to the flyout menu for the Artboard selected.


Jonas Svensson
InVision ambassador Jonas Svensson , ambassador Edited

I'm just posting here since I have the same problem and want to know when there will be a fix.

Since updating to Sketch 67.1 and latest Craft version (as of today) my document looks just like Michael McGillivrays with purple nodes everywhere which I can do nothing with. Not delete, not edit, nothing.. 

Ernie Guaimano
InVision ambassador Ernie Guaimano , ambassador

Confirming I also cannot find a solution to this issue. There are no interactions applied at the symbol level in my documents so the workarounds at the top of the page are not viable solutions. The issue seems to spawn from copied artboards but not being able to remove the purple links is causing entire pages to be unusable. 

InVision ambassador Bruno , ambassador


I have the same problem than Michael McGillivray

I can't remove milion purple link arrows. It's very unconfortable to work like this. 

Please, fix the bug or tell us how we can fix it.


Thank you very much :-)

Sofia Qureshi
InVision ambassador Sofia Qureshi , ambassador

Also still having this issue-- it's extremely frustrating as it basically renders this craft feature unusable.
I've also tried all the workarounds in this thread, but to no avail.

Camille M
InVision ambassador Camille M , ambassador


Michael McGillivray, Chris Phillips, Jonas Svensson, Ernie Guaimano, BrunoSofia Qureshi - thanks so much to you all for taking the time to report this issue!

I'm happy to share that our Engineering team are aware of this bug and working hard on a resolution as we speak. 

We'll be opening tickets on your behalf to let our team know that you've been affected by this issue, and to keep you in the loop with further updates.

If anyone else is experiencing this issue, please email to report the issue you’re encountering.



Will Ilarraza
InVision ambassador Will Ilarraza , ambassador Edited

Facing the same problem. For me all the symbols are from a library that isn't using links. I can't remove the orphan links and it's slowing the performance of the file I'm working on. 

Rick Hocutt
InVision ambassador Rick Hocutt , ambassador Edited

Add 1 more to the list. I recently got the pesky purple lines that I can't edit or delete also.

Camille M
InVision ambassador Camille M , ambassador

Hi Will and Rick,

Thanks for reporting that you've also been affected by this issue.

We'll open Support tickets for you to gather some further detail and let our team know you've been affected by this bug.



InVision ambassador Bonita , ambassador

Hi guys, just want to share how I fixed this: I found random purple links when I opened my Sketch file this morning; they started on library components and were linked to completely random screens. They disappeared when I updated my library. So it should then also work if you go to File > Sync library components.

Hope this is helpful to someone.

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Thanks so much for chiming in here to help out, Bonita! Please let us know if there's anything we can help you with in the future :)

Have a wonderful day,


Luca Boehi
InVision ambassador Luca Boehi , ambassador

Add one to the list. Been through all of the suggestions, so far nothing works. Purple lines are persistent


join the conversation

To comment, sign up or sign in.