×

Invision not showing Sketch symbol overrides in Inspect mode assets

When I upload to Invision from Sketch via Craft, Symbols with overrides applied (e.g an icon with colour changes) appear fine in the prototype, but when you inspect and go to download the asset, the icon in the asset section is the default symbol (i.e without my colour changes). Same result whether I use a slice or set a symbol to "export"

 

Anyone found a workaround?

0

Comments

Please sign in to leave a comment.

  • Avatar
    Cail

    Sketch 53.2 (72643)

    Craft: 1.0.76

    MacOS: 10.14.2 (18C54)

    0
  • Avatar
    Shaina Torgerson

    Hi Cail,

    This sounds like it may be related to an issue that our Engineering team is already aware of. To ensure that this is related, can you please also provide what browser and operating system are you running? This can be found at https://www.whatismybrowser.com/.

    Look forward to hearing from you,

    Shaina

    0
  • Avatar
    Cail

    OS details are above, browser is Chrome 72

    0
  • Avatar
    Shaina Torgerson

    Thanks for providing that additional information, Cail. I'm going to open a ticket on your behalf with our Support team so that they can do some further troubleshooting. Please look for a message from them soon.

    0
  • Avatar
    Stephi Bigalke

    Hi, 

    we have the same problem with all Symbols and Symbols linked to a sketch library.

    we defined a button (which is a simple rectangle) and assigned a layer style for the color.

    Because of the layer style we're able to chance the color by override. in Inspect mode we do see the changed color,
    but on the right side you still see the hex code of the original color of the symbol.

     

    Mac OS 10.13.4

    Safari 11.1

    Sketch 53.1 (72631)

    Craft plugin 1.0.77 132

     

     

    0
  • Avatar
    Shaina Torgerson

    Hi Stephi,

    Thanks for taking the time to reach out here in Community about this issue. I apologize for any frustration that this is causing for you!

    Since you are on the most up-to-date versions of Sketch and Craft Manager, I would like our Support team to take a closer look at this for you. What you're running into may be related to an issue that our Engineering team is already investigating. 

    I will open a ticket on your behalf so that our Support team can dig deeper. Please keep an eye out for an email from one of our Support agents requesting more information.

    Thanks,

    Shaina

    0
  • Avatar
    Benjamin VADOT

    Hello !

    We've the same problem since Sketch release his "Layer Style Overrides" feature in Sketch 52 in October 2018.

    We waiting patiently your update (:

    Thanks for your amazing work !

    B.

    ---

    • MacOS 10.14.3 (18D109)
    • Chrome 73.0.3683.86 (Build officiel) (64 bits)
    • Sketch 53.2 (72643)
    • Craft v1.0.78 (136)
    0
  • Avatar
    Shaina Torgerson

    Hi Benjamin,

    I'm sorry to hear about the troubles you're having with Inspect not respecting the color overrides. 

    The behavior you are describing may be related to a known issue that our team is currently investigating. We've found that Inspect does not show the correct color for symbols with Sketch's layer styles override. That being said, we would like to take a closer look at this for you and I'll be opening a ticket on your behalf to confirm that this is the same issue.

    In the meantime, the only workaround solution we were able to find is to detach from the symbol. We know this is far from ideal and our team is continuing to work on resolving this issue.

    Best,

    Shaina

    0