Can't log into Getty or iStock image function

Sign in just hangs in both cases... I tried to let it run to see if it would catch up... but hung for an hour... has been like this all day. Tested both logins on their respected sites... but nothing.



Please sign in to leave a comment.

  • Official comment
    Shaina Torgerson


    Please accept our apologies for the trouble that you were seeing with Craft Stock, where you were unable to login to iStock or Getty images. With the release of Craft Stock 1.0.30 our engineers have identified the source of the issue and this release includes a fix, our team has tested this here and we are able to login to the image repositories and access images so it appears that everything is working correctly once more.

    Please give this another try and do please let us know if you're still having trouble. Otherwise, I would like to offer our thanks for your patience while we worked to fix this issue.

  • Avatar
    Shaina Torgerson

    Hi Jack,

    Sorry to hear that you're running into issues with logging into Getty or iStock. Would you mind providing a few additional details into what is happening, so that we can dig deeper? 

         1. Can you please provide a screenshot of your "About this Mac" overview?
         2. What version of the Craft Stock plugin are you using?
         3. What version of Craft Manager are you currently running?
         4. Could you provide a screenshot showing what’s going wrong?

    Look forward to hearing from you,


  • Avatar

    I'm the same, I can't login.

  • Avatar
    Shaina Torgerson

    Hi Ben,

    Can you please provide the same information that I requested from Jack above? This will give me a better idea of what might be causing this issue for you.



  • Avatar

    Hi, I am having this same issue. Here is the information you asked for above:

    The version of the Craft Stock Plugin is 1.0.31, version of Craft Manager is 1.0.74.


    And here is a screenshot of what is happening. I try to click "Authorize" and nothing happens at all.

  • Avatar
    Shaina Torgerson

    Hi Ashley,

    Sorry to hear that you're continuing to run into this issue. I appreciate you taking the time to provide those screenshots and version numbers. As a next step, I'd like to have you perform a comprehensive, deep uninstall/reinstall of Craft using the steps below. Please skip any steps that are not applicable (e.g. if a file/folder mentioned is not present) and let me know if you get stuck anywhere along the way: 

    1. Close Craft Manager (by clicking into the "C" > clicking the gear icon > choosing Close).
    2. Go into Sketch, and navigate to Plugins ➝ Manage Plugins.
    3. In the pop-up modal, select Craft by InVision Labs, and click the gear icon in the lower left and select the uninstall option. This will move some items to the trash.
    4. Quit Sketch entirely.
    5. Open the Activity Monitor (via Applications > Utilities > Activity Monitor), and then force quit the Craft Manager and Panels (if applicable) processes.
    6. Open Spotlight and search for ~/Library/Application Support/
    7. Delete the com.invisionlabs.CraftManager folder, the com.invisionlabs.CraftManager.json file, the com.invisionlabs.CraftInstaller folder, and the CraftManager folder.
    8. Open the com.bohemiancoding.sketch3 folder.
    9. Delete the Panels folder (if applicable). Please note that these steps will remove any custom Type or Photos items you’ve created in Craft Data. If you'd like to preserve those, please go to ~/Library/Application Support/com.bohemiancoding.sketch3/Panels/.settings and back up the file "com.invisionlabs.data."
    10. Open the Plugins folder.
    11. Delete the Panels.sketchplugin file (if applicable).
    12. Navigate to the Downloads folder.
    13. Search for craftinstaller and delete any files that deal with the Craft Installation process.
    14. In Applications or the folder in which you installed Craft Manager, delete CraftManager.app.
    15. Empty the Trash.
    16. Go to https://craft-assets.invisionapp.com/CraftManager/production/CraftManager.zip and unzip the CraftManager
    17. Drag and drop the Craft Manager app into your computer's "Applications" folder or the folder of your choice before launching it.
    18. Open Craft Manager and then install Craft for Sketch.
    19. If you had backed up the "com.invisionlabs.data" file before performing these steps: launch Sketch now in order to rebuild the ` ~/Library/Application Support/com.bohemiancoding.sketch3/Panels/.settings ` directory. Then, place the backed up "com.invisionlabs.data" file in the ".settings" folder and restart Sketch to restore your custom Type & Photos items.

    After following these steps, if you are still having issues, please do let us know and we will gladly help. 

    Look forward to hearing from you,