Sorry, the InVision Help Center does not support Internet Explorer. Please download Microsoft Edge or another modern browser.


InVision ambassador ambassador
Emanuele Livi Emanuele Livi

Invision Studio doesn't wok with old Mac hardware

Hello everyone,

I have compatibility problems with my old mac to use Invision Studio. I think the fact to use a powerful graphic card is quite ridiculous for a software for UI/UX prototype. Are you planning to update the version with more compatibility or I have to bin my mac book pro to use the software?

This is my mac:

Thanks

2

comments

sort by

official comment
Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

UPDATE

Our Engineers have been busy working to improve InVision Studio :) I wanted to reach out and let you know that as of Studio 1.8.0, the Intel HD Graphics 4000 gpu is now supported! We're terribly sorry for the lengthy delay in getting this resolved, but I hope you will still give Studio a try! 

Our team has been testing on an older Macbook Pro and we're happy to report that Studio appears to be working as expected now. We would like to make sure you're no longer experiencing any trouble. If you can, please visit https://www.invisionapp.com/studio and download the latest version. Once you've updated to 1.8.0 please try Studio out and follow up with us to let us know how it goes. We will be more than happy to take a closer look if you still encounter any issues.

If you have any trouble, we’re always here and happy to help, so please feel free to reach out.


Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Hi Emanuele,

While we strive to support as many systems as possible for our products, we do have certain system requirements. In order to use Studio, we support specific graphics cards at this time as mentioned in our Help Article, "What are the system requirements for Studio?":

To ensure optimal performance, you will want to use Studio on a computer with graphics cards that meet these specifications:

- Intel HD Graphics 5000 and above (found in certain MacBook Air models as early as Mid 2013 and in certain iMac and Mac mini models in 2014)
- Nvidia GeForce GT 650M and above (found in certain MacBook Pro and iMac models as early as Mid 2012)
- ATI Radeon HD 4850 and above (found in certain iMac models early as 2009)

After reviewing your “About this Mac” overview, I see that you are currently using a computer with an Intel HD Graphics 4000 graphics card. What you're encountering is a known limitation that our Product and Engineering teams have evaluated based on factors including severity, impact, scale, and frequency. Given the cost required to address this bug, we have decided to allocate our resources to address other issues with a greater impact on our customers, and don't intend to fix this issue in the near future.

However, we will continue to track this issue and monitor the prevalence and severity of the bug, and we will revisit that decision if the circumstances change. That being said, I will be opening a ticket on your behalf with our Support team to add your voice to this issue. Please look for a message from our Support team soon.

Thank you very much for your patience and understanding. I apologize for any inconvenience that this has caused for you thus far.

Have a wonderful day,

Shaina

-1

join the conversation

to comment, sign up or sign in.