×

[macOS / Photoshop] CraftManager shows that plugins are installed when they are not

Hey,

I've installed CraftManager quite long time ago and used it mainly with Sketch, but a few days ago I found that some extensions are not available in Photoshop when they should be available (Freehand and Sync are not available).

CraftManager shows that all plugins are installed but I cannot toggle any switch in CraftManager panel, look screen below:

but when I go to CraftManager - "Preferences" it says that "Craft for Photoshop - Not installed"

 

I was trying to follow instructions provided in https://support.invisionapp.com/hc/en-us/articles/207773013-Using-Craft-by-InVision-LABS mainly about removing files from "~/Library/Application Support" but it didn't help. I removed also any invision plugin from "~/Library/Application Support/Adobe/CEP/extensions".

Any ideas what should I do to resolve this issue?

My system

  • macOS 10.14.1
  • Photoshop CC 2019 (20.0.0), "Enable Generator" is checked
  • CraftManager 1.0.73
0

Comments

Please sign in to leave a comment.

  • Avatar
    Shaina Torgerson

    Hi Dawid,

    Sorry to hear that you're running into this issue, and I appreciate you taking the time to search our Knowledge Base for answers. I'm happy to help!

    Would you mind trying to delete ~/Library/Application Support/CraftManagerand reinstall Craft Manager and let me know if this resolved the issue with the plugins for Photoshop appearing as not installed?

    If you continue to receive the generator error after reinstalling Craft Manager, we have seen cases regarding this issue where the plugin "Generator" was installing itself under the normal Photoshop file directory instead of under the Plug-ins. 

    To resolve this issue, please try to move the "Generator" folder into the "Plug-ins" directory, as displayed in the screenshot below:

    Looking forward to hearing from you,

    Shaina

    0
  • Avatar
    Dawid Karabin
    ~/Library/Application Support/CraftManager

    - I removed and reinstalled CraftManager, it didn't help.

    - I didn't have any problems with "Generator" but according to your suggestion, I removed "Generator" folder, it didn't help.

    I managed to fix this issue by using AppCleaner.app, it found all CraftManager files even some in "/private/tmp/" directory, removed everything by using AppCleaner.app and after launching CraftManager again, I got "introduction" messages and could install "photoshop plugins" and "sketch plugins", now everything works.

     

     

     

    Thanks for help, maybe it will help someone else.

    0
  • Avatar
    Shaina Torgerson

    Hi Dawid,

    So glad to hear that you were able to find a solution by using AppCleaner.app, and for posting your process here in Community. Please let me know if there's anything else I can help you with.

    Best,

    Shaina

    0