×

Craft Sync not exporting some nested symbols correctly in Sketch 52.1

When syncing my updated Sketch (52.1) files with an Invision prototoype using Craft Sync (2.3.82), I noticed a particular icon missing. Upon further inspection with Invision Inspect, I can see that the icon did export, but Invision is placing it outside the artboard. It appears to be placing it based on the width of the original symbol and not taking into account the resizing. A straight Sketch export will place it correctly, so it's clearly something in the Invision + Craft process.

 

Here is a bug test I set up - note that there are icons partially appearing along the right edge, and one in particular that is off canvas.

 

Here is the direct Sketch export

 

Would love to get this fixed... yesterday!

 

1

Comments

Please sign in to leave a comment.

  • Avatar
    Shaina Torgerson

    Hi Rolf,

    Thank you very much for providing these details around the issues you are facing with Craft Sync and Sketch 52.1. As a first step in troubleshooting, can you please confirm what version of Craft Manager you are currently running?

    Look forward to hearing from you,

    Shaina

    0
  • Avatar
    Rolf Mortenson

    v1.0.72 (122)

    0
  • Avatar
    Shaina Torgerson

    Hi Rolf,

    Thanks so much for providing your Craft Manager version. Since you are on the latest version of Craft Manager, it sounds like this may be occurring for another reason. Do you happen to be running any other plugins besides the Craft plugins (i.e. Anima's Auto Layout plugin)?

    Best,

    Shaina

    0
  • Avatar
    Rolf Mortenson

    While I do have Anima's Auto Layout plugin installed, it wasn't used in either case. As a test, I removed it and re-synced with Craft and there was no improvement. I have not used any other plugins with this.

    0
  • Avatar
    Rolf Mortenson

    I take that back, after rebooting, the removal of Anima Auto Layout did fix the issue - thank you!

    0
  • Avatar
    Shaina Torgerson

    Glad to hear it, Rolf! Please let me know if you continue to have issues, and I can get our Support team involved.

    Have a great day,

    Shaina

    0
  • Avatar
    Heather Henderson

    My team uses Sketch, Craft, and Anima plugins in our workflow. We've deactivated Anima plugin for the time being. How can we resolve this issue? Should we submit a ticket to Anima plugin developers? Or is it something InVision developers can address?

    0
  • Avatar
    Shaina Torgerson

    Hi Heather,

    Sorry to hear that you're also running into these issues, but I'm glad to hear that disabling the Anima plugin helps in the meantime. As for finding a resolution for this issue, I would definitely recommend to reporting these issues to our Support team so they can take a closer look. I'm happy to open a ticket on your behalf with them. Can please provide the following information?:

         1. A screenshot of your "About this Mac" overview
         2. The version of Sketch you're running
         3. The version of Craft Manager you're using

    Look forward to hearing from you,

    Shaina

    0
  • Avatar
    Heather Henderson

    Thanks, Shaina. Here's the information:

    1. macOS Mojave Version 10.14 iMac (Retina 4K, 21.5-inch, 2017)

    2. Sketch Version 52.6

    3. Craft Version 10.0.74

    0
  • Avatar
    Beth Vanderkolk

    Hi Heather!

    Shaina's OOO today so I'm taking over for her :)

    I just sent your details to our Support team, so you should hear back soon!

    Beth

    0