Skip to main content
InVision Support Home Page
InVision ambassador ambassador
Brandon Shepard
Brandon Shepard Updated

Craft Menu Bar Missing

I'm on Sketch 51.3, MacOS Mojave v.10.14, Craft Manage v1.0.70 (117) and the craft menu bar is missing. Is there an update to craft manager I'm missing here? 

This post is associated with a known feature request: [[ problemTicketSubject ]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.

-1

comments

Sort by

Beth Vanderkolk
InVision ambassador Beth Vanderkolk , ambassador

Hey Julia,

I'm so sorry for any frustration around this issue! I'm going to put you in touch directly with our Support team. I'll open a ticket on your behalf so they can begin to troubleshoot with you ASAP. Keep your eyed peeled for an email. Thanks for bearing with us here.

Beth

0
Zarrin Rahman
InVision ambassador Zarrin Rahman , ambassador Edited

Hi there,

I'm experiencing some problems with the Craft Manager app v1.0.72 (122) with Sketch 52.3. It appears that there is a bug and it showed as installed in the Craft Manager but in the preferences and in Sketch plugins it is not installed. It doesn't even show up in the plugin window in Sketch :(

Would appreciate some help on this, thank you!



0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Hi Zarrin,

So sorry to hear that you're also running into these issues with the latest version of Craft. I'd like to have you perform a comprehensive, deep uninstall/reinstall of Craft using the steps below. Please skip any steps that are not applicable (e.g. if a file/folder mentioned is not present) and let me know if you get stuck anywhere along the way:

  1. Close Craft Manager (by clicking into the "C" > clicking the gear icon > choosing Close).
  2. Go into Sketch, and navigate to Plugins ➝ Manage Plugins.
  3. In the pop-up modal, select Craft by InVision Labs, and click the gear icon in the lower left and select the uninstall option. This will move some items to the trash.
  4. Quit Sketch entirely.
  5. Open the Activity Monitor (via Applications > Utilities > Activity Monitor), and then force quit the Craft Manager and Panels (if applicable) processes.
  6. Open Spotlight and search for ~/Library/Application Support/
  7. Delete the com.invisionlabs.CraftManager folder, the com.invisionlabs.CraftManager.json file, the com.invisionlabs.CraftInstaller folder, and the CraftManager folder.
  8. Open the com.bohemiancoding.sketch3 folder.
  9. Delete the Panels folder (if applicable). Please note that these steps will remove any custom Type or Photos items you’ve created in Craft Data. If you'd like to preserve those, please go to ~/Library/Application Support/com.bohemiancoding.sketch3/Panels/.settings and back up the file "com.invisionlabs.data."
  10. Open the Plugins folder.
  11. Delete the Panels.sketchplugin file (if applicable).
  12. Navigate to the Downloads folder.
  13. Search for craftinstaller and delete any files that deal with the Craft Installation process.
  14. In Applications or the folder in which you installed Craft Manager, delete CraftManager.app.
  15. Empty the Trash.
  16. Go to https://craft-assets.invisionapp.com/CraftManager/production/CraftManager.zip and unzip the CraftManager
  17. Drag and drop the Craft Manager app into your computer's "Applications" folder or the folder of your choice before launching it.
  18. Open Craft Manager and then install Craft for Sketch.
  19. If you had backed up the "com.invisionlabs.data" file before performing these steps: launch Sketch now in order to rebuild the ` ~/Library/Application Support/com.bohemiancoding.sketch3/Panels/.settings ` directory. Then, place the backed up "com.invisionlabs.data" file in the ".settings" folder and restart Sketch to restore your custom Type & Photos items.

Let me know how you go with this. If you have any questions along the way please don't hesitate to ask.

Look forward to hearing from you,

Shaina

0
Tyler Hinkelman
InVision ambassador Tyler Hinkelman , ambassador

19 Steps to fix this, and who knows how long it could all take, honestly it'd be easier to just revert my OS back to High Sierra

0
Zarrin Rahman
InVision ambassador Zarrin Rahman , ambassador

Hi @Shaina

I've tried these steps previously from another posters problem but since the Craft plugin isn't actually installed for Sketch it does not appear in the plugins menu and in any of the folders.

This is the same problem I have experienced to one of the other users in this thread and support saying it is a bug an opening a ticket to fix this.

It's becoming an annoyance exporting each screen to my InVision account and adding to projects rather than with the plugin :(

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Hi Tyler,

Sorry to hear that you are also encountering this issue. Can you please confirm what versions of Craft Manager and Sketch you are currently running? If you are on the most up-to-date versions of each, I will be happy to open a ticket on your behalf so that our Support team can do some further troubleshooting.

Thanks,

Shaina

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Hi Zarrin,

Thank you very much for performing the comprehensive uninstall and reinstall. We greatly appreciate you taking the time to do some further troubleshooting.

At this point, I would like for our Support team to take a closer look at this and will open a ticket on your behalf. Please look for a message from our Support team soon.

Best,

Shaina

0
Mark Thomsen
InVision ambassador Mark Thomsen , ambassador

I experience the same problem. Craft toolbar is missing. High Sierra 10.13.6, Sketch 63.1, Craft 1.0.103. I have uninstalled Craft, deleted Craft folder, restarted my mac, installed craft once again and clicked the "toogle craft" in the Plugins menu. Still no sign of the Craft toolbar. Please help.

0
Jessica Eisner
InVision ambassador Jessica Eisner , InVision Employee , ambassador

Mark Thomsen Thanks for getting in touch on this! I suspect you may be encountering a new issue. Please see this post. If that doesn't do the trick, please let us know, and we'll create a ticket with our support team to dig in further. 

0

join the conversation

To comment, sign up or sign in.