Skip to main content
Latest news: [[ newestAnnouncement.title ]] Learn more
InVision Support Home Page
Sign in
InVision ambassador ambassador
Gordon Peterson
Gordon Peterson Updated

Scroll

Hi. I am probably overlooking something and this is probably an easy answer, but after adding an interaction from one page to another how do I NOT maintain the scroll position? Currently, in Invision Studio, if I have a button half way down on a long page, and an interaction that links to a totally different long page, the second page's scroll position is the same as the first. I just want it to act like a normal page change and go to the top. How do I do that!? In the online Invision App, it does it by default and I have to check a box that maintains the scroll position. It seems like in studio there would be something that does the opposite? I don't get it.

 

This post is associated with a known feature request: [[ problemTicketSubject ]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.

0

comments

Sort by

official comment

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

UPDATE

Great news! Our engineers identified the source of the issue and we released a fix in the last update which is Studio v1.0.2. Our Support and Engineering teams have tested this and transition interactions should not maintain scroll position anymore. 

I do want to note that we added a new toggle option within the Interactions Panel, in which you can toggle the button to 'Maintain Scrolling Position'

If you are testing your project for this update and are still seeing the behavior, please check your interaction panel to ensure the button isn't toggled on, as it might default to a checked button which would maintain the scrolling position otherwise.

We apologize for any inconvenience that this has caused for anybody who encountered this issue, and we appreciate your patience while we worked to fix this issue.

If anybody continues to have issues, please don't hesitate to reach out.

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador Edited

Hi Gordon,

Sorry to hear that you're encountering this issue in Studio. Our Support team has received reports of similar behavior to what you're seeing. It looks like that when the interaction is located further down the home artboard and requires scrolling, it keeps that same position on the target artboard. When there is no scrolling required, the interaction to the next screen behaves as expected.

I will be escalating this to my Support team so they're able to investigate further. Please look for a message from them soon.

I apologize for any inconvenience that this is causing for you, and appreciate your patience in this process.

Have a great day,

Shaina

If anyone else is experiencing this issue, please contact our Support team directly here to report your incident.

0
Mane Branco
InVision ambassador Mane Branco , ambassador

Hiya, is there a way that I can predefine the app not to include 'Maintain Scroll Position" when I create new interactions?
I use more without than with and its annoying to have to keep changing it.

Thanks

0
Camille M
InVision ambassador Camille M , ambassador

Hi Mane,

Thanks for taking the time to write into Community to share your feedback about this. Great news! This is actually a feature that our Support and Product teams are already tracking interest for.

I will open a ticket on your behalf to track your interest for this potential feature. Please keep an eye out for an email indicating that we’ve formally tracked your feedback.

Have a great day,
Camille

1

join the conversation

To comment, sign up or sign in.