Skip to main content
Latest news: [[ newestAnnouncement.title ]] Learn more
InVision Support Home Page
Sign in
InVision ambassador ambassador
JennaGengler
JennaGengler Updated

Font styles not displaying in InVision Inspect mode

Our designer is using Sketch to create comps, and then using the Craft plugin to sync the artboards to an Invision prototype. When I, as the developer, go to inspect a screen to pull font styles, it allows me to click on a text layer, and the symbol in the layers pane shows that it recognizes it as a text layer, but the styles panel displays no typography data - just a message that says, "Your screen doesn't include any font styles to display." (Screenshot attached.)

We've never had this issue before and are using the same process as usual. Any thoughts? This is making design/dev handoff pretty unbearable. 

Thanks!

This post is associated with a known feature request: [[ problemTicketSubject ]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.

0

comments

Sort by

Lala Galindo
InVision ambassador Lala Galindo , ambassador

Welcome to the community, JennaGengler!

What layer does it select on your left side panel? And what's the name of the font?

Looking forward for your reply and helping out!

Lala

0
Johannes Larsson
InVision ambassador Johannes Larsson , ambassador

I have the same problem, started like 2 days ago. None of my preview projects can tell me the fonts anymore. 

0
Johannes Larsson
InVision ambassador Johannes Larsson , ambassador

I got it working again, just updated the Craft to latest version and its back to normal again. I had to re-sync my project again to overwrite. 

Hope its working for after update as well. 

 

// Johannes

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Hi Johannes,

Thank you very much for sharing this information! Glad that you were able to get this working

Jenna - What version of Craft Manager, and the Craft Plugins are you on?

Have a great day,

Shaina

0
Shaun Smylski
InVision ambassador Shaun Smylski , ambassador

Hello Shaina,

I'm having the same issue as the original poster. I was not able to resolve the issue by updating my Craft plugin or Sketch app.

I have:

  • Craft v1.0.61 and is fully up to date
  • Sketch v50.2 and is fully up to date

I've tried:

  • Deleting the Invision prototype and re-uploading through fully updated Craft and Sketch.
  • I've looked at past projects and found inspect not working either.

Thank you,

 

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Hi Shaun,

Sorry to hear that you're also running into this issue. Thank you very much for providing your version details and what troubleshooting steps you have already performed.

As a first step, I would like for you to update your Craft Manager. You mentioned that you are using Craft Manager v1.0.61, however, the latest version of Craft Manager is 1.0.66. For help finding which Craft plugin versions you're currently using or to check for updates, please read this guide.

Please let me know if you run into any issue updating Craft Manager to the latest version.

Thanks,

Shaina

0
Shaun Smylski
InVision ambassador Shaun Smylski , ambassador

Thank you Shaina,

I was able to resolve the issue. 

I thought I was up to date, but I was confusing the "'Sketch Tools' were up to date" message with the Craft App updates found in Settings > Preferences > Check for updates. 

 Thank you,

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Hi Shaun,

Happy to hear that you were able to resolve this issue! Please let me know if there's anything else I can help you with.

Have a great day,

Shaina

0
daki85
InVision ambassador daki85 , ambassador

Hi, does anybody know if InVison can recognize text style from Sketch in Inspector Mode?
Thanks!

0
Beth Vanderkolk
InVision ambassador Beth Vanderkolk , ambassador

Hey there,

It'll recognize all the attributes of the text, but nothing that mentions what text style it is:

1
Kit French
InVision ambassador Kit French , ambassador

I'm also curious about this above question ^^

 

0
Beth Vanderkolk
InVision ambassador Beth Vanderkolk , ambassador

Hello,

Apologies for any confusion. I believe by "style," you mean the Sketch library style:

At this time, InVision does not show the section highlighted in red in Inspect; we just show the raw font data just below it. 

0
daki85
InVision ambassador daki85 , ambassador

Thank you Beth! Yes, that's exactly what I was thinking of. Any chance to get that feature anytime soon? I think that would be very useful for collaboration between designers and developers. 😊

1
Beth Vanderkolk
InVision ambassador Beth Vanderkolk , ambassador

Hey there,

I can't make any promises but it's a feature request that the Product Manager of Inspect is already tracking!

Beth

2
Mattia
InVision ambassador Mattia , ambassador

+1 for the feature request

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Hi Mattia,

I'm happy to open a ticket on your behalf to track your vote for the ability to generate a style guide from Inspect properties. Please look for a message confirming your vote soon.

If anybody else would like to add their vote for this feature, please contact Support here and voice your opinion!

Have a great day,

Shaina

 
0
Christopher Daly
InVision ambassador Christopher Daly , ambassador

I am having the same issue - but specific to when there are multiple fonts in the layer. IE, when a single text layer has, say, two fonts within it. If the two fonts are in the same family, the font family attribute will display, but the face attribute will not. If the two fonts are not the same family, than neither the family nor the face attribute display.

Note: Zeplin displays this use case correctly, with separate attribute sets for each font face in the layer.

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Hi Christopher, 

Sorry to hear you're running into this issue. Can you please provide the following details so that we can dig a bit deeper into what might be happening here?:

     1. A screencast or screenshot displaying the use case you have described above.
     2. What version of Sketch are you using?
     3. What version of Craft Manager are you using?
     4. What version of the Craft Sync + Prototype plugin are you using?

Look forward to hearing from you!

Shaina

0
Christopher Daly
InVision ambassador Christopher Daly , ambassador

Thanks Shaina

First the versions...

Sketch: v52.5 (but this same issue was happening on earlier versions)

Craft Manager: v1.0.73

Craft Syn plug-in: v1.0.55

 

And here's a video of the use case. The results actually changed a bit with all the new updates, but inspect mode can't distinguish multiple fonts in a single layer.

In the video you see 3 lines of text, each with a different font configuration, to see what Inspect reads it as:

- line 1: whole line is in Lato Light font. This is acceptably read in Inspect mode as Family: Lato, Weight: 300

- line 2: line starts with Lato Light and ends with Lato Bold. This is read in Inspect mode as Family: Lato, Weight: Bold

- line 3: line starts with Lato Light and ends with Georgia regular. This is read in Inspect mode as Family: Georgia, Weight: Regular

So clearly Inspect Mode is only picking up the last font face/weight data it finds in a layer, rather than each set.

https://drive.google.com/open?id=1czN8JmsynMG-lOltDoXV4KgsFsIsWwid

 

 

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador Edited

Hi Christopher,

Thank you for providing all of those details! I am seeing that you are on an outdated version of the Craft Sync + Prototype plugin. The current version is 2.3.108.

Can you please try updating your plugin and see if you continue to run into this issue? For help finding which Craft plugin versions you're currently using or to check for updates, please read this guide.

Look forward to hearing from you,

Shaina 

 

0
Christopher Daly
InVision ambassador Christopher Daly , ambassador

Sorry - I'm on 2.3.108.

Looks like i had both the old Craft plug-in as well as the new Craft Manager with plug-ins going. I turned the old one off. Same issue. It simply looks like Inspect mode can only handle one font per layer. Please confirm.

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Hi Christopher,

Thank you very much for double checking. I would like for our Support team to take a closer look at this issue and do some further troubleshooting.

I will open a ticket on your behalf with our Support requesting additional information. Please look for a message requesting this information soon.

Best,

Shaina

0

join the conversation

To comment, sign up or sign in.