Sorry, the InVision Help Center does not support Internet Explorer. Please download Microsoft Edge or another modern browser.

InVision ambassador ambassador
Adrian Adrian

Library problem with sync between 2+ designers creates -new Folder


wehre using the current Craft Manager Plugin and Sketch version but we have still problems with using one and same library.
I can create e clean and new library on out cloud drive. But when my colleague is importing this library craft creates a xxx-new folder.
Also the same issue when he is creating a new library and i will import it.

We are both working with the lasses Craft and Sketch version.
But collaborating actually is not possible.

Please can someone from the support help us.



sort by

Preston McCauley
InVision ambassador Preston McCauley , ambassador
Comment actions Permalink

Hi Adrian,

What type of cloud drive are you using to share your files? I've experienced this at times if there is a slow down or firewall between the two systems with onedrive, and at times with dropbox.


InVision ambassador Adrian , ambassador
Comment actions Permalink

Hey Preston,

tried it with Dropbox, OneCloud, Nextcloud and Adobe CreativeCloud...


Preston McCauley
InVision ambassador Preston McCauley , ambassador Edited
Comment actions Permalink

Here is what I tried to replicate it.

I created 2 new libraries. I placed one in dropbox, another in onedrive. I then went to import and imported library one. I looked in the folder and didn't see any XXX-new folder. I closed out sketch and opened it again and repeated the process with onedrive.  

I suspect what's going on is a permission issue on the folder that is preventing one of your systems from the write read / write privileges to the shared folder. As a result when you import the library it's trying to update but it can't so it creates a new folder. I would try to make sure you all have the same permissions. It may be something at a system level on one persons mac depending on your own business policies that are blocking the save.


Jordan Dimitrov
InVision ambassador Jordan Dimitrov , ambassador
Comment actions Permalink

Hi @Adrian, did you by any chance find a solution to your issue?

Our team is experiencing the same roadblock, and we also tried all kinds of clouds.

To @Preston's advice - it's not a permissions thing :/


Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador
Comment actions Permalink

Hi Jordan,

Thank you very much for both reaching out here in Community, and directly to our Support team. It appears as if our Support team was able to help you find a resolution to the issues you were encountering.

For others' reference, please make sure that everyone on your team has imported and is using the "-new.library" folder as the default folder for the remote library. To expand on that, when you first import a library into Craft Library v1.0.54+, Craft will create a copy of your library and add -new to the Library file name.

Craft’s conflict resolution feature requires special files to be present in order to track checksums, which allows Craft to compare the local and remote libraries to determine whether changes have been made. Since these special files are created only within the "-new" library, all team members should make sure to be using the "-new" library folder moving forward and treat it as the remote library. Here you have some more information on the how the Craft library works and the utility of the -new.library folder.

Thanks again for re-raising this issue, Jordan!




join the conversation

to comment, sign up or sign in.