Skip to main content
InVision Support Home Page
InVision ambassador ambassador
Zoltan Totik
Zoltan Totik Updated

craft sync - exportable layers not showing up as assets, stuck on "sync in progress" when viewed in inspector

I am trying to sync a sketch file using library symbols with craft sync. Layers and slices are marked as exportable in the library file. The artboard gets synced and can be viewed correctly in inspect, but when selecting the library symbol layers that are set as exportable, the previews of the assets don't show up, and instead have "sync in progress" and "preview not yet available" beside them, and there is no download link for them either.
The assets don't appear in the project's assets either.

Anybody have this? Any workaround other than NOT using sketch library?

sketch: 49.2
craft sync+prototype: 2.3.66
craft manager:1.0.58


This post is associated with a known feature request: [[ problemTicketSubject ]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.



Sort by

Preston McCauley
InVision ambassador Preston McCauley , ambassador Edited


I tried to do all the above and I'm not seeing the messages you are seeing. I'm also able to download the individual assets and the package assets. You may have to put in a support ticket if you are still experiencing this problem. 


Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Hi Zoltan,

So sorry to hear that you're running into this. I noticed that you have already reached out to our Support team in regards to this issue. I have notified them of your post here in Community as well.

The Support team will be able to best assist you with this issue. Please be sure to look for a message from them soon. I will also keep an eye on your ticket.

Look forward to getting some answers for you!



Zoltan Totik
InVision ambassador Zoltan Totik , ambassador

Hi Preston,

I tried with a brand new sketch file and a brand new library. Were your symbols from an external library as well? Those are the ones that don't work in invision inspect.
Thanks, Zoli

Preston McCauley
InVision ambassador Preston McCauley , ambassador

Mine were from a new library I created and synced.. It may be a feature request or ticket. 

Thomas Miller
InVision ambassador Thomas Miller , ambassador

Having this exact problem.

Michael S
InVision ambassador Michael S , ambassador

Hi Thomas!

Thanks for getting in touch. I'm sorry to hear you're experiencing this issue as well!

When you have a moment, would you mind providing the following information for us to troubleshoot?

  1. What operating system are you using? Please include the version (e.g. macOS 10.13.3 or Windows 10).
  2. What version of Sketch are you using?
  3. What Version of Craft Manager and the Craft Sync plugin are you using? (Navigate to Craft Manager and hover over Sync to view its version)

These details will help us take a closer look into what might be going on. We look forward to hearing back from you!



join the conversation

To comment, sign up or sign in.