×

InVision projects unavailable in Craft sync

The none of my previous projects show up as available to sync to from the Craft plugin since updating the plugin to the newest version using version 49 of Sketch. I've tried restarting and re-installing the plugin but nothing works.

0

Comments

Please sign in to leave a comment.

  • Avatar
    Shaina Torgerson

     Hi Chris,

    As a next step, I'd like to have you perform a comprehensive, deep uninstall/reinstall of Craft using the steps below. Please skip any steps that are not applicable (e.g. if a file/folder mentioned is not present):

    1. Close Craft Manager (by clicking into the "C" > clicking the gear icon > choosing Close).
    2. Go into Sketch, and navigate to Plugins ➝ Manage Plugins.
    3. In the pop-up modal, select Craft by InVision Labs, and click the gear icon in the lower left and select the uninstall option. This will move some items to the trash.
    4. Quit Sketch entirely.
    5. Open the Activity Monitor (via Applications > Utilities > Activity Monitor), and then force quit the Craft Manager and Panels (if applicable) processes.
    6. Open Spotlight and search for ~/Library/Application Support/
    7. Delete the com.invisionlabs.CraftManager folder, the com.invisionlabs.CraftManager.json file, the com.invisionlabs.CraftInstaller folder, and the CraftManager folder.
    8. Open the com.bohemiancoding.sketch3 folder.
    9. Delete the Panels folder (if applicable). Please note that these steps will remove any custom Type or Photos items you’ve created in Craft Data. If you'd like to preserve those, please go to ~/Library/Application Support/com.bohemiancoding.sketch3/Panels/.settings and back up the file "com.invisionlabs.data."
    10. Open the Plugins folder.
    11. Delete the Panels.sketchplugin file (if applicable).
    12. Navigate to the Downloads folder.
    13. Search for craftinstaller and delete any files that deal with the Craft Installation process.
    14. In Applications or the folder in which you installed Craft Manager, delete CraftManager.app.
    15. Empty the Trash.
    16. Go to https://s3.amazonaws.com/www-assets.invisionapp.com/labs/craft/manager/CraftManager.zip and unzip the CraftManager
    17. Drag and drop the Craft Manager app into your computer's "Applications" folder or the folder of your choice before launching it.
    18. Open Craft Manager and then install Craft for Sketch.
    19. If you had backed up the "com.invisionlabs.data" file before performing these steps: launch Sketch now in order to rebuild the ` ~/Library/Application Support/com.bohemiancoding.sketch3/Panels/.settings ` directory. Then, place the backed up "com.invisionlabs.data" file in the ".settings" folder and restart Sketch to restore your custom Type & Photos items.

    Please let me know if this does not solve your issue.

    Thanks,

    Shaina

    0
  • Avatar
    Linda Strydom

    Hi Shaina,

    This doesn't work for me. Ive upgraded my Craft plugin, tried the above but still cant see my projects. We are a huge company which means we still run on an old version of Sketch (Version 44.1). This might be the problem?

    Linda

    0
  • Avatar
    Shaina Torgerson

    Hi Linda,

    As a next step, could you please open a Terminal session (via Applications > UtilitiesTerminal) and run the following two commands to delete those tokens? 

    • defaults delete com.bohemiancoding.sketch3.plist com.invisionlabs.Sync.refreshToken
    • defaults delete com.bohemiancoding.sketch3.plist com.invisionlabs.Sync.accessToken


    After that, simply restart Sketch, and you should then be able to log in.

    Please let me know if you continue to have any trouble, and we'll take a deeper look!

    Thanks,

    Shaina

    0