×

The Craft plugin is not showing on my sketch after installed

I just downloaded the CraftManger.zip and installed the plugin, but the plugin is not showing up on my Sketch. I tried to install it again, but it not allowed me to reinstalled. and I double click the CraftManger icon in my "Application", nothing shows up...Any one had same situation? 

0

Comments

Please sign in to leave a comment.

  • Avatar
    Shaina Torgerson

    Hi Qing,

    In order to locate the newly installed Craft Manager plugin, can you please try going to your "Plugins" menu on your Sketch toolbar and click "Toggle Craft"? See below:

    If this does not resolve the issue please let me know.

    Thanks,

    Shaina

    0
  • Avatar
    QING YANG

    Hi Shaina,

    Thanks for your reply, but Toggle Craft is not showing under Plugins in my Sketch. And when I reinstalled the Craft application, it's keeping showing the message below, but I really don't know what's going on. 

    0
  • Avatar
    Shaina Torgerson

    Hi Qing,

    As a next step, I'd like to have you perform a comprehensive, deep uninstall/reinstall of Craft using the steps below. Please skip any steps that are not applicable (e.g. if a file/folder mentioned is not present):

    1. Close Craft Manager (by clicking into the "C" > clicking the gear icon > choosing Close).
    2. Go into Sketch, and navigate to Plugins ➝ Manage Plugins.
    3. In the pop-up modal, select Craft by InVision Labs, and click the gear icon in the lower left and select the uninstall option. This will move some items to the trash.
    4. Quit Sketch entirely.
    5. Open the Activity Monitor (via Applications > Utilities > Activity Monitor), and then force quit the Craft Manager and Panels (if applicable) processes.
    6. Open Spotlight and search for ~/Library/Application Support/
    7. Delete the com.invisionlabs.CraftManager folder, the com.invisionlabs.CraftManager.json file, the com.invisionlabs.CraftInstaller folder, and the CraftManager folder.
    8. Open the com.bohemiancoding.sketch3 folder.
    9. Delete the Panels folder (if applicable). Please note that these steps will remove any custom Type or Photos items you’ve created in Craft Data. If you'd like to preserve those, please go to ~/Library/Application Support/com.bohemiancoding.sketch3/Panels/.settings and back up the file "com.invisionlabs.data."
    10. Open the Plugins folder.
    11. Delete the Panels.sketchplugin file (if applicable).
    12. Navigate to the Downloads folder.
    13. Search for craftinstaller and delete any files that deal with the Craft Installation process.
    14. In Applications or the folder in which you installed Craft Manager, delete CraftManager.app.
    15. Empty the Trash.
    16. Go to https://s3.amazonaws.com/www-assets.invisionapp.com/labs/craft/manager/CraftManager.zip and unzip the CraftManager
    17. Drag and drop the Craft Manager app into your computer's "Applications" folder or the folder of your choice before launching it.
    18. Open Craft Manager and then install Craft for Sketch.
    19. If you had backed up the "com.invisionlabs.data" file before performing these steps: launch Sketch now in order to rebuild the ` ~/Library/Application Support/com.bohemiancoding.sketch3/Panels/.settings ` directory. Then, place the backed up "com.invisionlabs.data" file in the ".settings" folder and restart Sketch to restore your custom Type & Photos items.

    Please let me know if this does not solve your issue.

    Thanks,

    Shaina

    0
  • Avatar
    Max Blake

    Hi Shaina,

    I'm having the same problem, and followed your steps above. Still nothing.

    I double-click on Craft Manager once in my application folder and nothing happens.

    I'm using MacOS 10.13.6

     

    Thanks

    0
  • Avatar
    Shaina Torgerson

    Hi Max,

    Thank you very much for attempting my steps provided above, and I'm sorry for any inconvenience with this issue. Before sending this to our Support team, can you please provide the following information so that they can better diagnose your issue?:

         1. Can you please provide a screenshot of your "About this Mac" overview?
         2. What version of Craft Manager are you currently running?
         3. What version of Sketch are you using?

    Look forward to hearing from you and helping you get some answers.

    Thanks,

    Shaina

    0
  • Avatar
    Prameela Jeppu

    it was working fine untill I updated sketch. The craft panel has disappeared. I don't find it in my plugins either. Pleas help..!

    0
  • Avatar
    Shaina Torgerson

    Hi Prameela,

    Thank you for reaching out here in Community, as well as opening a ticket with our Support team. I noticed that one of our Support agents has responded to your request with some troubleshooting steps. I have notified them of your comment here in Community, and they will be able to best assist you moving forward.

    Please let me know if there's anything else I can do to help.

    Best,

    Shaina

    0
  • Avatar
    Nor Adilla Adlin

    Hi Shaina,

     

    I'm facing the same problem as Prameela. Everything works fine until I updated my machine. 

    Before this I used Craft tool to sync with inVision. However, it was missing. 

    Please kindly assist.

    Thank you.

    1
  • Avatar
    Shaina Torgerson

     Hi Nor Adilla Adin,

    Sorry to hear that you're also running into this issue. Can you please provide the following information?:

         1. Can you please provide a screenshot of your "About this Mac" overview?
         2. Have you tried the comprehensive uninstall/reinstall steps detailed above?
         3. What version of Sketch are you using?
         4. Can you please try to click the Craft "C" icon, then shift + cmd + r? This should bring all plugins up to date. After doing so, please restart Sketch and check the plugins again.

    Look forward to hearing from you,

    Shaina

    0
  • Avatar
    Mark B

    Hi Shaina, 

    I'm having the exact same issue. However, mine happened all of sudden and not right after install. I just noticed one day all of the plugins missing from the sidebar. The only part left was the gray C at the top. I've done everything you have suggested here with no luck. Please see the info you asked for from someone above. 

    Sketch version 52.4

    Thanks

     

    1
  • Avatar
    Shaina Torgerson

    Hi Mark,

    Sorry to hear that you're also running into this! I appreciate you providing all of the details requested from others above, as well as going through the troubleshooting steps in this thread.

    I would like for our Support team to take a closer look at this issue for you and will be opening a ticket on your behalf. Please look for a message from our Support team soon.

    Thanks,

    Shaina

    0
  • Avatar
    Jaylyn Dawson

    I also have this problem and when I did the 'comprehensive uninstall' and got to step #18 I noticed this message.

    0
  • Avatar
    Shaina Torgerson

    Hi Jaylyn,

    Thanks for attempting the uninstall/reinstall process. I'm sorry to hear that you ran into this error message when doing so. In order to further troubleshoot, can you please provide the following info?:

         1. A screenshot of your "About this Mac" overview
         2. Your Sketch version number
         3. Can you please try to reset your password?
              - Click here >> https://projects.invisionapp.com/d/password/requestReset
              - Enter the email address associated with your account.
              - Click Request Reset Link.

    Look forward to hearing from you,

    Shaina

    0
  • Avatar
    Will Hepworth

    Hi, 

    I'm also having that issue. I'm Sketch version 52.5. CraftManager has been installed and reinstalled on my macbook as per the above guidance but the toolbar still isn't appearing in my Sketch file. Attached image of macbook details for reference. Please could you help? 

     

    Thanks

    0
  • Avatar
    Shaina Torgerson

    Hi Will,

    Sorry to hear that you're also running this issue. Can you please provide the following information?:

         1. Did you attempt the comprehensive uninstall/reinstall steps detailed above?
         2. Did you attempt to reset your password and log back in as detailed above?
         3. Can you please provide a screenshot of the error message(s) you are receiving?
         4. What steps did you take in order to encounter this issue?

    Look forward to hearing from you,

    Shaina

    0