Sorry, the InVision Help Center does not support Internet Explorer. Please download Microsoft Edge or another modern browser.


InVision ambassador ambassador
William Martin William Martin

Library assets not working since updating to Sketch 49

All of my assets are present in the library, but when I move them onto an artboard, everything except text is hidden. The selection container still behaves as if the asset were completely present, but nothing is visible.

 

0

comments

sort by


Preston McCauley
InVision ambassador Preston McCauley , ambassador

Hi Good Morning William,

Can you check to see what version of craft manager you are currently running? 

Thanks

0

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador

Hey William,

This issue might be related to the release of Sketch 49. 

If you haven't already done a complete uninstall and reinstall, please follow the steps below:

      1. Uninstall all the Craft plugins from Sketch 
      2. Uninstall Craft Manager
      3. Restart computer
      4. Download the new version of Craft Manager and you're back in business!

If you are still having issues after performing the update, please be sure to post here and I will notify our Support team.

Thanks,

Shaina

0

William Martin
InVision ambassador William Martin , ambassador

Craft Manager v. 1.0.52 (78)

Yesterday I completely uninstalled/reinstalled craft manager and the problem persisted after restarting.

0

Hsichen Hsieh
InVision ambassador Hsichen Hsieh , ambassador

Uninstall and reinstall Craft didn't work. Those grey shapes in the middle are some of the icon symbols in the library.



0

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador Edited

Hi William and Hsichen,

Thanks for first trying the uninstall-and-reinstall steps provided. So sorry that you're still experiencing these frustrating issues.

I will be opening tickets on each of your behalf with our Support team so that they can troubleshoot further with you, and get to the root of the issue you are facing. Please look for a message from our Support team soon.

Thanks for hanging in there with us!

Shaina

If anyone else is experiencing this issue, please contact our Support team directly here for the speediest resolution.

0

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador

Update!

We've released a new version of Craft Library 1.0.76 with a fix in place to resolve the issue discussed in this thread, where the majority of the elements within symbols were invisible when dragging the symbol from Craft Shared Library into a Sketch document after the update to Sketch 49. Please check that you're on the most current version of Craft Library and Sketch. You can check your Craft Library version by clicking the "C" icon and then hovering over Library as in the screenshot below:

  

Please first check for any Craft Manager updates by clicking the "C" icon > gear icon > Preferences > Check for updates. This will ensure you're on the most current version of Craft Manager.

To check for any plugin updates, simply click the "C" icon once again and then hit shift + command + R to refresh Craft Manager. This should then prompt to restart Sketch if any updates are available.

Once you're on the most current version of Craft Library, you should no longer experience the issue. Thanks to everybody for their patience with us!

0

join the conversation

to comment, sign up or sign in.