Skip to main content
InVision Support Home Page
InVision ambassador ambassador
Alessandro
Alessandro Updated

DELETED ASSETS STILL VISIBLE IN INSPECT MODE > UNEXPECTED ERROR

Hi there,

I've started using the "Slice" tool in Sketch to have automatically generated assets in the Inspect Mode, to speed up the process together with devs. Really clever. The issue is that when I removed the slice from Sketch, since some of theme where "a test", I can still see them in the inspect mode but of course are broken, since the link is now missing. If I try to select and download I'm immediately redirect to an "Unexpected Error" page. I did also check the InVision Sync folder and there's nothing there. I've ended up using the Assets folder where my devs go and download them, but I'd really like to know what's the issue, or if I'm doing something wrong within Sket-Craft-InVision. Screen shots attached. Thanks y'all!

 

 



This post is associated with a known feature request: [[ problemTicketSubject ]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.

0

comments

Sort by

Elizabeth Brookshire
InVision ambassador Elizabeth Brookshire , ambassador

Hi Chiara, welcome and thanks for these details! I'm going to open a ticket with our Support team so we can dig in deeper and determine what's causing those error messages and assets from being removed after deleting them from your prototype. Stay tuned for a separate message from us. Thanks!

0
Patrick Shannon
InVision ambassador Patrick Shannon , ambassador

I have the same problem, exportables that are accidentally synced with Invision are removed from the comp or assets folder view area, they still show up in the Inspect > Assets area as shown in the screenshot above. I think there should be a way to delete assets on that page.

0
Beth Vanderkolk
InVision ambassador Beth Vanderkolk , ambassador

Hey Patrick,

I'm so sorry for the trouble! Our Engineering team is currently looking into this, so I'm going to connect you with our Support Team so they can keep you posted.

Beth

0
Marcin
InVision ambassador Marcin , ambassador

Its ultra mega big crap, that assets which dont existing in Sketch project are still available at Invision assets Panel!!!!

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Hi Marcin,

This issue is absolutely on our Engineering team's radar, and I will be sure to raise this in our next Product meeting as well.

Please look for a message from our Support team soon. They will be able dive deeper into this issue with you and provide some feedback.

Thanks and have a wonderful day,

Shaina

0
John Daltrey
InVision ambassador John Daltrey , ambassador

Hi, is there still no solution to this? My biggest issue is that assets seem to be kept for any older versions of designs with no way to clear them. Even if you delete a design and re-upload they reappear, despite the fact that the slices have been removed in sketch. It really is causing a big issue with workflow... even just the option to manually delete assets after syncing would be a help!

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Hi John,

It appears as if each person who has commented on this thread and has worked with our Support team has reported similar, but different desired functionality. That being said, I would like our Support team to look into the exact functionality you desire and see if they can offer you any advice or a workaround for the time being.

I will open a ticket on your behalf with our Support team. Please look for a message from them soon.

Thanks for your patience,

Shaina

1
Tyler
InVision ambassador Tyler , ambassador

I am also still experiencing this issue on several of my prototypes. 

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Hi Tyler,

Very sorry to hear you’re running into an issue with your assets in Inspect as well. Would it be possible to provide a screenshot of this particular issue, as well as confirm the version of Craft Manger that you're using?

Thanks,

Shaina

0
Carina B. Velasquez
InVision ambassador Carina B. Velasquez , ambassador

I am also experiencing this bug in Inspect after deleting an asset in the "Assets" tab in Invision.

0
Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador

Thanks for reaching out here, as well as in another Community thread about this issue, Carina. As mentioned in my response to your other comment, can you please provide a screenshot displaying this issue? Feel free to respond here or in the other Community thread.

0

join the conversation

To comment, sign up or sign in.