Sorry, the InVision Help Center does not support Internet Explorer. Please download Microsoft Edge or another modern browser.


InVision ambassador ambassador
Alex Restuccia Alex Restuccia Edited

"No metadata.json file" message appears every time a new Sketch window opens

Every time I open a new Sketch window (whether it's opening an existing .sketch file, or starting a new .sketch file) I get the following message:

No metadata.json file

No metadata.json file located in "<filename>.library". If your library is stored in a cloud location, please ensure it has fully downloaded before attempting to import again, and contact us at "https://support.invisionapp.com/hc/en-us" if troubles persist.

There is in fact a metadata.json file in that library, so I'm not sure what the problem is. The library is stored on an SMB network drive. Everything seems to be working ok in Craft, so it's really just an annoyance. Any suggestions?

Thanks,

Alex

1

comments

sort by


Elizabeth Brookshire
InVision ambassador Elizabeth Brookshire , ambassador

Hi Alex, welcome to the InVision Community! It appears that our Support team will need to investigate the exact source of that error message you're seeing, even though your Library is working ok. I've opened up a ticket with Support so we can get to the bottom of this repetitive message for you, so stay tuned for a separate message from us.Thanks!

0

Ignacio
InVision ambassador Ignacio , ambassador

Hi, I'm having the exact same issue.

I'll gladly provide more information about it.

0

Elizabeth Brookshire
InVision ambassador Elizabeth Brookshire , ambassador

Hi Ignacio, welcome! I've opened a ticket with our Support team so we can dig into your issue,  as well. Stay tuned!

1

Ignacio
InVision ambassador Ignacio , ambassador

Hey! I updated Craft, created a library using the plugin, and now it seems it's solved. ¯\_(ツ)_/¯

0

Elizabeth Brookshire
InVision ambassador Elizabeth Brookshire , ambassador Edited

Great news, Ignacio! Glad it was a simple fix. Thanks for letting us know how you solved this!

0

Katja Sinning
InVision ambassador Katja Sinning , ambassador

Hi, today the exact same problem popped up for me. I think it appeared after the last craft plugin update...do you know how I can solve this issue?

0

Shaina Torgerson
InVision ambassador Shaina Torgerson, InVision Employee , ambassador

Hi Katja,

So sorry that you're running into this issue! Apologies for the troubles you're having here with your Library. Can you try the following for me:

     -Open the Library plugin and remove all Libraries in the plugin
     -Quit out of Sketch
     -Open Spotlight and navigate to the following folder: ~/Library/Application 
     -Support/com.bohemiancoding.sketch3/Panels/.settings/Documents/com.invisionlabs.library
     -Remove the Libraries that appear here from the folder
     -Re-open Sketch and import the Library

After doing that, are you continuing to see this issue?

Best,

Shaina

0

join the conversation

to comment, sign up or sign in.