Sorry, the InVision Help Center does not support Internet Explorer. Please download Microsoft Edge or another modern browser.


InVision ambassador ambassador
Hayley Barile

Custom placed overlays

The overlays are being extremely glitchy. I will set a custom placed overlay on my screen (for a dropdown menu) but when I go to view it in preview mode it will be in the wrong place or won't show up at all. Worst of all, when I share the link to try my prototype they do not work at all!!! Help!

This post is associated with a known feature request: [[problemTicketSubject]]. Let our Product team know that you’re interested in this feature.

Sign in to add your vote

Thanks for taking the time to share your feedback about making our product better. We’ve let our Product team know that you’re interested in this feature so they can factor that into their product strategy.

comments

Sort by

official comment

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador Edited
Comment actions Permalink

UPDATE: 

We had provided an interim update some time ago to let customers who reported this issue know that our engineers had fixed a part of the issue in iOS app version (2.3.3), specifically for desktop type prototypes but the issue still persisted for mobile/tablet prototypes.

With this update, it is my pleasure to let you all know that we're considering this issue to be fully resolved, as overlays are now correctly positioned for all prototype types in the latest version of the iOS App version 2.6.4. We really appreciate your patience and we encourage you to reach out if you still encounter any issues. 


Beth Vanderkolk
InVision ambassador Beth Vanderkolk , ambassador
Comment actions Permalink

Hi Hayley,

This sounds like something our Support team needs to look into for you- it definitely doesn't sound right! My sincere apologies for any frustration here. Keep a look out for a response from our Support team via email shortly.

Beth

0

Mitch N
InVision ambassador Mitch N , ambassador
Comment actions Permalink

Same problems. Preview in the browser is fine but when I view it in the IOS app the position is way off. Any updates on this?

0

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador
Comment actions Permalink

Hi Mitch,

Our Support team needed more information around this issue on the customer's specific case. Since this is a unique issue, I will open a ticket on your behalf so that our Support team can dive deeper for you.

Please standby for a message from our Support team.

Have a wonderful day,

Shaina

1

Terrance Luckett
InVision ambassador Terrance Luckett , ambassador
Comment actions Permalink

I have found a work around for this, while it gets sorted by InVision. Simply create an Artboard (in my case using Photoshop) with the same width as the screen that will host the overlay. Make sure you have the background set to transparent. Then position the elements where they are to be rendered in the view, positioned absolutely from the top edge. Then in InVision, simple set Top Center and it should work. Doing it that way solved my custom position problems on both iPhone and Android devices. Obviously this is not a solution for screen with a lot of elements further down in the view. But For simple views, this is what is working for me.

 

0

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador Edited
Comment actions Permalink

Hi Terrance,

Thanks so much for sharing that workaround with the rest of the Community! I'm sure this will come in very handy for other InVision users while we're working on things.

Since you are also experiencing this issue, I would be happy to open a ticket on your behalf with our Support team so that they can log it. Please look for a message from them shortly.

Have a wonderful day,

Shaina

If anyone else is experiencing this issue, please contact our Support team directly here for the speediest resolution. And, of course, please feel free to use Terrance's workaround for the time being!

0

Sandy Perez-Sanchez
InVision ambassador Sandy Perez-Sanchez , ambassador
Comment actions Permalink

This is still a problem today. Selecting "Custom" and placing the overlay manually in position does NOT get saved. When you hit Enter to get out of the Custom mode, it displays the item centered, and the dropdown to select the placement options reverts to "Centered" as well. You can actually see the "Centered" appear as the selected option right through the transparent layer when you are in custom mode.

0

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador
Comment actions Permalink

Hi Sandy,

So sorry to hear that you're also running into this issue. I would like for our Support team to dive deeper into this with you to help determine the cause of this.

I will open a ticket on your behalf with our Support team, in which they will request more information from you for troubleshooting. Please look for a message from them soon.

Have a great day,

Shaina

0

Sandy Perez-Sanchez
InVision ambassador Sandy Perez-Sanchez , ambassador
Comment actions Permalink

Hi, I had ended up finding a workaround, since I needed to present the prototype the day I wrote this, and I knew I would not be able to resolve it on time. I ended up exporting the screen at full size with a transparent background. Thanks.

0

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador
Comment actions Permalink

Hi Sandy,

Thanks for the heads up! I have let the Support agent who was assisting you know that you found a workaround.

Have a wonderful day,

Shaina

0

Chelsea Reyes
InVision ambassador Chelsea Reyes , ambassador
Comment actions Permalink

I am having the same issue - custom placed overlays defaulting to centered. And they won't even show up in my prototype at all. Incredibly frustrating.

0

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador
Comment actions Permalink

Hi Chelsea,

Sorry to hear that you're running into this issue! Can you please provide the following information?:

     1. Does the issue continue when viewing your project in an incognito or private window?
     2. Could you please provide screenshots of the issue occurring?
     3. Are you experiencing this in the mobile application, or just your browser?
     4. What browser and version are you on?

Look forward to hearing from you,

Shaina

0

Chelsea Reyes
InVision ambassador Chelsea Reyes , ambassador
Comment actions Permalink

Shaina,

The issue appears to have been resolved, however this is what was happening:

     1. Does the issue continue when viewing your project in an incognito or private window? When testing today, it was working fine.
     2. Could you please provide screenshots of the issue occurring? It's more of a flow. When I would place a hotspot, then I would set the hotspot to do an overlay with a custom placed overlay. I would set the overlay, and on hitting enter, the hotspot menu would tell me the overlay was centered rather than custom placed. Then, when I tested it, either the hotspot would not work at all on click, or it would indeed make the overlay centered rather than where I had placed it.
     3. Are you experiencing this in the mobile application, or just your browser? This was only in the browser. It is a tablet prototype but I have not had the chance to test it on a touch device yet.
     4. What browser and version are you on? Chrome on mac, Version 67.0.3396.99 (Official Build) (64-bit)

0

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador
Comment actions Permalink

Hi Chelsea,

Happy to hear that the issue is now resolved! As mentioned in my update above, it appears as if our Mobile team released a fix for this issue just yesterday. This would explain why things are now working for you. 

Please feel free to reach out if you continue you have issues after the update.

Thanks,

Shaina

0

Jodi
InVision ambassador Jodi , ambassador
Comment actions Permalink

Hi. I'm having similar issues. I've set a panel to appear as an overlay in a custom position. If I click the hotspot to activate the panel from that page without having arrived at the page from another, it all works fine.

If, however, I was on a different page and scrolled down that page, when I get to the page with the hotspot that activates the panel, it appears in a position relative to the scroll position of the previous page! Neither have anything to do with the other, so I'm not sure why this is happening. It's very frustrating because sometimes if I've scrolled all the way down the page on the previous screen, then nothing appears when I click the hotspot that activates the panel because it's out of view.

 

0

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador
Comment actions Permalink

Hi Jodi,

So sorry to hear that you're also running into issues with customer placed overlays not appearing in the correct position when previewing your prototype. I greatly appreciate your detailed screenshots! This really helps visualize the issues you're running into. 

In order to determine what might be causing this, I will need some additional information. Please provide the following information at your convenience:

     1. What type of device are you previewing your prototype on?
     2. Are you previewing your prototype on a desktop web browser, mobile web browser, or the InVision mobile app?
     3. If you are previewing on a browser, please provide your browser details. You can get these details by going to http://www.whatsmybrowser.org/, clicking “Copy”, and pasting the link it gives you here.
     4. If you are previewing on the InVision mobile app, what version are you currently running?
     5. Is this happening for all prototypes or just this one?
     6. Does the issue continue when viewing your project in an incognito or private window?
     7. Can you please provide a screenshot displaying your overlay settings for the one having this issue?

Look forward to hearing from you,

Shaina

0

Hannah Kyle
InVision ambassador Hannah Kyle , ambassador
Comment actions Permalink

Hello,

I've seen multiple times in this thread that this issue has been resolved, but I am experiencing the exact same issue. I set it to custom placement for my overlay, press enter, go to view it and it is still in the wrong spot on the screen.

 

Hannah

0

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador
Comment actions Permalink

Hi Hannah,

Thanks for reaching out here in Community about this issue. I'm sorry to hear that you're also encountering the issue described above.

So that we can better understand why you might be experiencing this, we will need the following information:

     1. What type of device are you previewing your prototype on?
     2. Are you previewing your prototype on a desktop web browser, mobile web browser, or the InVision mobile app?
     3. If you are previewing on a browser, please provide your browser details. You can get these details by going to http://www.whatsmybrowser.org/, clicking “Copy”, and pasting the link it gives you here.
     4. If you are previewing on the InVision mobile app, what version are you currently running?
     5. Is this happening for all prototypes or just this one?
     6. Does the issue continue when viewing your project in an incognito or private window?
     7. Can you please provide a screenshot displaying your overlay settings for the one having this issue?

Look forward to hearing from you,

Shaina

0

Alec Starzef
InVision ambassador Alec Starzef , ambassador
Comment actions Permalink

Same issue with me, can't set custom position for the overlay screen. I'm on Mac and Chrome is not capable for this. Safari is better, I am able set custom position about 50% of the time.

0

Shaina Torgerson
InVision ambassador Shaina Torgerson , ambassador
Comment actions Permalink

Sorry to hear that you're also running into these issues with overlays, Alec. Can you please provide the same information as requested above?:

  1. A screenshot of your "About this Mac" overview
  2. Please provide your browser details for both Chrome and Safari. You can get these details by going to http://www.whatsmybrowser.org/, clicking “Copy”, and pasting the link it gives you here.
  3. Is this happening for all prototypes or just this one?
  4. Does the issue continue when viewing your project in an incognito or private window?
  5. Can you please provide a screenshot displaying your overlay settings for the one having this issue?

Look forward to hearing from you,

Shaina

0

Rupert Edson
InVision ambassador Rupert Edson , ambassador
Comment actions Permalink

I was having this same problem. Switching from Chrome to Edge resolved the issue for me. 

0

join the conversation

to comment, sign up or sign in.