×

Release Notes: September 2018

We are improving InVision by squashing bugs and releasing new features every day. Here's an account of what we've accomplished this month.

Studio

What’s New as of Version 0.97.1

  • From SVG export and shadow rendering to input fields and menu items, we’ve included over 150 bug fixes and improvements in this release. The result is a more stable, more consistent, and more reliable experience.

Improvements & Bug Fixes

Tools & Shortcuts

  • Improved behavior when editing a path: You can now distribute multiple selected points when editing a path.
  • Pen and Scissors icon issue: Now you won’t encounter the issue that caused the Pen and Scissors tool icon to continue displaying, even after switching to another tool.
  • Undo error issue: After drawing a shape with the pen tool, using the Undo option (in the Edit menu or via the keyboard shortcut, ⌘+Z) to step back to the last point in the path no longer causes an error.
  • Improved File menu: You’ll notice that you can now use the File menu to access Preview and Publish options. We also cleaned up the titles and order of items listed in the File menu.
  • Unintended scrolling issue: Using the spacebar to pan the canvas no longer scrolls the layers panel.
  • Keyboard modifiers: When drawing an artboard, keyboard modifiers for constraining the proportion or changing the origin are now applied as expected.
  • Document swatches: You’ll see improved handling of document swatches across separate installations of Studio.
  • Improved indication of hierarchy in layers panel: Reordering a layer in a way that would result in the layer being placed outside of an artboard will now display a dashed line in the layers panel to more clearly indicate the change in hierarchy.
  • Move to Front and Move to Back shortcuts issue: When selecting a layer from the layers panel, you will no longer run into the issue that would prevent the Move to Front and Move to Back keyboard shortcuts from working.
  • Page deletion: You can now delete a page using the Delete key or the Delete action in the Edit menu.
  • Color picker issue: When using the color picker and pressing the Tab key to move between the RGB or HSL input fields, you will no longer encounter the issue that prevented Studio from committing any changes made to the previous field.
  • Improved handling of menu items: Studio now handles menu items based on the state of the selected layer or overall state of the application.
  • Cursor issue: Now you won’t run into the issue that caused the cursor to get stuck using the path icon after the Paste Image as Fill shortcut (CTRL + Option + V) was used editing a path.
  • Search layers issue: Using the Search Layers shortcut (CMD + F) while viewing the pages or library panel will no longer jump back to the layers list.
  • Grab issue: When drawing a layer shape, you no longer have to press the Spacebar twice to invoke the grab behavior.
  • Issue when searching the layers panel: Groups and containers inside a component definition can now be expanded or collapsed when the Layers panel is being filtered by a search term.
  • Aligning and distributing layers: Keyboard shortcuts for aligning and distributing layers now work as expected, even when the layers panel is hidden.
  • Issue selecting path points: You should no longer experience the issue that prevented you from using the selection net to select path points when grouped with another layer and not inside an artboard.
  • Issue with paths not on an artboard: Aligning points on a path that is not on an artboard now works as expected.

Layers & Styling Layers

  • Rendering and performance of shadows: You’ll notice major improvements to shadow and inner shadow rendering and performance. We also improved rendering of inner shadows for shapes with borders.
  • Files with numerous combined shapes: You should see improved performance when working with files that contain many combined shapes.
  • Resizing duplicated combined shapes: The reliability of resizing combined shapes that have been duplicated has been improved.
  • Positioning font layers: Modifying the position of a font layer using auto width that contains a missing font will now update its position as expected.
  • Issue with paths that aren’t on an artboard: When editing points on a path that isn’t placed on an artboard, the changes are applied as expected.
  • Pasting rich text: When pasting rich text between text layers, the rich text now behaves as expected.
  • Issue with locked layers and alignment: Locked layers now stay where they are placed, even when included in a selection and any alignment options are used.
  • Distributing masked layers: You’ll see better handling of distributing layers when the selection includes masked layers.
  • Moving layers without fills or borders: Layers that have no visible fill or border can now be dragged and moved in the editor after being selected from the layers panel.
  • Issue changing path point types: You will no longer see the issue that prevented you from changing a path point type after using the ESC key to stop drawing the path.
  • Issue reordering children of a combined shape: Reordering multiple child layers of a combined shape now works as expected.
  • Corner radius of a path point:
    • Deleting the contents of the corner radius input field for a path point now resets it back to zero.
    • The corner radius of a path point is no longer capped at 100px.

Canvas

  • Improved accuracy of the color picker: The application now defaults to sRGB for everything.
  • Issue moving grouped, unbound shape layers: When moving grouped, unbound shape layers (e.g., a line segment), you will no longer experience the issue that could sometimes cause the layer to move in the opposite direction as intended.
  • Improved snapping behavior:
    • When editing paths with Smart Guides active, you will notice the snapping behavior has improved.
    • When a layer’s original value is a decimal, snapping to grids and columns now works better.
  • Improved behavior when pasting an object into an artboard: Now if the position of the pasted object would be out of view, it is pasted into the center of the viewport instead.
  • Issue adding or removing child layers with keyboard modifiers: Layers that are children of a component or are not part of an artboard now behave as expected when using keyboard modifiers to add or remove layers from the selection.
  • Displaying artboard names when zooming out: Now when zooming out, artboard names are displayed longer before getting truncated or hidden.
  • Issues with bounding boxes: You will no longer see the issues that sometimes prevented the bounding box from matching the path, especially if the points had a corner radius, resulting in rendering artifacts and clipping.
  • Unintentional shifting of layers: When un-grouping the parent of a deeply nested group, you won’t encounter the issue that would cause the layers to shift unexpectedly.
  • New notification style for certain errors: You will notice that we’ve introduced a new toast notification style for non-critical errors, like those related to file import.

Inspector

  • Improved accuracy of X and Y positioning: When multiple layers are selected, you’ll notice an improvement in how Studio displays the X and Y position.
  • Issue with scrolling feature: This release corrects an issue that would result in the scrolling feature getting hidden in the inspector for some users.
  • Issue with Bézier curve input fields: Updating the values of a Bézier curve using the input fields now works as expected in the motion editor.
  • Issue with X, Y, height, and width values: After converting a group to a container and then attempting to undo that change, you will no longer encounter the issue that caused invalid X, Y, height, and width values in the inspector.
  • Unit label legibility: You can no longer run into a scenario in which the X or Y values in the inspector could overlap the unit label.
  • Issue with certain vertically aligned layers jumping: Now you won’t see the issue that would cause the layers to jump when editing the X value of multiple vertically aligned layers by scrubbing the input label.
  • Issue with file operations: Now you won’t encounter the issue that would prevent file operations—such as saving or zooming—when certain input fields or menus were active.
  • Unintentionally disabled anchor panel: The anchor panel is no longer disabled for children of a component instance that is not placed on an artboard.
  • Issue with editing placement: Trying to move a point at 0,0 using the inspector now works as expected.

Importing & Exporting

  • Improved export performance:
    • Exporting SVG files: You should notice major improvements to Studio’s SVG export capabilities, including support for the line path type and better handling of opacity, corner radius, and gradient fills.
    • Assets that extend their boundaries: You’ll also see improved handling when exporting assets that extend their bounds by shadows or borders.
  • Error handling: Studio now more gracefully handles any errors that occur when importing very large Sketch files.
  • Accuracy of bitmap exports: You’ll see improved accuracy of bitmap exports when a child of a group is anchored to anything other than top-left, a situation that previously could cause issues.
  • Exporting artboards as raster images: When exporting especially large artboards as raster images, you’ll see improved performance.
  • Issue with duplicated artboards: Duplicated artboards now retain the Include in Export setting as expected.
  • Edit multiple layers at once: Now you can edit matching export options of multiple selected layers at the same time.

Components

  • Unintended ability to paste a page into a component definition: Corrected a scenario that could have allowed you to paste an entire page into a component definition.
  • Removed unnecessary icons: When editing a master component, you will no longer see the Back and Add Page icons, which were defunct and unnecessary.
  • Issue with component instances not updating: You will no longer experience an issue that would prevent component instances from updating after editing or swapping nested components in the component definition.
  • Issue with text overrides: Your text overrides on a component instance will now get added to the undo/redo history as expected.
  • Issue swapping nested component instances: Swapping component instances that are nested multiple levels deep now behaves as expected.
  • Improvement to nested components: You can now include nested components in groups created in a component definition.
  • Issue with detaching a component instance: Detaching a component from its definition no longer results in unexpected layer positioning when the child layers are constrained to something other than the top left.
  • Unresponsive inspector panel: The inspector panel will no longer become unresponsive after swapping a component instance.

Basic Interactions & Advanced Animations

  • Issue with timing in motion editor: You will no longer encounter an issue that prevented a layer’s duration and delay settings from getting reflected accurately in the motion editor.
  • Issue with interaction panel: Opening the list of triggers in the interaction panel no longer causes the position of the interaction panel to jump.

Previewing Prototypes

  • Unwanted positioning of layers: You won’t run into the issue that caused some layers to get positioned unexpectedly after resizing or zooming the preview window.
  • Issue with cursor when previewing: Using the arrow keys when previewing a prototype and trying to edit the size of a custom device using the input fields now moves your cursor as expected, instead of controlling the prototype.
  • Unwanted hotspot boundary visibility: You will no longer see a brief flash of the blue hotspot boundaries on the target artboard when interacting with a prototype that uses a double-click trigger.
  • Issue with viewport size: Setting a custom viewport size in the preview window will no longer automatically switch over to Auto if the height or width is larger than 1200px.

Publishing Prototypes

  • Issue with artboard backgrounds: Publishing artboards or sending them to Freehand will now always include the artboard background.
  • Issue with copy in Freehand publishing flow: You will no longer see the inaccurate copy that was in the Freehand publishing flow.
  • Improved error handling and state preservation: When publishing to Freehand, you may notice the improved handling of errors and preserving states.

Collaboration

Improvements & Bug Fixes

  • IP range whitelisting: InVision now has IP range whitelisting support for IPv4 and IPv6 ranges. Enterprise users can request InVision support to turn on IP whitelisting for your select ranges.
  • Boards in the main project page: You may notice that we've stopped reloading board thumbnail placeholders in the main projects page. This will increase the product performance.
  • Choose a plan page: You will see a new “Choose a plan” page in the InVision billing section.
  • Stability improvements: A number of stability improvements and optimizations were made this month to ensure the product works as expected.
  • @mention for team members: You can now @mention team members who don’t belong to a prototype. This will trigger an email notification that will include a prototype share link.
  • Assets with Android prefixes: You can now download all Android asset versions if you have specified multiple prefixes for exporting.
  • Updating billing details: Now you can't run into a couple of blockers that had prevented some users from updating their billing details. 

Craft + Sync

What's New

  • Increased Support: Craft + Sync is now supported for use with Sketch 52.

Improvements & Bug Fixes

  • Migrate to object IDs: To track screen changes and asset changes, Craft + Sync now uses object IDs, which resolves many common bugs where screen updates get out of sync.

See all our Craft + Sync release notes.

Mobile: Android

Improvements & Bug Fixes in Version 1.10.6

  • Performance improvements: This month we made a number of bug fixes and performance improvements.

See all our Android app release notes.

Security

Improvements & Bug Fixes

  • Platform stability & security improvements: This month we made general security fixes including updates addressing the publicly announced Intel processor vulnerability.

Getting Started: Release Notes (
)

Release Notes: September 2018

Prev