×

Release Notes: Studio

InVision is committed to continually improving Studio by resolving bugs and often implementing new features with each release. You'll find our latest Studio release notes below.

InVision Studio 1.3.0

This quick release will squash a few more annoying bugs and speed up your workflow when editing components.

Improvements and Bug Fixes

Tools & Shortcuts

  • You can now right-click any component instance to quickly edit its definition.
  • Even better, type Command + Enter with a component instance selected to start editing the definition. Then use Command + Esc to return to the instance.

Layers & Styling Layers

  • Shadows with 0px blurs now render as expected on containers.
  • Applying X and Y offsets to inner shadows with a blur greater than 0 works as expected again.
  • Reordering layers between containers no longer results in an unexpected shift in the layer's position.
  • When pasting or duplicating pinned layers inside a container, you’ll notice an improvement to how Studio calculates their position.

Canvas

  • Some invalid combined shapes were getting the renderer all out of sorts. Those kinds of errors are handled more gracefully now.

Previewing Prototypes

  • Does trying to paste a hex code into the preview window's background color picker have you feeling #0000ff? Everything should work as expected now.
  • Changing a viewport in the preview window to one that is larger than the currently selected viewport will no longer require a refresh to render the entire view.

Publishing Prototypes

  • Attempting to publish a prototype using one of the Web presets no longer results in an error.
  • Attempting to publish a prototype with the preview set to a semi-transparent window background color no longer results in an error either.

InVision Studio 1.0

This packed Studio release includes powerful new features and enhancements—all based on feedback from users like you. Learn more about what’s new below, and start designing your best screen ever. We can’t wait to see what you create.

Shared Design Libraries

Shared design libraries create a source of truth across teams. This new way of managing and sharing components makes it easy to improve collaboration and increase consistency. Any changes made to components in the library automatically sync across every file using those components, keeping everyone and everything up to date.

Device Frames

Preview your prototype as it will appear on a device using one of our beautiful new device frames. Covering 25 different devices and over 70 color variants, not only do they add realism and provide greater context to your designs, you'll be able to ensure your content steers clear of any rounded corners or notches.

Pen Tool Update

Draw paths with increased speed, accuracy, and fidelity using our newly-revamped Pen tool.

Other New Features

  • Now you can choose whether you want to maintain the user's scroll position when transitioning between scrollable artboards.
  • You no longer have to auto-link new layers added to a motion transition. We'll do it for you in the background so your animations are always up to date.

Major Improvements & Highlights

  • You'll notice improved scrolling performance for files with numerous text layers.
  • You'll also see improved performance overall when working with and resizing combined shapes.
  • Check out the all-new interface for managing Pages in the Layers panel.
  • Now you can change the grid and column layout settings of multiple selected artboards at the same time.
  • To enable more-immersive presentations, the top bar in the preview window is now hidden in fullscreen mode.
  • Smart guides now appear when moving artboards and layers that are not part of an artboard.
  • The new and improved sign-in form makes it much easier to sign in to a team account or create a new InVision account.
  • Improved rendering accuracy of outside and inside borders along curved paths ensures smooth sailing.
  • With the improved rendering of oval masks, you won't run into pixelated edges.

Other Improvements & Bug Fixes

Tools & Shortcuts

  • The Pen tool now shows a live preview of the path or point that will be drawn as you move your cursor around the canvas.
  • You should notice improved accuracy of the Pen tool when closing a path.
  • The Pen tool now supports using the Shift key to snap new path points to 45-degree increments.
  • When creating a new point with the Pen tool, now you can click and drag to convert the point from straight to mirrored.
  • There's a new selected state for path points that makes it much easier to differentiate between selected and un-selected.
  • When drawing with the Pen tool, you'll find that the tolerance for closing a path is less aggressive.
  • The Cut Path tool now behaves as expected when removing segments from open paths.
  • You'll find that the way Studio calculates and renders corner radii is much improved, especially on non-right angles.
  • Corner radius is no longer calculated on open ends of a path.
  • You can count on improved accuracy when rendering paths connecting a straight point and a mirrored point.
  • Snapping and smart guides are now behaving as expected when creating or moving a path point.
  • The selection net now behaves as expected when selecting path points in a flipped group.
  • The Control key no longer enables deep selection, which is now only enabled with the Command key—as expected.
  • Deep selection using the Command key now works as expected when trying to click through a component instance.
  • We're 99.99% sure you can't tell the difference between a 234% and 234.21% zoom level, so we're just going to round to whole numbers there.
  • When editing a component definition with no layers selected, now you won't see the menu options that were errantly enabled previously.
  • When using the pen tool, now you can't run into the issue that had been causing the canvas to become unresponsive if you switched to a different page while editing a path.
  • While drawing a shape, clicking Escape before releasing the mouse or trackpad button no longer causes all tools to become unresponsive to keyboard shortcuts until another tool is manually selected from the menu.

Layers & Styling Layers

  • Duplicating a text layer now positions the new layer consistently, regardless of the selected layout constraints.
  • Dragging a layer to the bottom of the layer list while editing a component definition no longer deletes that layer.
  • Pasted layers that could previously fall outside the container's visible bounds are now placed in the center, while all other layers retain their X and Y position.
  • Files created with older versions of Studio no longer run the risk of containing data that was preventing artboard duplication.
  • Layers that have been set to ignore the underlying masks can now be added to a new mask as expected.
  • The color picker now stays open when you select a layer from the Layers panel.
  • The border on new rectangles, rounded rectangles, and ovals now defaults to center instead of inside.
  • So you can still see the resize handles on fixed-size text boxes when working with smaller font sizes, we've reduced the threshold for hiding the handles.
  • Setting the X and Y values for multiple selected layers now accepts %-based values as expected.
  • You can no longer run into the issue that was sometimes causing the mouse cursor to get stuck if you hit Escape while editing a gradient endpoint.
  • After using the Layers panel to move combined shapes outside of an artboard, the shapes now remain selectable.
  • Double-clicking a group will now consistently drill into the group as expected. Previously, this action would sporadically fail.
  • The masking icon now accurately reflects the active state of a layer.
  • When resetting the line height back to auto after setting it to another numeric value, you'll notice improved consistency.
  • Rotating a layer no longer forces it to snap to pixels.
  • Undoing a rotation action no longer takes two undo commands.
  • Dragging a group that contains a combined shape into a container now updates the container's bounds as expected.
  • The calculations of borders on a combined shape have been improved to prevent Studio from crashing (in rare instances) when editing the border.
  • Changing the width and height of a flipped layer with a locked aspect ratio now behaves as expected when scrubbing your mouse over the input label or using the arrow keys to increment the value.
  • Blurs for shadows and inner shadows now have an upper limit of 100px.
  • To smooth out jagged edges, we've improved the rendering of rotated paths.
  • For more accurate rendering when viewing at 100% zoom level, we've increased the anti-aliasing of rounded caps on paths.
  • Semi-transparent drop shadows with 0px blurs now render more accurately.
  • You'll see improved anti-aliasing of drop shadows and inner shadows with 1px blurs.
  • Pasting hidden UTF-8 characters into a text field no longer causes the text to become invisible once you've committed the changes.
  • Converting a group to a container and vice versa now preserves the layers' layout constraints and renders the expected position when the layers are moved.
  • Pinned layers in a group that has been flipped horizontally or vertically now move and resize as expected.
  • When resizing multiple layers with large shadows, you'll notice improved performance.

Canvas

  • Resizing the Layers panel now feels snappier and more accurately tracks your mouse movement.
  • Paste in Place and Paste and Replace now position the layers as expected when pasting into a group or container.
  • Now you won't hit the 16,000px limit on the X and Y coordinates—we've removed the limit.
  • Smart guides no longer appear when you're trying to snap to a layout column, row, or grid.
  • When reducing the line height of a text field or using negative letter spacing, you'll no longer see the issue that was previously sometimes resulting in rendering artifacts.
  • You can no longer interact with the layers list or canvas when a modal view is active.
  • Zooming out extremely quickly—which could happen if your mouse wheel was set to a ludicrously high sensitivity—no longer causes Studio to hang.
  • The jitter bug is dead: Layers will no longer occasionally jump by 1px when while dragging and holding Shift to constrain movement to one dimension.
  • Drawing a new layer into a flipped group now renders the layer in the expected location.
  • When dragging an object that uses both a large outside border and large shadow value, now you don't have to suffer the issue that would previously cause artifacts to remain on the canvas.

Inspector

  • You'll notice that the Artboard Orientation toggle button in the Inspector panel has been replaced with a more obvious Swap icon.
  • Changing the height of a group using the arrow keys now increments by 1 as expected.
  • The Typography section of the Inspector panel now displays only the font weights that are available for each typeface.
  • Setting the vertical and horizontal pinning options from the dropdown lists now works as expected.
  • Now Studio will apply the changes you make in the HSL color picker input fields when moving to another field rather than only applying the changes when you press Enter.
  • A single selected point can't be in two places at once; therefore, Studio will no longer show a Mixed value for a its position if set to 0,0.
  • The X and Y fields are now disabled in the Inspector panel when nothing is selected because... well, nothing is selected.
  • The X and Y coordinates of a group are now accurately displayed after switching the group to a container and then back a group again.
  • Multiple selected path points with different values now display Mixed in the X and Y fields instead of 0.

Importing & Exporting

  • When importing from Sketch, you'll notice improved handling of image fills and layout constraints on groups.
  • Importing combined shapes from Sketch no longer applies percentage-based coordinates to the sub paths, because that had previously caused strange behavior when resizing the parent of the combined shape.
  • You'll notice improved accuracy when exporting SVGs.
  • You'll also notice an improved result when exporting bitmap images that are swapped nested components that had been used as an override.
  • The message alerting you to any errors after a Sketch import now stays visible until you close it. This message also now indicates how many instances of each error occurred.
  • Symbols from remote libraries in Sketch continue to import just fine, and now you can also copy and paste those remote symbols into Studio.
  • Now you can import a file by dragging it onto the Studio app icon in the Dock without running into an error.

Components

  • Master components will now reflect updates made to their nested components as expected.
  • Studio pinning rules have been updated, so groups now inherit the pinning of their child layers when converted into a component.
  • Offset pinning changes made in a component master will now update the pinning of component instances as expected.
  • When editing a component, Studio will now show the correct layer in a selected state as expected.
  • You can now expand components as expected in the layers list after using Command+Click.
  • You can now swap components that have the same name.
  • You will no longer encounter the issue that had caused layers in a component master to be removed from the component if they were dragged to be orphans.
  • Detaching a component and then ungrouping layers within that component will no longer errantly change the position and size of the layers.
  • Copying and pasting a child layer in a component that has offset pinning will no longer paste the layer in an unexpected location.
  • Now if you change the pinning of a component layer after resizing the component artboard, the component will not jump.
  • Now you can make changes to a component without losing the background of the component artboard.
  • It's no longer possible to paste layers into a component instance using paste in place functionality.
  • You can now expand and collapse nested components that are orphans as expected in the layers list.
  • Removing certain styles from component masters when the styles are overridden in component instances no longer causes Studio to crash.
  • Component instances now reset to their original state as expected, because we've improved Studio's reset overrides logic.
  • The Inspector panel now correctly displays any styles that have been overridden in a component instance.
  • Changing between auto and fixed text properties no longer causes the text layer to jump in components.
  • Swapped components now update as expected in the layers list.
  • Pinned, combined shapes in components now update properly when you resize them.
  • The Undo and Redo functionality now updates pinning properties for components as expected.
  • When creating components from containers, the component bounds will now behave as expected.
  • You will no longer see drawable properties in component frames, since you shouldn't be able to add them.
  • The ability to override text with color was causing a cascade of other component bugs, so we have removed this ability.
  • You can now delete a component definition from the library panel even while viewing that component master on the canvas.
  • Component masters that contain nested components can now be detached as expected.
  • Selecting multiple components and nudging them together will no longer errantly change the width of certain layers.
  • You can now draw new layers—including when a layer of a component is selected—without Studio positioning the new layers in unexpected locations.
  • Creating components as orphans will no longer cause groups, masks, and containers to jump position.
  • Now you can use Undo and Redo functionality on text overrides.
  • Creating a component from rotated paths will no longer break the artboard of the component.
  • Converting a group to a component will no longer errantly change the X and Y values of children in the group.
  • Now combined shapes won't show up in unexpected places after reopening a Studio file.
  • Text layers inside a component instance now respect the defined layout properties of the master component.
  • The thumbnail preview for an image fill of a layer that is the child of a component now correctly updates immediately after being edited.
  • It's no longer possible to create combined shapes from multiple layers inside a component instance, because that functionality changed the structure of the component itself.
  • Overrides on nested component instances are now applied as expected after detaching the component.

Basic Interactions & Advanced Animations

  • Studio now displays a warning message if you create an interaction with a Timer trigger set to a 0s timeout on both the originating artboard and target artboard, because this configuration will prevent the target artboard from rendering. It's still possible to create such an interaction, but we obviously don't recommend it.
  • The default timeout for a Timer trigger is now 0.2s to avoid that 0s scenario.
  • You can no longer set the duration of a Motion transition to an invalid value, because the invalid value would prevent you from adjusting the timing curve in the Timeline editor.
  • You can now scroll the menu in the Navigate To Screen dropdown list, so your options are no longer limited to the number of artboards that could fit on your screen.
  • Artboards now render as expected after returning from the Timeline editor.

Previewing Prototypes

  • You'll notice improved consistency between the preview window and the Timeline editor when rendering an animation.
  • Now you won't see an issue that previously resulted in some rendering artifacts when animating artboard backgrounds.
  • You'll no longer see any white flickers between preset transitions; this issue had especially impacted the Push transition.
  • The preview window will no longer occasionally become white during an animation and render only the start and end artboard.
  • Appearance settings and the last used viewport are now saved with the file so you don't have to reset your preferences each time you preview your prototype.
  • The input labels for the viewport size now update when you move to another field rather than requiring you to hit Return in each field.
  • You should notice the improved performance when interacting with and resizing the preview window, even when the appearance settings dialog is visible.
  • You'll also not improved performance when animating layers with image fills, especially on mobile devices.

Publishing Prototypes

  • Prototypes published in landscape orientation will now display as expected when viewing your prototype in InVision Cloud. Previously, an issue had caused these prototypes to display in portrait orientation in InVision.
  • Publishing will no longer fail due to an expired session with no warning from Studio that the session has expired.
  • Users who don't have the necessary permissions to update a given prototype, will no longer see that prototype in the list of previously published prototypes.
  • Clicking the Publish button repeatedly no longer results in duplicate prototypes being created.
  • Now we use the most up-to-date file name to populate the title when publishing a prototype.
  • Prototypes that were published, renamed, and then updated no longer show up twice on the list of previously published prototypes.
  • Previously published prototypes are now sorted as expected—by most recently updated.
  • Updating a published prototype without making any changes to the file no longer creates a duplicate prototype.
  • You should notice improved performance when publishing large prototypes and publishing on slow connections.

Other Improvements & Bug Fixes

  • A failed attempt to sign in to a team account will no longer result in signing you in to your associated personal account without notifying you of the error.
  • Renaming an open file outside of Studio now updates the filename in Studio as expected and no longer prevents the you from saving the file.
  • When you first launch Studio, the Welcome video is now muted by default. To hear the audio, click the speaker icon.
  • Unused image assets are now entirely removed from the Studio file when it's closed.
  • Studio is now more usable—not to mention more beautiful—thanks to various updates to the user interface.
  • You will now see the Studio Tour in its intended position in the launch screen, even if you resize the Layers panel before starting the tour.
  • You will no longer see a temporary email address displayed in the Studio menu after creating a new InVision account.
  • You can now use the links to our new and improved tutorial videos on the Learn Studio hub as expected.
  • You may notice improved visual feedback when Studio is loading a large file.
  • Now you'll see a warning message if you create or open a Studio file on a machine with an unsupported GPU.

Studio Version 0.97.1 

What’s New

  • From SVG export and shadow rendering to input fields and menu items, we’ve included over 150 bug fixes and improvements in this release. The result is a more stable, more consistent, and more reliable experience.

Improvements & Bug Fixes

Tools & Shortcuts

  • Improved behavior when editing a path: You can now distribute multiple selected points when editing a path.
  • Pen and Scissors icon issue: Now you won’t encounter the issue that caused the Pen and Scissors tool icon to continue displaying, even after switching to another tool.
  • Undo error issue: After drawing a shape with the pen tool, using the Undo option (in the Edit menu or via the keyboard shortcut, ⌘+Z) to step back to the last point in the path no longer causes an error.
  • Improved File menu: You’ll notice that you can now use the File menu to access Preview and Publish options. We also cleaned up the titles and order of items listed in the File menu.
  • Unintended scrolling issue: Using the spacebar to pan the canvas no longer scrolls the layers panel.
  • Keyboard modifiers: When drawing an artboard, keyboard modifiers for constraining the proportion or changing the origin are now applied as expected.
  • Document swatches: You’ll see improved handling of document swatches across separate installations of Studio.
  • Improved indication of hierarchy in layers panel: Reordering a layer in a way that would result in the layer being placed outside of an artboard will now display a dashed line in the layers panel to more clearly indicate the change in hierarchy.
  • Move to Front and Move to Back shortcuts issue: When selecting a layer from the layers panel, you will no longer run into the issue that would prevent the Move to Front and Move to Back keyboard shortcuts from working.
  • Page deletion: You can now delete a page using the Delete key or the Delete action in the Edit menu.
  • Color picker issue: When using the color picker and pressing the Tab key to move between the RGB or HSL input fields, you will no longer encounter the issue that prevented Studio from committing any changes made to the previous field.
  • Improved handling of menu items: Studio now handles menu items based on the state of the selected layer or overall state of the application.
  • Cursor issue: Now you won’t run into the issue that caused the cursor to get stuck using the path icon after the Paste Image as Fill shortcut (CTRL + Option + V) was used editing a path.
  • Search layers issue: Using the Search Layers shortcut (CMD + F) while viewing the pages or library panel will no longer jump back to the layers list.
  • Grab issue: When drawing a layer shape, you no longer have to press the Spacebar twice to invoke the grab behavior.
  • Issue when searching the layers panel: Groups and containers inside a component definition can now be expanded or collapsed when the Layers panel is being filtered by a search term.
  • Aligning and distributing layers: Keyboard shortcuts for aligning and distributing layers now work as expected, even when the layers panel is hidden.
  • Issue selecting path points: You should no longer experience the issue that prevented you from using the selection net to select path points when grouped with another layer and not inside an artboard.
  • Issue with paths not on an artboard: Aligning points on a path that is not on an artboard now works as expected.

Layers & Styling Layers

  • Rendering and performance of shadows: You’ll notice major improvements to shadow and inner shadow rendering and performance. We also improved rendering of inner shadows for shapes with borders.
  • Files with numerous combined shapes: You should see improved performance when working with files that contain many combined shapes.
  • Resizing duplicated combined shapes: The reliability of resizing combined shapes that have been duplicated has been improved.
  • Positioning font layers: Modifying the position of a font layer using auto width that contains a missing font will now update its position as expected.
  • Issue with paths that aren’t on an artboard: When editing points on a path that isn’t placed on an artboard, the changes are applied as expected.
  • Pasting rich text: When pasting rich text between text layers, the rich text now behaves as expected.
  • Issue with locked layers and alignment: Locked layers now stay where they are placed, even when included in a selection and any alignment options are used.
  • Distributing masked layers: You’ll see better handling of distributing layers when the selection includes masked layers.
  • Moving layers without fills or borders: Layers that have no visible fill or border can now be dragged and moved in the editor after being selected from the layers panel.
  • Issue changing path point types: You will no longer see the issue that prevented you from changing a path point type after using the ESC key to stop drawing the path.
  • Issue reordering children of a combined shape: Reordering multiple child layers of a combined shape now works as expected.
  • Corner radius of a path point:
    • Deleting the contents of the corner radius input field for a path point now resets it back to zero.
    • The corner radius of a path point is no longer capped at 100px.

Canvas

  • Improved accuracy of the color picker: The application now defaults to sRGB for everything.
  • Issue moving grouped, unbound shape layers: When moving grouped, unbound shape layers (e.g., a line segment), you will no longer experience the issue that could sometimes cause the layer to move in the opposite direction as intended.
  • Improved snapping behavior:
    • When editing paths with Smart Guides active, you will notice the snapping behavior has improved.
    • When a layer’s original value is a decimal, snapping to grids and columns now works better.
  • Improved behavior when pasting an object into an artboard: Now if the position of the pasted object would be out of view, it is pasted into the center of the viewport instead.
  • Issue adding or removing child layers with keyboard modifiers: Layers that are children of a component or are not part of an artboard now behave as expected when using keyboard modifiers to add or remove layers from the selection.
  • Displaying artboard names when zooming out: Now when zooming out, artboard names are displayed longer before getting truncated or hidden.
  • Issues with bounding boxes: You will no longer see the issues that sometimes prevented the bounding box from matching the path, especially if the points had a corner radius, resulting in rendering artifacts and clipping.
  • Unintentional shifting of layers: When un-grouping the parent of a deeply nested group, you won’t encounter the issue that would cause the layers to shift unexpectedly.
  • New notification style for certain errors: You will notice that we’ve introduced a new toast notification style for non-critical errors, like those related to file import.

Inspector

  • Improved accuracy of X and Y positioning: When multiple layers are selected, you’ll notice an improvement in how Studio displays the X and Y position.
  • Issue with scrolling feature: This release corrects an issue that would result in the scrolling feature getting hidden in the inspector for some users.
  • Issue with Bézier curve input fields: Updating the values of a Bézier curve using the input fields now works as expected in the motion editor.
  • Issue with X, Y, height, and width values: After converting a group to a container and then attempting to undo that change, you will no longer encounter the issue that caused invalid X, Y, height, and width values in the inspector.
  • Unit label legibility: You can no longer run into a scenario in which the X or Y values in the inspector could overlap the unit label.
  • Issue with certain vertically aligned layers jumping: Now you won’t see the issue that would cause the layers to jump when editing the X value of multiple vertically aligned layers by scrubbing the input label.
  • Issue with file operations: Now you won’t encounter the issue that would prevent file operations—such as saving or zooming—when certain input fields or menus were active.
  • Unintentionally disabled anchor panel: The anchor panel is no longer disabled for children of a component instance that is not placed on an artboard.
  • Issue with editing placement: Trying to move a point at 0,0 using the inspector now works as expected.

Importing & Exporting

  • Improved export performance:
    • Exporting SVG files: You should notice major improvements to Studio’s SVG export capabilities, including support for the line path type and better handling of opacity, corner radius, and gradient fills.
    • Assets that extend their boundaries: You’ll also see improved handling when exporting assets that extend their bounds by shadows or borders.
  • Error handling: Studio now more gracefully handles any errors that occur when importing very large Sketch files.
  • Accuracy of bitmap exports: You’ll see improved accuracy of bitmap exports when a child of a group is anchored to anything other than top-left, a situation that previously could cause issues.
  • Exporting artboards as raster images: When exporting especially large artboards as raster images, you’ll see improved performance.
  • Issue with duplicated artboards: Duplicated artboards now retain the Include in Export setting as expected.
  • Edit multiple layers at once: Now you can edit matching export options of multiple selected layers at the same time.

Components

  • Unintended ability to paste a page into a component definition: Corrected a scenario that could have allowed you to paste an entire page into a component definition.
  • Removed unnecessary icons: When editing a master component, you will no longer see the Back and Add Page icons, which were defunct and unnecessary.
  • Issue with component instances not updating: You will no longer experience an issue that would prevent component instances from updating after editing or swapping nested components in the component definition.
  • Issue with text overrides: Your text overrides on a component instance will now get added to the undo/redo history as expected.
  • Issue swapping nested component instances: Swapping component instances that are nested multiple levels deep now behaves as expected.
  • Improvement to nested components: You can now include nested components in groups created in a component definition.
  • Issue with detaching a component instance: Detaching a component from its definition no longer results in unexpected layer positioning when the child layers are constrained to something other than the top left.
  • Unresponsive inspector panel: The inspector panel will no longer become unresponsive after swapping a component instance.

Basic Interactions & Advanced Animations

  • Issue with timing in motion editor: You will no longer encounter an issue that prevented a layer’s duration and delay settings from getting reflected accurately in the motion editor.
  • Issue with interaction panel: Opening the list of triggers in the interaction panel no longer causes the position of the interaction panel to jump.

Previewing Prototypes

  • Unwanted positioning of layers: You won’t run into the issue that caused some layers to get positioned unexpectedly after resizing or zooming the preview window.
  • Issue with cursor when previewing: Using the arrow keys when previewing a prototype and trying to edit the size of a custom device using the input fields now moves your cursor as expected, instead of controlling the prototype.
  • Unwanted hotspot boundary visibility: You will no longer see a brief flash of the blue hotspot boundaries on the target artboard when interacting with a prototype that uses a double-click trigger.
  • Issue with viewport size: Setting a custom viewport size in the preview window will no longer automatically switch over to Auto if the height or width is larger than 1200px.

Publishing Prototypes

  • Issue with artboard backgrounds: Publishing artboards or sending them to Freehand will now always include the artboard background.
  • Issue with copy in Freehand publishing flow: You will no longer see the inaccurate copy that was in the Freehand publishing flow.
  • Improved error handling and state preservation: When publishing to Freehand, you may notice the improved handling of errors and preserving states.

Studio version 0.96.1

Improvements & Bug Fixes

  • Font rendering on published prototypes: You should no longer encounter the font rendering issue introduced with version 0.96.0. That issue impacted published prototypes that included non-system fonts, causing them to render incorrectly on the web.

Studio version 0.96.0

What's New

  • New publishing workflow: The publish modal now includes a preview area as well as everything you need to configure the viewport, scaling, and appearance options for your prototype. You can also publish right from the preview modal now.
  • New zooming option: Switching between zooming relative to the center of the canvas or the center of a selected layer is now possible.
  • Override typography colors: Override typography colors on component instances.

Improvements & Bug Fixes

  • Masking behavior:
    • Studio now uses the bottom-most layer to create the mask.
    • Layers that cannot be made into a mask (e.g., images) no longer offer the mask option in the tool bar.
    • Now you can create components from masked layers.
  • Components:
    • When adding center or outside borders to component children, you should no longer experience the issue that that caused size of the master component to render incorrectly in edit mode.
    • When editing a component master, you can now access export settings in the inspector.
    • After renaming a component definition of a nested component, you should now be able reorder the component definition in the layers panel.
    • Updating the name of a layer in a component definition should now update the layer name of its instances as expected.
    • When detaching components, you should no longer see layers moving around unexpectedly, rotating incorrectly, anchoring incorrectly, or sometimes disappearing altogether.
    • When creating components, the auto-layout behavior will now use offset anchoring instead of percentage-based dimensions.
  • HSL color issues:
    • Changing the saturation value in the HSL color picker no longer also modifies the hue.
    • Nudging the HSL color input fields using the arrow keys now sets the new value as expected.
    • When using the color picker, the hue slider no longer shifts slightly when adjusting the shade.
  • Alignment issues:
    • Text layers inside a component with anchoring overrides now animate based on the correct anchor point.
    • The X and Y values fare now updated more consistently during undo and redo as well as when using the alignment options.
  • Importing or pasting from Sketch: 
    • The issue that prevented you from pasting content from some .sketch files into Studio (even though you could import those files) has been corrected.
    • Layers imported from Sketch that aren’t part a group or artboard are now imported in the correct order.
    • Layers pasted into Studio from Sketch are now positioned as expected, rather than always being placed in the center of the viewport.
    • Artboards pasted into Studio from Sketch are now positioned as expected.
    • You may notice that we've added support for importing symbol overrides from older versions of Sketch.
    • Layers imported from Sketch with an angular gradient fill, which is not supported in Studio yet, now get their default fill color from the first gradient stop.
    • Artboards imported from Sketch are now using the expected active or inactive background settings.
  • Importing and Exporting SVGs: 
    • SVG imports that have shapes with no fill defined now default to black.
    • You may notice the improvements to our SVG import, including more complete support for the line element.
    • Exporting to SVG now respects the setting for whether or not to include the artboard background in the export.
  • Rendering issues: 
    • You should no longer encounter rendering errors when subtracting a rectangle at certain angles from an oval that has a border.
    • Rendering has been improved for joined paths created with the pen tool and when combining shapes.
  • Publishing: 
    • Publishing a prototype to InVision without a device viewport set was throwing a number of errors that we've fixed with this release.
    • When updating the viewport size in the app after publishing to InVision, you will now see the size updated as expected on the web.
    • You'll notice improved support for publishing large Studio files to InVision.
  • Shortcuts: 
    • You should no longer encounter the issue that was preventing some shortcut keys from working (until pressing the Esc key) after dismissing the Sketch import dialog.
    • You can now use Command + Option + G to create a new container from the selected objects.
    • You will now see keyboard shortcuts included in tooltips wherever applicable.
  • Combined shapes: 
    • You won't run into the issue that prevented creation of combined shapes after undoing any combined shape action on the same path.
    • Performance has been improved for resizing combined shapes.
    • Combined shapes that end up with no children will now get deleted as expected.
  • Duplication issue: Duplicating artboards or pages no longer un-links layers connected by a Motion interaction.
  • Failed interactions in preview: After deleting an artboard that has an interaction, you will no longer experience the issue that prevented subsequent interactions from getting triggered in the preview modal.
  • Layout and guides: 
    • You can now set a total width for your layout columns.
    • The input fields for layout guides and grids can no longer accept invalid or negative values.
    • Columns, rows, and grids are now available when editing a component master.
    • The behavior of smart guides when drawing has been improved.
    • Layout settings are no longer reset after the artboard orientation is changed.
  • Inserting images: You won't experience the issue that previously prevented you from inserting image layers when the layers panel has to scroll.
  • Motion editor: 
    • Studio will now round to two decimal places for the range sliders in the motion editor (rather than using the 17 decimal places that had been unintentionally used sometimes).
    • Images dragged into the motion editor no longer create new image layers in the editor.
  • Layers Panel:
    • The layers list no longer jumps to re-center on a selected layer.
    • The hit area on certain icons in the layers panel has been expanded.
    • We no longer copy the corner radius value when copying layer styles (this can be done on the canvas as well as in the layers panel).
  • Tooltips position: When drawing while zoomed in on the canvas, the tooltips are now positioned correctly.
  • Fonts: The list of document fonts are now updated right away, rather than not getting updated until after selecting another layer.
  • Closing empty files: Studio will no longer prompt you to save when closing an empty file, including one created with a blank artboard selected from the Studio launcher.
  • Updating Studio: There is a new visual indicator to let you know when an update is available.
  • Learning Studio: The 'Learn Studio' link now takes you to our new learning center.
  • Cursor flickering: The cursor no longer flickers slightly when hovering over certain tools.

Studio version 0.95.6

Improvements & Bug Fixes

  • Opening older Studio files: Certain files created in older version of Studio were not opening properly in version 0.95.5. This release has corrected that bug, which was caused by invalid or missing data in a component instance override.

Studio version 0.95.5

Improvements & Bug Fixes

  • Pasting nested components: This release correctly renders nested components that are copied and pasted.

Studio version 0.95.3

What's New

  • Freehand: You can now publish your Studio artboards to Freehand for real-time collaboration and feedback. Present, draw, comment, edit, and more in Freehand.
  • Auto viewport: The new Auto viewport mode lets you share more immersive and realistic prototypes.
  • New motion curve options: Bounce and elastic motion curves have been added to the motion editor for quick access to more dynamic animation timing.

Improvements & Bug Fixes

  • Seemingly empty files: This release fixed an issue that caused Studio files saved in the motion editor to later open using the wrong scroll position, which made the files appear to be empty.
  • Improved animation support: Studio now supports animation of inner shadows, multiple shadows, borders of any type, and border fills.
  • Fade In transitions: You will no longer encounter unexpected behavior when animating between artboard fills using the Fade In transition.
  • Abandoned swipe gesture: Interactions and transitions now behave as expected following an abandoned swipe gesture.
  • Editing X and Y values: You can now access the X and Y position for selected anchor points so you can directly edit the values in the inspector.
  • Editing component definitions: Now you can edit the component definition even when you have selected a child layer within a component.
  • Modifying borders of combined shapes: We improved the handling of collinear points during convex hull calculations, so Studio will no longer crash when you’re modifying the borders of a combined shape.
  • Duplicating nested component instances: Studio now offers better support for duplicating or copying nested component instances, especially between pages and Studio files.
  • Unintended reset of component overrides: Component overrides are no longer reset when you duplicate, copy and paste, or detach them.
  • Shortcut improvement: Using Shift + Click on a component now selects the component instead of expanding it.
  • Grouping and un-grouping pinned layers: Now when grouping or un-grouping your pinned layers, the layers will remain in their expected position/s.
  • Offset data for text fields: You should notice improved handling of offset data for text fields created in older versions of Studio.
  • Crashing when editing: We have added checks to prevent a crash when switching back and forth between editing a component definition and working in the editor.
  • Component child layer visibility: All child layers of a component are now visible at all times when editing a nested component definition.
  • License acknowledgement: You will now see third-party license acknowledgements in the Help menu.
  • Component background handling: 
    • Backgrounds in a component definition that have been set to not be included in instances of that component are now appropriately ignored.
    • You will no longer encounter a bug that required you to move a component instance (after opening a file) before Studio would render the component's background fill.
  • Vertical scrolling with fixed layers: You may notice several improvements to vertical scrolling of fixed layers that aren’t at the top of the layers list.
  • Overrides for nested components: This release solves an issue that affected nested components that had been overridden and replaced with different child component, preventing the parent component from being copied, pasted, or duplicated.
  • Pasting nested components: This release also solved an issue that caused the copy and paste function to stop working when nested components were not getting properly reset after the component definitions were destroyed.
  • Pasting rich text: You may notice the improved handling of copying rich text from one Studio file and pasting to another Studio file.
  • Gradient fills for groups: Gradient fills can now be used on groups as expected.
  • Copying text from a component name field: You can no longer encounter a crash that could previously occur when trying to copy text from the name field of a component.
  • Zoom to Selection: This function now uses the actual bounds instead of the visible bounds for masked layers.
  • Navigating the font selector: You may notice the improved navigation behavior of the font selector.
  • Resizing layers: The latest release offers better handling of layers when resized with negative height and width values.
  • Layout issues when creating components: This release resolved some unexpected layout issues when creating a component from layers pinned to top/bottom and left/right.
  • Looping animation during playback: In some cases, like when the artboard was changed during playback, the preview window could get stuck in a looping animation. This issue has been solved.
  • Positioning detached layers of a component: This release fixed several issues that would cause layers detached from a component to end up with unexpected positioning.
  • Export options: You will no longer see export options for individual layers selected inside a component instance, because exporting those layers is not currently supported.
  • SVG exports: Adding multiple SVG exports to a layer no longer increments the size, because that’s not how SVGs should work.
  • Container layer icon: You will notice a new layer icon for containers, so you can tell which behavior to expect at a glance.
  • Shortcut fix: Alt + Drag now works as expected for containers
  • Bounding boxes: When dragging or resizing children of a component, group, or container, we now show an outline of the parent’s bounding box to provide additional context.
  • Range bug: This release fixed a bug where dragging the ranges of multiple layers too far to the right would put the ranges in a very unexpected state.
  • Custom device sizes in preview: This release fixed an issue that was preventing you from setting a custom device size when previewing your prototype.
  • Layers list issue: When you click a layer, the layers list scrolls so it is visible—now this works for Command + Click as well as Shift + Command + Click.
  • Boolean operations: These operations are now disabled when you only have one layer selected since you can’t combine a single shape.
  • Page deletion improvement: When you are prompted to confirm deleting a page, we now include the name of the page being deleted.
  • Menus and keyboard shortcuts: We cleaned up the menus and added a bunch of new keyboard shortcuts for navigating the layers panel, working with text layers, pinning, zooming, selection, combining shapes, alignment, and distribution.
  • Accessing recent files: The ten Studio files you opened most recently are now accessible under the File menu.
  • Italic font: You will see a new italic font menu item and can use the keyboard shortcut Command + I to apply italics.
  • Switching tools: You can now switch to the selector tool from the pen tool by pressing V.
  • Setting layer opacity: Now you can set the opacity of a layer using hotkeys even when the inspector is hidden.
  • Sign Out/In menu items: The Sign Out and Sign In menu items now accurately reflect your current status.
  • Creating a new page: You will now see an icon to create a new page from the layers panel.
  • Efficiency improvement: Now Studio saves your most recently used interaction trigger type so you can prototype faster.
  • New icons: You will see new app and file icons, and we updated the icons for layer alignment so they are easier to understand at a glance.
  • Exporting background fills: The Include in Export option is now only visible if there is a background fill to include in the first place.
  • Recent files in Studio launcher: We improved the empty state of the recent files list in the launcher.
  • macOS close window button: This button now accurately reflects the file’s saved status.
  • Studio tutorials: There are updated tutorial files to use.

Studio version 0.94.20

What's New

  • Containers: Now you can set any group to behave like a container for the layers inside—making Studio's responsive design capabilities even more powerful. Think of a container as a mini-artboard within an artboard.
  • Copy & Paste interactions: You can now copy and paste your interactions from the Inspector panel.
  • Text formatting shortcuts: Use keyboard shortcuts to quickly reformat text. These include shortcuts for applying and removing bold font, changing font size, and text alignment.
  • Decimals for corner radius: You can now use decimal values when editing the radius of a corner.
  • Retained environment details: Studio will now open with the same zoom level, canvas position, and last viewed page as when you last close the app, so you can get back to work more quickly.

Improvements & Bug Fixes

  • Border properties: Changing the properties of multiple borders selected at once now works as expected.
  • Corner radius discrepancy: Editing a path with a single corner radius now matches the radius set in the editor.
  • Scrubbing with the Rotate label: Using the scrubber for the Rotate label will now rotate groups, components, combined shapes, masks, and images as expected.
  • Moving & maximizing window: The draggable area in the top bar is larger than before, so you can move or maximize your window without needing to be so precise.
  • SVG exports: Images and image fills are now included when exporting an SVG.
  • Inspector panel unexpectedly locking: You will no longer encounter the issue that was, in some cases, causing the Inspector to lock up when selecting the artboard layer of a component definition.
  • Hidden Auto Link Layers button: The Auto Link Layers button is no longer hidden in the timeline editor when the Inspector panel is visible.
  • Hidden layers panel: The bottom of the layers panel no longer gets covered up when resizing the Studio window to fit on smaller monitors.
  • Boolean path operations: The boolean path operations have been disabled when an artboard is selected, because the operations are not useful in such cases.
  • Combined shapes: 
    • The handling of combined shapes has been improved so you will no longer see that result in invalid or invisible shapes.
    • There is more consistency when combining complex shapes, especially using the inverse operation.
    • The combined shape operations have been disabled when open paths are selected.
  • Pinned, nested groups: Ungrouping a nested group that is pinned to anything other than the top-left now works as expected.
  • Scaling of nested components: Nested components where both the child and parent components are set to use percentage-based width or height now scale with the proper relative size.
  • Detaching components with percentage-based width: You will no longer run into the issue that caused unexpected sizes and multiple undo steps when detaching a component with percentage-based width.
  • SVG exports: The fidelity and accuracy of SVG exports has been improved.
  • Zero-pixel width text areas: It is now considerably harder to accidentally draw a zero-pixel width text area.
  • Swapping components: You will no longer see the issue that prevented the swapping of components after pasting or duplicating them.
  • Overrides and fill colors for pasted components: You can now apply overrides and fill colors as expected to pasted components.
  • Anchor point behavior: Now you can change the anchor point behavior for the starting point and ending point of open paths.
  • Point and path selection: The hit area for point and path selection in the editor is bigger now.
  • Editing a gradient stop: It's now easier to edit a gradient stop when zoomed in.
  • Keyboard shortcuts: Studio now supports keyboard shortcuts using the extended numeric keypad.
  • Scrolling through expanded components: The handling of scrolling when viewing expanded components in the layers list has been improved.
  • Checking for updates: When clicking the Check for Updates option in the InVision Studio drop-down menu, you will now see whether Studio is up to date or you need to download a newer version.
  • Unintentionally resetting component names: Component names no longer reset if you click the Go to Component Master checkbox.
  • Copying & pasting: Now you can copy and paste within artboards when the Library panel is visible.
  • Keyboard shortcuts for character spacing: These shortcuts have been updated:
    • Increase character spacing: Alt + Control + L
    • Decrease character spacing: Alt + Control + T

Getting Started: Release Notes (
)

Release Notes: Studio

Prev