Skip to main content
InVision Support Home Page

Are there keyboard shortcuts for Studio?

InVision Studio has quite a few keyboard shortcuts to streamline your design work. See all the Studio shortcuts in the various tables below.

 

Tools

Action Mac Windows Menu Item
Selector V V Tools > Selector
Rectangle R R Tools > Rectangle
Rounded Rectangle U U Tools > Rounded Rectangle
Ellipse O O Tools > Ellipse
Path (pen tool) P P Tools > Path
Artboard A A Tools > Text
Image I I Tools > Image
Text T T Tools > Artboard

 

Selection

Action Mac Windows Menu Item
Dive Into Group Return Enter N/A
Delete Selection Delete Delete Edit > Delete
Climb Out of Group Escape Escape N/A
Select All Cmd-A Ctrl-A Edit > Select All
Select All Artboards Shift-Cmd-A Shift-Ctrl-A Edit > Select All Artboards
Select Sibling Tab Tab N/A
Select Layer Within Scope Click Click N/A
Direct Select Child Cmd-Click Ctrl-Click N/A
Cut Cmd-X Ctrl-X Edit > Cut
Copy Cmd-C Ctrl-C Edit > Copy > Copy
Copy Style Opt-Cmd-C Alt-C Edit > Copy > Copy Style
Paste Cmd-V Ctrl-V Edit > Paste > Paste
Paste Style Opt-Cmd-V Ctrl-Alt-V Edit > Paste > Paste Style
Paste In Place Shift-Cmd-V Shift-Ctrl-V Edit > Paste In Place
Paste And Replace Shift-Opt-Cmd-V Shift-Ctrl-Alt-V Edit > Paste And Replace
Paste Image as Fill Ctrl-Opt-V Shift-Alt-V Edit > Paste > Paste Image As Fill
Duplicate Cmd-D Ctrl-D Edit > Duplicate
Add or Remove Siblings and Parents To or From Selection Shift-Click Shift-Click N/A
Add or Remove Bottom Most Layers To or From Selection Shift-Cmd-Click Shift-Ctrl-Click N/A
Duplicate to New Position Opt-Drag Alt-Drag N/A
Select Layer Above Ctrl-↑ [ N/A
Select Layer Below Ctrl-↓ ] N/A
Select Up Ctrl-Shift-↑ Shift-[ N/A
Select Down Ctrl-Shift-↓ Shift-] N/A

 

Layers

Action Mac Windows Menu Item
Set opacity to 10% 1 1 N/A
Set opacity to 20% 2 2 N/A
Set opacity to 30% 3 3 N/A
Set opacity to 40% 4 4 N/A
Set opacity to 50% 5 5 N/A
Set opacity to 60% 6 6 N/A
Set opacity to 70% 7 7 N/A
Set opacity to 80% 8 8 N/A
Set opacity to 90% 9 9 N/A
Set opacity to 100% 0 0 N/A
Decrease Width by 1 Cmd-← Ctrl-← N/A
Increase Width by 1 Cmd-→ Ctrl-→ N/A
Decrease Height by 1 Cmd-↑ Ctrl-↑ N/A
Increase Height by 1 Cmd-↓ Ctrl-↓ N/A
Decrease Width by 10 Shift-Cmd-← Shift-Ctrl-← N/A
Increase Width by 10 Shift-Cmd-→ Shift-Ctrl-→ N/A
Decrease Height by 10 Shift-Cmd-↑ Shift-Ctrl-↑ N/A
Increase Height by 10 Shift-Cmd-↓ Shift-Ctrl-↓ N/A
Flip Horizontally Shift-H Shift-H Layer > Flip Horizontal
Flip Vertically Shift-V Shift-V Layer > Flip Vertical
Group Layers into Container Opt-Cmd-G Ctrl-Opt-G N/A
Group Layers Cmd-G Ctrl-G Arrange > Group Layers
Ungroup Layers Shift-Cmd-G Shift-Ctrl-G Arrange > Ungroup Layers
Rename Layer Cmd-R Ctrl-R N/A
Show or Hide Layer Shift-Cmd-H Shift-Ctrl-H Arrange > Toggle Layer Visibility
Reveal in Layer List Shift-Cmd-J Shift-Ctrl-J N/A
Lock or Unlock Layer Shift-Cmd-L Shift-Ctrl-L Arrange > Toggle Layer Lock
Rotate Shift-Cmd-R Shift-Ctrl-R Layer > Rotate
Collapse All Artboards and Groups Ctrl-Cmd-C Ctrl-Opt-C N/A
Collapse Artboard Layers Ctrl-Shift-← Ctrl-Opt-Shif-← N/A
Expand Artboard Layers Ctrl-Shift-→ Ctrl-Opt-Shift-→ N/A
Use as Mask Ctrl-Cmd-M Ctrl-Opt-M N/A

 

Components

Action Mac Windows Menu Item
Create Component Cmd-K Ctrl-K Layer > Create Component
Edit Component or Enter into Path Edit Cmd-Return Ctrl-Enter Layer > Edit Master
Detach Component Cmd-Ctrl-D Ctrl-Opt-D N/A
Exit Component Editing Mode Cmd-Escape Ctrl-Escape Layer > Return To Instance

 

Prototyping

Action Mac Windows Menu Item
Create Interaction C C Interaction > Create Interaction
Show Connections X X View > Canvas > Show Connections
Play Animation
(while in Timeline)
Spacebar Spacebar N/A
Open Preview Window Cmd-P Ctrl-P File > Preview
Show Viewport Ctrl-Opt-X N/A View > Canvas > Show Viewport 

 

Layout, Rulers, Smart Guides, and Hover Guides

Action Mac Windows Menu Item
Measure Distance To Hovered Item Opt-Hover Opt-Hover N/A
Measure Distance To Bottom-Most Hovered Item Opt-Cmd-Hover Ctrl-Opt-Hover N/A
Show or Hide Columns Ctrl-L Opt-L View > Layout > Toggle Columns
Show or Hide Rows Ctrl-R Opt-R View > Layout > Toggle Rows
Show or Hide Grid Ctrl-G Ctrl-G View > Layout > Toggle Grid
Show or Hide Rulers Ctrl-G Opt-G View > Canvas > Show Rulers
Show Pixels on Zoom Ctrl-P Ctrl-Opt-Y View > Canvas > Show Pixels on Zoom
Show Pixel Grid on Zoom Ctrl-X Ctrl-' View > Canvas > Show Pixel Grid on Zoom


Alignment

Action Mac Windows Menu Item
Align to Horizontal Center Ctrl-Cmd-H Opt-H Arrange > Align > Horizontally
Align to Vertical Middle Ctrl-Cmd-V Opt-V Arrange > Align > Vertically
Align to Left Ctrl-Cmd-← Opt-A Arrange > Align > Left
Align to Right Ctrl-Cmd-→ Opt-D Arrange > Align > Right
Align to Top Ctrl-Cmd-↑ Opt-W Arrange > Align > Top
Align to Bottom Ctrl-Cmd-↓ Opt-S Arrange > Align > Bottom

 

Pinning

Action Mac Windows Menu Item
Pin to Horizontal Center Ctrl-Opt-H Shift-Opt-H N/A
Pin to Vertical Middle Ctrl-Opt-M Shift-Opt-M N/A
Pin to Left Ctrl-Opt-← Shift-Opt-A N/A
Pin to Right Ctrl-Opt-→ Shift-Opt-D N/A
Pin to Top Ctrl-Opt-↑ Shift-Opt-W N/A
Pin to Bottom Ctrl-Opt-↓ Shift-Opt-S N/A

 

Arrangement

Action Mac Windows Menu Item
Move Forward Opt-Cmd-↑ Opt-Ctrl-↑ Arrange > Forward
Move Backward Opt-Cmd-↓ Opt-Ctrl-↓ Arrange > Backward
Move to Front Ctrl-Opt-Cmd-↑ Ctrl-Opt-Shift-↑ Arrange > Move to Front
Move to Back Ctrl-Opt-Cmd-↓ Ctrl-Opt-Shift-↓ Arrange > Move to Back

 

Distribution

Action Mac Windows Menu Item
Distribute Horizontally Shift-Ctrl-Cmd-H Ctrl-Opt-Shift-H Arrange > Distribute > Horizontally
Distribute Vertically Shift-Ctrl-Cmd-V Ctrl-Opt-Shift-V Arrange > Distribute > Vertically

 

Text

Action Mac Windows Menu Item
Bold Cmd-B Ctrl-B Text > Bold
Italic Cmd-I Ctrl-I Text > Italic
Change Font Cmd-T Ctrl-T Text > Change Font
Underline Cmd-U Ctrl-U Text > Underline
Uppercase Ctrl-Cmd-U Ctrl-Opt-U Text > Uppercase
Lowercase Ctrl-Cmd-L Ctrl-Opt-L Text > Lowercase
Align-Text-Left Shift-Cmd-[ Ctrl-Opt-[ Text > Align Left
Align Text Right Shift-Cmd-] Ctrl-Opt-] Text > Align Right
Align-Text-Center Shift-Cmd-| Ctrl-Opt-| Text > Align Center
Increase Font Size Opt-Cmd-+ Ctrl-Opt-Shift-+ Text > Increase Font Size
Decrease Font Size Opt-Cmd-- Ctrl-Opt-- Text > Decrease Font Size
Increase Character Spacing Ctrl-Opt-L Opt-Shift-Ctrl-L Text > Increase Character Spacing
Decrease Character Spacing Ctrl-Opt-T Opt-Shift-Ctrl-T Text > Decrease Character Spacing

 

Pen Tool, Path Editing, and Combined Shapes

Action Mac Windows Menu Item
Union Selection Opt-Cmd-U Opt Ctrl-U N/A
Subtract Selection Opt-Cmd-S Opt-Ctrl-S N/A
Intersect Selection Opt-Cmd-I Opt-Ctrl-I N/A
Exclude Selection Opt-Cmd-X Opt-Ctrl-X N/A
Enter Path Editing Mode Return Enter N/A
Toggle Selected Point Tab Tab N/A
Delete Point Delete or Backspace Delete or Backspace N/A
Exit Path Editing Escape Escape N/A

 

Editor Window

Action Mac Windows Menu Item
Hide Window Cmd H   InVision Studio > Hide InVision Studio
Minimize Window Cmd-M Win-↓ N/A
Maximize Window   Win-↑ N/A
Filter Layers Cmd-F   Edit > Filter Layers
New Document Cmd-N Ctrl-N File > New
Open Cmd-O Ctrl-O File > Open
Quit Cmd-Q   File > Quit
Save As Shift-Cmd-S Shift-Ctrl-S File > Save As...
Save Cmd-S Ctrl-S File > Save
Close Window Cmd-W Opt-F4 File > Close
Previous Page Cmd-{   View > Previous Page
Next Page Cmd-}   View > Next Page
Change App Window Focus Cmd-~ Ctrl-Tab N/A
Hide Interface Cmd-. Ctrl-. View > Hide Interface
New Page Shift-Cmd-N Shift-Ctrl-N N/A
Import Shift-Cmd-O Shift-Ctrl-O N/A
Hide Others Opt-Cmd-H   N/A
Show Layer List Opt-Cmd-1 Shift-Ctrl-1 View > Show Layer List
Show Inspector Opt-Cmd-2 Shift-Ctrl-2 View > Show Inspector
Hide Layers and Inspector Opt-Cmd-3 Shift-Ctrl-3 View > Hide Layers and Inspector
Search Library Cmd-L Ctrl-L View > Search Library
Enter Fullscreen Ctrl-Cmd-F F11 View > Enter Full Screen

 

Canvas

Action Mac Windows Menu Item
Zoom In Cmd-+ Ctrl-= View > Zoom In
Zoom Out Cmd-- Ctrl-- View > Zoom Out
Center Canvas Cmd-1 Ctrl-1 View > Zoom To > Fit Canvas
Zoom Selection Cmd-2 Ctrl-2 View > Zoom To > Selection
Center Selection Cmd-3 Ctrl-3 View > Center Selection
Zoom to 100% Cmd-0 Ctrl-0 View > Zoom To > Full Size
Scroll to Zoom Z-Scroll or Cmd-Scroll Z-Scroll or Ctrl-Scroll N/A
Pan Canvas Spacebar-Click-Drag Spacebar-Click-Drag N/A

 

Go-To Shortcuts

Action Mac Windows Menu Item
Undo Cmd-Z Ctrl-Z Edit > Undo
Redo
Shift-Cmd-Z Ctrl-Y
Edit > Redo
  Shift-Ctrl-Z
Show Color Picker Ctrl-C Shift-Opt-I N/A
Show Context Menu

Ctrl-Click or
Right-Click

Right-Click N/A
Export Shift-Cmd-E Shift-Ctrl-E File > Export Selection
Send to Freehand Shift-Cmd-F Shift-Ctrl-F File > Send to Freehand
Insert Layer or Add Component Q Q N/A
Was this article helpful?

Still have a question?

Get help